Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Windows 10 a bit reluctant to connect?



  • Pi3b, 2.1A aftermarket power supply
    Retropie 4.3
    Pre made SD Image: retropie-4.3-rpi2_rpi3.img
    1 USB wireless bluetooth keyboard
    2 identical Arcade DragonRise USB joysticks

    Windows 10 Pro 1803

    Whilst my mac connects effortlessly, my Windows 10 PC refused to connect to the pi, until I used WinSCP and logged in with a username and password which gave full access.
    But it appears the share folders are still not working.

    I tried:
    Changing the Wifi network to a 'private' network
    Turning on services
    -Network Discovery, DHCP Client, SSDP Discovery, DNS services, UPNP Device Host,
    Adding Windows Features
    -SMB 1.0 cifs file sharing support (despite security risks)
    (this actually made the pi visible in Explorer but it still wouldn't connect)
    Disabling the Windows firewall
    Restarting the pi and Windows 10
    Double Clicking on RETROPIE in File Explorer
    Entering the //192.168.x.x address
    Entering smb://retropie
    Entering smb://RETROPIE
    Entering smb://192.168.x.x

    ***Tried WinSCP from https://winscp.net/eng/download.php
    - that actually works!



  • That's a Windows problem, the shares are working fine. I have also Win10 1803 Pro (+updates) and I have no problem connecting to RetroPie (4.4.x based on Raspbian Stretch). The correct syntax to use in Windows Explorer is \\retropie, or \\IP_address, not smb://.... There's no need to

    • disable the Windows firewall (that's a bad idea anyway)
    • enable SMB 1.0 (also a bad idea)
    • fiddle with the rest of the network services (DNS/DHCP/UPnP, SSDP, etc).

    Are you sure it's a Win10 Professional edition ? Have you changed your pi user password ?



  • For some off reason it only works for me if im on auto dhcp wont work with a static ip no idea when.



  • @mitu said in Windows 10 a bit reluctant to connect?:

    (4.4.x based on Raspbian Stretch). The correct syntax to use in Windows Explorer is \retropie, or \IP_address, not smb://.... There's no need to

    Thanks, \192.168... and \retropie were tried first, but they did not work..
    I have tried everything I can think of. Firewall and SMB are back to normal now - they were just temporary.

    Yes, I have changed the pi password, but it never asked for a password. The share folders normally need no password.

    I know the ip address is correct, as I checked it using Retropie and it pings ok.

    When you say "fiddle with the rest of the network services (DNS/DHCP/UPnP, SSDP," i'm not sure what else I can do - the pi is getting an IP - it's on the network...

    I think it's just this computer, when things are working normally I don't have any issues connecting to a share folder.

    Out of curiosity I even tried a different wifi router - you never know. It got a new IP address, but still says "Windows cannot access \RETROPIE check the spelling of the name" (yes I used lowercase) and offered its useless 'Diagnose' feature along with an equally useless Microsoft Error: "Error code;0x80004005 Unspecified error" - you've got to love the engineers who write these messages..

    So not sure but will keep my ear to the ground.
    Thanks



  • I also tried disabling IPV6 and running on IPV4.
    Ensured NetBios was on under network adapters.
    Ensured Print and File sharing is on.
    None of this changed anything.



  • Ok there is a clue,
    I can ping the IP address, but not the name "retropie"
    This seems to suggest a DNS problem or no name is being added to the hosts file, wherever that is, perhaps it can be entered manually.
    Also, since I turned off SMBv1 (for security reasons) the retropie doesn't even show up in explorer anymore.



  • @crumbs said in Windows 10 a bit reluctant to connect?:

    When you say "fiddle with the rest of the network services (DNS/DHCP/UPnP, SSDP," i'm not sure what else I can do - the pi is getting an IP - it's on the network...

    Sorry, I meant DON't fiddle with those settings.



  • Lol - okay no probs!



  • @crumbs Enable SMB v2 in Samba - https://www.cyberciti.biz/faq/how-to-configure-samba-to-use-smbv2-and-disable-smbv1-on-linux-or-unix - and see if that works. Is this your home or work computer ?



  • Alright so I found hosts in
    c:\Windows\System32\Drivers\etc\hosts.

    I put in a line:

    retropie <static_ip_address_of_my_pi>
    

    Now I can ping retropie in the DOS window.

    But same rubbish windows message when I try to access the \retropie through WIndows Explorer.

    Uggghh why is it so hard? You'd think I was trying to hack into the government.



  • @mitu thank you. I'm always a little suspicious of a linux how to that suggests I use vi text editor, as though it was natuarally intuitive... ha
    Right now I have no more time for this, wasted all arvo, no more.
    Thanks again.



  • its

    \\192.168.x.x
    not \ and not // x.x will be your ip and dont put it in your we browser windows explorer


  • @grant2258 I realise it's a double slash but this forum kept escaping the slashes and then after 3 edits it locked me out of editing the post because it concluded I must be writing spam!

    :) I can not correct it anymore :).



  • Are you running the most recent version of Windows 10? They removed all the homegroup stuff back in the spring. Smart move on their part since it would also cause issues with non windows shares.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.