Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulationstation detecting controllers that aren't there



  • I'm attempting to set up PS4 controller support using this guide

    https://github.com/RetroPie/RetroPie-Setup/wiki/PS4-Controller

    I can connect the controller via the terminal and I added the script to the rc.local to run on start up but it's not connecting. Emulationstation will also list that controllers are connected that aren't there sometimes after boot.



  • sorry forgot to include this

    Pi model: B+
    Retropie Version 4.4

    I'm using the dsdrv, and my controller omits the "--hidraw"


  • Global Moderator

    You don't need ds4drv, just pair the controller via Bluetooth or normally via an USB cable (if you don't want to play wireless). On the newer kernel version (i.e. newer than Raspbian Jessie), the DS4 shows as 2 controllers - both the gamepad and motion sensors.
    There is a topic about this and a solution if you'd like to disable the motion sensors being detected. This should be used if you want to use multiple controllers. Here is the topic with the solution.



  • @mitu ah, thank you! I had did searching myself but hadn't seen that thread. I'll check it out!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.