Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

New installed emulator not showing in ES



  • Hello,

    I installed retropie on my Pi 3b (2.5A power cable connected) via the latest PINN.

    Then I've added the mxs console via the menu in retropie. Next added roms to the roms folder. But the MSX is not showing in ES.

    I've read these posts but I think the system is right. I tried lr_fmsx and lr_bluemsx.

    https://retropie.org.uk/forum/topic/10689/new-emulators-not-showing-up-despite-adding-roms
    https://retropie.org.uk/forum/topic/7604/newly-installed-emulators-not-displaying-even-with-roms

    I have the roms (.rom files) in
    /home/pi/RetroPie/roms/msx

    And I only have the
    /etc/emulationstation/es_systems.cfg
    (not in home)

    Here the cfg:

      <system>
        <name>msx</name>
        <fullname>MSX</fullname>
        <path>/home/pi/RetroPie/roms/msx</path>
        <extension>.rom .mx1 .mx2 .col .dsk .zip .m3u .ROM .MX1 .MX2 .COL .DSK .ZIP .M3U</extension>
        <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ msx %ROM%</command>
        <platform>msx</platform>
        <theme>msx</theme>
      </system>
    

    What's next to trie? Anyone have an idea?

    Thanx!


  • Global Moderator

    @boomspar Have you restarted Emulationstation after adding the ROMs ? What extension have the ROM files ?



  • Hi, yes. Multiple times. The files are rom-files. Work fine in BlueMSX-emu under Windows.


  • Global Moderator

    @boomspar said in New installed emulator not showing in ES:

    The files are rom-files

    So they have the .rom extension ? Can you show a listing of the msx folder with the files in it ?



  • /home/pi/RetroPie/roms/msx/a1942.ROM
    /home/pi/RetroPie/roms/msx/BALANCE.ROM
    /home/pi/RetroPie/roms/msx/Balloona1.rom
    /home/pi/RetroPie/roms/msx/Billiard.rom
    /home/pi/RetroPie/roms/msx/BOSCONIA.ROM
    /home/pi/RetroPie/roms/msx/BreakIn.rom
    /home/pi/RetroPie/roms/msx/BUBBLE.ROM
    /home/pi/RetroPie/roms/msx/CABBAGE.ROM
    /home/pi/RetroPie/roms/msx/EGGER.ROM
    /home/pi/RetroPie/roms/msx/F1SPIRIT.ROM
    /home/pi/RetroPie/roms/msx/F-PANIC.ROM
    /home/pi/RetroPie/roms/msx/FROGGER.ROM
    /home/pi/RetroPie/roms/msx/FruitSearch.rom
    /home/pi/RetroPie/roms/msx/FUTURE.ROM
    /home/pi/RetroPie/roms/msx/Galaga.rom
    /home/pi/RetroPie/roms/msx/GALAXIAN.ROM
    /home/pi/RetroPie/roms/msx/GALIOUS.ROM
    /home/pi/RetroPie/roms/msx/GOLF.ROM
    /home/pi/RetroPie/roms/msx/GOONIES.ROM
    /home/pi/RetroPie/roms/msx/GRADIUS2.ROM
    /home/pi/RetroPie/roms/msx/GUARDIC.ROM
    /home/pi/RetroPie/roms/msx/HARDBALL.ROM
    /home/pi/RetroPie/roms/msx/HBOXING.ROM
    /home/pi/RetroPie/roms/msx/HBOYS.ROM
    /home/pi/RetroPie/roms/msx/HEAVEN.ROM
    /home/pi/RetroPie/roms/msx/HOLE.ROM
    /home/pi/RetroPie/roms/msx/HOLEPRO.ROM
    /home/pi/RetroPie/roms/msx/IKARI.ROM
    /home/pi/RetroPie/roms/msx/INSPECTZ.ROM
    /home/pi/RetroPie/roms/msx/Kings_Valley_2_MSX2_Gold.rom
    /home/pi/RetroPie/roms/msx/KUNGFU2.ROM
    /home/pi/RetroPie/roms/msx/KVALLEY.ROM
    /home/pi/RetroPie/roms/msx/MADRIDER.ROM
    /home/pi/RetroPie/roms/msx/MONKEY.ROM
    /home/pi/RetroPie/roms/msx/MONKEYAC.ROM
    /home/pi/RetroPie/roms/msx/MOPIRANG.ROM
    /home/pi/RetroPie/roms/msx/MOUSER.ROM
    /home/pi/RetroPie/roms/msx/MRCHIN.ROM
    /home/pi/RetroPie/roms/msx/MRGHOST.ROM
    /home/pi/RetroPie/roms/msx/MUE.ROM
    /home/pi/RetroPie/roms/msx/nemesis.rom
    /home/pi/RetroPie/roms/msx/NEMESIS2.ROM
    /home/pi/RetroPie/roms/msx/nemesis3.rom
    /home/pi/RetroPie/roms/msx/ninja.rom
    /home/pi/RetroPie/roms/msx/OGRE.ROM
    /home/pi/RetroPie/roms/msx/PACMAN.ROM
    /home/pi/RetroPie/roms/msx/PacMania.rom
    /home/pi/RetroPie/roms/msx/PARODIUS.ROM
    /home/pi/RetroPie/roms/msx/PENGUIN.ROM
    /home/pi/RetroPie/roms/msx/PILOT.ROM
    /home/pi/RetroPie/roms/msx/PIPPOLS.ROM
    /home/pi/RetroPie/roms/msx/pooyan.rom
    /home/pi/RetroPie/roms/msx/PROTECT.ROM
    /home/pi/RetroPie/roms/msx/QBERT.ROM
    /home/pi/RetroPie/roms/msx/RALLYX.ROM
    /home/pi/RetroPie/roms/msx/ROAD.ROM
    /home/pi/RetroPie/roms/msx/ROLLERBA.ROM
    /home/pi/RetroPie/roms/msx/SALAMAND.ROM
    /home/pi/RetroPie/roms/msx/SpaceMazeAttack.rom
    /home/pi/RetroPie/roms/msx/SpaceTrouble.rom
    /home/pi/RetroPie/roms/msx/sparkie.rom
    /home/pi/RetroPie/roms/msx/SuperSnake.rom
    /home/pi/RetroPie/roms/msx/TANK.ROM
    /home/pi/RetroPie/roms/msx/tennis.rom
    /home/pi/RetroPie/roms/msx/TWINBEE.ROM
    /home/pi/RetroPie/roms/msx/VAMPIRE.ROM
    /home/pi/RetroPie/roms/msx/VIRGIN.ROM
    /home/pi/RetroPie/roms/msx/WIZ.ROM
    /home/pi/RetroPie/roms/msx/WOODY.ROM
    /home/pi/RetroPie/roms/msx/XEVIOUS.ROM
    /home/pi/RetroPie/roms/msx/ZANAC.ROM
    /home/pi/RetroPie/roms/msx/ZANACEX.ROM
    
    

  • Global Moderator

    @boomspar The listing looks fine - the files are named according to the extension configured. Do you by any chance have toggled the Parse Gamelists Only option in Emulationstation ? If it's on, then ES only reads the existing gamelist.xml files and doesn't scan for new files.



  • No I didn't touch that. For a test I putted some mame roms in the mame folder and snes in the snes folder and YES 2 systems showing up in the menu. But still no MSX.

    I already tried to remove them - reboot - reinstall - reboot. Tried it for fmsx and bluemsx...


  • Global Moderator

    @boomspar How did you copy them ? Have you used the root account, maybe Emulationstation cannot read the ROMs. Can you paste the ES log file from (/home/pi/.emulationstation/es_log.txt) ?



  • No I didn't use/activate the root account.
    MSX is not in the logging..

    lvl2: 	EmulationStation - v2.7.5rp, built Feb 27 2018 - 18:11:47
    lvl2: 	Creating surface...
    lvl2: 	Created window successfully.
    lvl2: 	Added unconfigured joystick MOSIC      SPEED-LINK Competition Pro  (GUID: 030000000b0400003365000000010000, instance ID: 0, device index: 0).
    lvl2: 	Checking available OpenGL extensions...
    lvl2: 	 ARB_texture_non_power_of_two: MISSING
    lvl2: 	Loading system config file /home/pi/.emulationstation/es_systems.cfg...
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/amstradcpc/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/amstradcpc/../carbon.xml")
        could not find file "" 
    lvl1: 	System "amstradcpc" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/arcade/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/arcade/../carbon.xml")
        could not find file "" 
    lvl1: 	System "arcade" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/atari2600/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/atari2600/../carbon.xml")
        could not find file "" 
    lvl1: 	System "atari2600" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/atari5200/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/atari5200/../carbon.xml")
        could not find file "" 
    lvl1: 	System "atari5200" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/atari7800/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/atari7800/../carbon.xml")
        could not find file "" 
    lvl1: 	System "atari7800" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/atari800/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/atari800/../carbon.xml")
        could not find file "" 
    lvl1: 	System "atari800" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/atarilynx/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/atarilynx/../carbon.xml")
        could not find file "" 
    lvl1: 	System "atarilynx" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/fba/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/fba/../carbon.xml")
        could not find file "" 
    lvl1: 	System "fba" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/fds/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/fds/../carbon.xml")
        could not find file "" 
    lvl1: 	System "fds" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/gamegear/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/gamegear/../carbon.xml")
        could not find file "" 
    lvl1: 	System "gamegear" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/gb/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/gb/../carbon.xml")
        could not find file "" 
    lvl1: 	System "gb" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/gba/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/gba/../carbon.xml")
        could not find file "" 
    lvl1: 	System "gba" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/gbc/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/gbc/../carbon.xml")
        could not find file "" 
    lvl1: 	System "gbc" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/mame/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/mame/../carbon.xml")
        could not find file "" 
    lvl1: 	System "mame-libretro" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/mame/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/mame/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/mastersystem/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/mastersystem/../carbon.xml")
        could not find file "" 
    lvl1: 	System "mastersystem" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/megadrive/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/megadrive/../carbon.xml")
        could not find file "" 
    lvl1: 	System "megadrive" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/n64/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/n64/../carbon.xml")
        could not find file "" 
    lvl1: 	System "n64" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/neogeo/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/neogeo/../carbon.xml")
        could not find file "" 
    lvl1: 	System "neogeo" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/nes/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/nes/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/ngp/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/ngp/../carbon.xml")
        could not find file "" 
    lvl1: 	System "ngp" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/ngpc/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/ngpc/../carbon.xml")
        could not find file "" 
    lvl1: 	System "ngpc" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/pcengine/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/pcengine/../carbon.xml")
        could not find file "" 
    lvl1: 	System "pcengine" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/psx/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/psx/../carbon.xml")
        could not find file "" 
    lvl1: 	System "psx" has no games! Ignoring it.
    lvl2: 	Parsing XML file "/home/pi/.emulationstation/gamelists/retropie/gamelist.xml"...
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/retropie/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/retropie/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/sega32x/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/sega32x/../carbon.xml")
        could not find file "" 
    lvl1: 	System "sega32x" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/segacd/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/segacd/../carbon.xml")
        could not find file "" 
    lvl1: 	System "segacd" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/sg-1000/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/sg-1000/../carbon.xml")
        could not find file "" 
    lvl1: 	System "sg-1000" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/snes/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/snes/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/vectrex/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/vectrex/../carbon.xml")
        could not find file "" 
    lvl1: 	System "vectrex" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/zxspectrum/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/zxspectrum/../carbon.xml")
        could not find file "" 
    lvl1: 	System "zxspectrum" has no games! Ignoring it.
    lvl1: 	  Unknown platform for system "kodi" (platform "kodi" from list "kodi")
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/kodi/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/kodi/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/auto-allgames/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/auto-allgames/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/auto-favorites/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/auto-favorites/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/auto-lastplayed/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/auto-lastplayed/../carbon.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/carbon/custom-collections/theme.xml"
      (from included file "/etc/emulationstation/themes/carbon/custom-collections/../carbon.xml")
        could not find file "" 
    lvl2: 	 req sound [basic.launch]
    lvl2: 	   (missing)
    lvl2: 	Attempting to launch game...
    lvl2: 		/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ snes /home/pi/RetroPie/roms/snes/Top\ Gear\ 2\ \(U\)\ [\!].zip
    lvl2: 	Creating surface...
    lvl2: 	Created window successfully.
    lvl2: 	Added unconfigured joystick MOSIC      SPEED-LINK Competition Pro  (GUID: 030000000b0400003365000000010000, instance ID: 0, device index: 0).
    lvl2: 	Added unconfigured joystick MOSIC      SPEED-LINK Competition Pro  (GUID: 030000000b0400003365000000010000, instance ID: 0, device index: 0).
    
    

  • Global Moderator

    The log doesn't show any fatal errors, but I can't find a reason for the problem. You can try using the RetroPie's own image from retropie.org.uk/download, instead of the PINN provided one.



  • I know you mentioned not having an additional es_systems.cfg in your original post ... but can you check this location (you mentioned not in home so I just wanted to make sure you've checked the proper secondary location)?

    /opt/retropie/configs/all/emulationstation

    If you've added the emulators, the entry is in the /etc/emulationstation/es_systems.cfg, and you've added roms with the appropriate extension, that's the only other thing I can think of after the other suggestions above.



  • @boomspar make sure you’re not using a custom essystems.cfg file. If you did a custom one to reorder systems, it will not update when adding new systems, you have to manually add them in.



  • @dmmarti that did the job!

    I had an older version of es_system.cfg in /opt/retropie/configs/all/emulationstation.

    So I copied the /etc/emulationstation/es_systems.cfg to this loaction then restarted the system and THERE THEY ARE.

    But for my understanding.. are there more files to be copied to here for proper operation?


  • Global Moderator

    @boomspar said in New installed emulator not showing in ES:

    I had an older version of es_system.cfg in /opt/retropie/configs/all/emulationstation.

    And you said that you don't have a custom config file in your home...

    But for my understanding.. are there more files to be copied to here for proper operation?

    You should not copy anything, the system es_systems.cfg file is kept up to date by the RetroPie setup script - when you add a new emulator, the corresponding folder is created under ~/RetroPie/roms and the necessary entries are added in the ES config file also. If you copied the ES config file in your home and customized it - as described in the docs - then you can have a 2nd config file, which is NOT updated by the RetroPie setup script and that you can manually maintain.



  • I didn't saw any file in /home. But instead so in /opt.

    I think I am a little confused.
    So what can I do to make it proper working.

    I will restore the file in /opt and then what's the best way to do?

    ps. I didn't manualy edit files. I following steps out of the es-gui -->

    • Retropie - configuration
    • retropie setup
    • P Manage packages
    • opt Manage optional packages
    • 211 lr-bluemsx
    • S Install from source

  • Global Moderator

    Jus remove the file in /opt/retropie/configs/all/emulationstation and the system (/etc/emulationstation/es_systems.cfg) will take over.

    When you said 'you don't have a file in your home', I meant to understand you don't have a custom es_systems.cfg file $HOME/.emulationstation. The folder $HOME/.emulationstation is the same as /opt/retropie/configs/all/emulationstation, so you must have added that file yourself - as per the docs page I mentioned - at some point, but your forgot about it.



  • @mitu Maybe @boomspar didn't notice $HOME/.emulationstation because it is a hidden directory? (i.e. beginning with a ".", just mentioned for others here)



  • Yes I didn't notice at first and discovered this morning indead that it was the same when I did a global search.

    Maybe the PINN installation did make it.

    I deleted it rebooted and MSX is showing, so thanx. But then... the roms wil not load. Returning to ES again.

    runcommand.log:

    Parameters: 
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-bluemsx/bluemsx_libretro.so --config /opt/retropie/configs/msx/retroarch.cfg "/home/pi/RetroPie/roms/msx/FROGGER.ROM" --appendconfig /dev/shm/retroarch.cfg
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 1006:   978 Segmentation fault      /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-bluemsx/bluemsx_libretro.so --config /opt/retropie/configs/msx/retroarch.cfg "/home/pi/RetroPie/roms/msx/FROGGER.ROM" --appendconfig /dev/shm/retroarch.cfg
    
    

    So I tried removing all the roms and put in one rom I know normally worked in ES. Reboot and again not showing up the game.


  • Global Moderator

    Looks like a bad ROM or missing BIOS files - see the MSX Emulators doc page.



  • Isn't it weird ; I followed the normal steps below and install does require manual steps...

    Retropie - configuration
    retropie setup
    P Manage packages
    opt Manage optional packages
    211 lr-bluemsx
    S Install from source

    or is that right?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.