Please do not post a support request without first reading and following the advice in

Retropie Configuration Screen Not Responding

  • Pi Model or other hardware: Zero
    Power Supply used: 5v Canakit
    RetroPie Version Used: 4.4
    Built From: Pre-made SD Image on RetroPie website
    Controller used: Logitech F310

    Hi, this is my first time working with the raspberry pi zero and retropie so I apologize if I'm overlooking a simple fix. I bought my raspberry pi zero as a bundle from Canakit. When I boot up retropie for the first time I am unable to successfully configure my controller. It recognizes my controller when it asks me to press and hold any button at the start, a couple times it's even allowed me to enter in a handful of buttons after that, but it will ultimately just become unresponsive. I've tried turning it off and on again and reinstalling retropie but neither has worked. I also have a rpi 3 with retropie which the Logitech controllers work fine with.

    Any advice is much appreciated as I'm not sure what else to try at this point.

  • Global Moderator

    @mace_in_space How are you connecting the controller to the PI ? Maybe your USB hub is not properly working with the Zero and the controller gets disconnected. Or are you using an adapter to get it connected ?

  • @mitu I'm using a micro USB adapter to plug in the wired controllers. I tried the adapter out on another device and it seems to work fine. I also just tried out my wired keyboard and I'm getting the same issue. It recognizes the keyboard when I initially press a key but a couple seconds later it completely stops.

  • Global Moderator

    @mace_in_space Does the keyboard work outside Emulationstation ? Try exiting ES and then running some commands from the CLI. Are any error/warnings logged by the system (dmesg) during this time ?

  • @mitu I'm still so new to this so I'm not very familiar with running commands... I was able to shut down the rpi by with "$ sudo shutdown -h now" and it worked correctly. No errors or warnings.

  • @mitu So because of this, would it be safe to assume it's not a hardware problem and instead something going on with emulation station? Btw, I really appreciate the help.

  • Global Moderator

    @mace_in_space I can't say it's an Emulationstation problem - on the contrary, this seems something specific to the PI zero configuration you have. If it's hardware or not, you haven't posted a log file to see what's behind (i.e. USB disconnects, resets, etc.).
    To get the system's log file, run

    dmesg > ~/RetroPie/roms/dmesg.txt`

    then copy the dmesg.txtcontents to so we can take a look. Also, a log file from Emulationstation would be useful (the file is in ~/.emulationstation/es_log.txt).

  • @mitu Sorry about that. I wasn't sure how to post the log file. So I ended putting some soldering some pins on it and putting it in a freeplay zero. I wiped the sd card and added the freeplay modded retropie (That was before I saw your post asking for the log file...). Weirdly enough a somewhat similar issue occurred again. The buttons stop responding and the pie pops up errors. Since I wiped the previous log and I can't access get my keyboard to work on the gba I don't think I can provide much to you. I talked to Ed from Freeplay and he suggested some things to try out. If it doesn't work I'm going to just try out a new raspberry pi and see if that's the problem. Thanks for taking the time to try and help me troubleshoot.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.