Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Updated Retropie and now having controller problems in retroarch



  • Raspberry pi 3 B+

    Hi I'm fairly new to using retropie just got mine set up and added some stuff to it. Yesterday I went into retropie setup script then I updated the script then on that same little grey box I did an update and then I think I did a basic install. After that a black screen came up and a bunch of commands started scrolling down for a little bit and then I got back on and everything was running fine until I got into one of my games and I found out the controller setup that I had on retroarch was not the same. Instead of just being user 1 and 2 like it was before it added users 4 and 5 and auto before the controller . when I had it set up for my Microsoft Xbox One controller which I'm using the Plug and Play kit USB cord to use the Xbox controller I had set up retroarch before so that the commands on the buttons were perfect. now I have all these button inputs multiple ones with "Auto" in front of them. I scrolled past all the auto and set the controller back up the way I would like it for the fighting game that I was playing and then told it to save game remap for it to save that controller the way I had it before just like the last time when I first set it up but now it won't accept the controller set up that I put in. If I go through all the auto options before it hits the actual buttons for the controller that I have and I make them as if they don't have any button inputs on them with the little dotted line then it becomes completely unresponsive. Only other problem that I can see the also the aspect ratio also won't stay the same one that I keep setting it up for. I'm trying to keep from having to put a fresh install retropie on the fix this, anyone know how to fix this? Thank you


  • Global Moderator

    Please add more info about your system , as described in https://retropie.org.uk/forum/topic/3/read-this-first - particularly about your RetroPie version and which image did you use.



  • @mitu could you please explain image and where to find it to me please, thank you

    The version I downloaded was v4.4


  • Global Moderator

    @outlaw52000 said in Updated Retropie and now having controller problems in retroarch:

    The version I downloaded was v4.4

    Where did you downloaded from ? Was is the RetroPie site (retropie.org.uk/download) or somewhere else ?



  • @mitu yes from the retropie site


  • Global Moderator

    Please add more info - what controllers/devices do you have connected ? How are they all connected (USB/Bluetooth) ? How many do you have ?
    Did you use 'Save configuration' in RetroArch or just the input remapping options ?



  • @mitu I stated in the paragraph that I was using a microsoft Xbox One controller and I had it connected using the USB charge and play kit.

    Retroarch, then controls, changed the setting then did the save to game remap



  • I have a similar issue:
    Having 2 PS 3 controllers, yesterday I performed sudo apt-get update and sudo apt-get dist-upgrade.
    After that, the controllers still paired, however auto-logon failed.
    Then I chose to update all packages from the Retropie setup.
    After that I rebooted, and then the controllers didn't pair anymore.

    I will roll back to my last image, anyway I think some mess was being built into the latest update components. Obviously I'm not the only one having logon and controller pairing issues after the recent updates...



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.