Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie Installation on Ubuntu 18.04



  • Hey folks,

    Having issues getting RetroPie installed on Ubuntu. EmulatorStation, RetroArch and a few other packages fail to build. I've enclosed a link to my log file, any solutions would be gratefully received. Ta.

    Chris

    Log File


  • Global Moderator

    Most of your problems come from a functional OpenGL libraries installation. Is there anything in particular that you modified on your system that has replaced/remove your OpenGL libraries and headers ? Did you install any 3rd party software/drivers besides the ones included in the distribution ?



  • @mitu Yep, I replaced the nouveau Nvidia driver with the official driver from the Nvidia website. A mistake I'm assuming?


  • Global Moderator

    @NeoDude Not a mistake, but it seems something is missing. Do you have OpenGL acceleration working ?
    Have you used Ubuntu's installer or did you manually install the driver ? I'd recommend using the Ubuntu's PPA packages to install the drivers or the Ubuntu package management app (Software center ?).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.