Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Missile Command stop working



  • Mame2003 and Missile Command doesn´t start.
    Used to work fine, suddenly no more. Just return to ES menu.

    Runcommand.log below:
    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-mame2003/mame2003_libretro.so --config /opt/retropie/configs/arcade/retroarch.cfg "/home/pi/RetroPie/roms/arcade/missile.zip" --appendconfig /dev/shm/retroarch.cfg'|'"/home/pi/RetroPie/roms/arcade/missile.zip.cfg"


  • Global Moderator

    Works for me with the latest Mame2003 - are you sure you're using the correct ROM ?



  • Yes, because it used to work before... :(



  • @mha Is it just missile command that isnt starting with mame2003? Have you done any updates/changes to your setup recently?


  • Global Moderator

    @mha Maybe your ROM file is corrupted. Run with verbose logging enabled and look in the log (/dev/shm/runcommand.log) to see what errors you get. What is your MAME2003 version ?



  • @mitu not too used to this, but verbose below.
    Have tried to re transfer my rom file...

    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-mame2003/mame2003_libretro.so --config /opt/retropie/configs/arcade/retroarch.cfg "/home/pi/RetroPie/roms/arcade/missile.zip" --verbose --appendconfig /dev/shm/retroarch.cfg
    [INFO] RetroArch 1.7.6 (Git 9750719)
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/arcade/missile.srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/arcade/missile.state".
    [INFO] === Build =======================================
    Capabilities: NEON VFPv3 VFPv4
    Built: Feb 4 2019
    [INFO] Version: 1.7.6
    [INFO] Git: 9750719
    [INFO] =================================================
    [INFO] Loading dynamic libretro core from: "/opt/retropie/libretrocores/lr-mame2003/mame2003_libretro.so"
    [INFO] [overrides] no core-specific overrides found at /home/pi/.config/retroarch/config/MAME 2003 (0.78)/MAME 2003 (0.78).cfg.
    [INFO] [overrides] no content-dir-specific overrides found at /home/pi/.config/retroarch/config/MAME 2003 (0.78)/arcade.cfg.
    [INFO] [overrides] no game-specific overrides found at /home/pi/.config/retroarch/config/MAME 2003 (0.78)/missile.cfg.
    [INFO] Shaders: preset directory: /home/pi/.config/retroarch/shaders/presets
    [INFO] Shaders: no game-specific preset found at /home/pi/.config/retroarch/shaders/presets/MAME 2003 (0.78)/missile.cgp.
    [INFO] Shaders: no game-specific preset found at /home/pi/.config/retroarch/shaders/presets/MAME 2003 (0.78)/missile.glslp.
    [INFO] Shaders: no content-dir-specific preset found at /home/pi/.config/retroarch/shaders/presets/MAME 2003 (0.78)/arcade.cgp.
    [INFO] Shaders: no content-dir-specific preset found at /home/pi/.config/retroarch/shaders/presets/MAME 2003 (0.78)/arcade.glslp.
    [INFO] Shaders: no core-specific preset found at /home/pi/.config/retroarch/shaders/presets/MAME 2003 (0.78)/MAME 2003 (0.78).cgp.
    [INFO] Shaders: no core-specific preset found at /home/pi/.config/retroarch/shaders/presets/MAME 2003 (0.78)/MAME 2003 (0.78).glslp.
    [INFO] Remaps: remap directory: /opt/retropie/configs/arcade/
    [INFO] Remaps: no game-specific remap found at /opt/retropie/configs/arcade/MAME 2003 (0.78)/missile.rmp.
    [INFO] Remaps: no content-dir-specific remap found at /opt/retropie/configs/arcade/MAME 2003 (0.78)/arcade.rmp.
    [INFO] Remaps: no core-specific remap found at /opt/retropie/configs/arcade/MAME 2003 (0.78)/MAME 2003 (0.78).rmp.
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/arcade/missile.srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/arcade/missile.state".
    [INFO] Environ GET_LOG_INTERFACE.
    [INFO] Environ PERFORMANCE_LEVEL: 10.
    [INFO] Content loading skipped. Implementation will load it on its own.
    [INFO] CRC32: 0x8b921531 .
    [libretro INFO] [MAME 2003] Content path: /home/pi/RetroPie/roms/arcade/missile.zip.
    [libretro INFO] [MAME 2003] Content lookup name: missile.
    [libretro INFO] [MAME 2003] Driver index counter: 3149. Matched game driver: missile.
    [libretro INFO] [MAME 2003] Content identified as having a tilt feature.
    [libretro INFO] [MAME 2003] Content identified as having a service button.
    [libretro INFO] [MAME 2003] Content identified as using trackball controls.
    [libretro INFO] [MAME 2003] Content identified as using trackball controls.
    [libretro INFO] [MAME 2003] Content identified as using trackball controls.
    [libretro INFO] [MAME 2003] Content identified as using trackball controls.
    [libretro INFO] [MAME 2003] Content identified as using 8-way joystick controls.
    [libretro INFO] [MAME 2003] Content identified by controls.c as having joysticks on axis with respect to the cabinet.
    [libretro INFO] [MAME 2003] Content identified as supporting 2 players with 2 distinct controls.
    [libretro INFO] [MAME 2003] Content identified as supporting 3 button controls.
    [libretro INFO] [MAME 2003] Content identified by controls.c as having mirrored multiplayer control labels.
    [INFO] Environ SYSTEM_DIRECTORY: "/home/pi/RetroPie/BIOS".
    [libretro INFO] [MAME 2003] content path: /home/pi/RetroPie/roms/arcade/
    [libretro INFO] [MAME 2003] system path: /home/pi/RetroPie/BIOS
    [libretro INFO] [MAME 2003] save path: /home/pi/RetroPie/roms/arcade/
    [INFO] Environ SET_VARIABLES.
    [INFO] Environ GET_VARIABLE mame2003_four_way_emulation:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_mouse_device:
    [INFO] mouse
    [INFO] Environ GET_VARIABLE mame2003_crosshair_enabled:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_skip_disclaimer:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_skip_warnings:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_display_setup:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE mame2003_neogeo_bios:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_stv_bios:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_use_alt_sound:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_dialsharexy:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_dual_joysticks:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_rstick_to_btns:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_vector_resolution_multiplier:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_vector_antialias:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_vector_beam_width:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_vector_translucency:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_vector_flicker:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_vector_intensity:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_dcs_speedhack:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_core_sys_subfolder:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_core_save_subfolder:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_tate_mode:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE mame2003_brightness:
    [INFO] 1.0
    [INFO] Environ GET_VARIABLE mame2003_gamma:
    [INFO] 1.0
    [INFO] Environ GET_VARIABLE mame2003_frameskip:
    [INFO] 0
    [INFO] Environ GET_VARIABLE mame2003_sample_rate:
    [INFO] 48000
    [INFO] Environ GET_VARIABLE mame2003_input_interface:
    [INFO] simultaneous
    [INFO] Environ GET_VARIABLE mame2003_mame_remapping:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_display_artwork:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE mame2003_art_resolution:
    [INFO] 1
    [INFO] Environ GET_VARIABLE mame2003_nvram_bootstraps:
    [INFO] N/A
    [INFO] Environ GET_VARIABLE mame2003_cheat_input ports:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE mame2003_machine_timing:
    [INFO] N/A
    [INFO] Environ SET_INPUT_DESCRIPTORS:
    [INFO] RetroPad, User 1, Button "B (bottom)" => "Button 1"
    [INFO] RetroPad, User 1, Button "Y (left)" => "Button 2"
    [INFO] RetroPad, User 1, Button "Select" => "Insert Coin"
    [INFO] RetroPad, User 1, Button "Start" => "Start"
    [INFO] RetroPad, User 1, Button "D-Pad Up" => "Joystick Up"
    [INFO] RetroPad, User 1, Button "D-Pad Down" => "Joystick Down"
    [INFO] RetroPad, User 1, Button "D-Pad Left" => "Joystick Left"
    [INFO] RetroPad, User 1, Button "D-Pad Right" => "Joystick Right"
    [INFO] RetroPad, User 1, Button "A (right)" => "Button 4"
    [INFO] RetroPad, User 1, Button "X (up)" => "Button 3"
    [INFO] RetroPad, User 1, Button "L" => "Button 5"
    [INFO] RetroPad, User 1, Button "R" => "Button 6"
    [INFO] RetroPad, User 1, Button "L2" => "Button 7"
    [INFO] RetroPad, User 1, Button "R2" => "Button 8"
    [INFO] RetroPad, User 1, Button "L3" => "Button 9"
    [INFO] RetroPad, User 1, Button "R3" => "Button 10"
    [INFO] RetroPad, User 2, Button "B (bottom)" => "Button 1"
    [INFO] RetroPad, User 2, Button "Y (left)" => "Button 2"
    [INFO] RetroPad, User 2, Button "Select" => "Insert Coin"
    [INFO] RetroPad, User 2, Button "Start" => "Start"
    [INFO] RetroPad, User 2, Button "D-Pad Up" => "Joystick Up"
    [INFO] RetroPad, User 2, Button "D-Pad Down" => "Joystick Down"
    [INFO] RetroPad, User 2, Button "D-Pad Left" => "Joystick Left"
    [INFO] RetroPad, User 2, Button "D-Pad Right" => "Joystick Right"
    [INFO] RetroPad, User 2, Button "A (right)" => "Button 4"
    [INFO] RetroPad, User 2, Button "X (up)" => "Button 3"
    [INFO] RetroPad, User 2, Button "L" => "Button 5"
    [INFO] RetroPad, User 2, Button "R" => "Button 6"
    [INFO] RetroPad, User 2, Button "L2" => "Button 7"
    [INFO] RetroPad, User 2, Button "R2" => "Button 8"
    [INFO] RetroPad, User 2, Button "L3" => "Button 9"
    [INFO] RetroPad, User 2, Button "R3" => "Button 10"
    [INFO] RetroPad, User 3, Button "B (bottom)" => "Button 1"
    [INFO] RetroPad, User 3, Button "Y (left)" => "Button 2"
    [INFO] RetroPad, User 3, Button "Select" => "Insert Coin"
    [INFO] RetroPad, User 3, Button "Start" => "Start"
    [INFO] RetroPad, User 3, Button "D-Pad Up" => "Joystick Up"
    [INFO] RetroPad, User 3, Button "D-Pad Down" => "Joystick Down"
    [INFO] RetroPad, User 3, Button "D-Pad Left" => "Joystick Left"
    [INFO] RetroPad, User 3, Button "D-Pad Right" => "Joystick Right"
    [INFO] RetroPad, User 3, Button "A (right)" => "Button 4"
    [INFO] RetroPad, User 3, Button "X (up)" => "Button 3"
    [INFO] RetroPad, User 3, Button "L" => "Button 5"
    [INFO] RetroPad, User 3, Button "R" => "Button 6"
    [INFO] RetroPad, User 3, Button "L2" => "Button 7"
    [INFO] RetroPad, User 3, Button "R2" => "Button 8"
    [INFO] RetroPad, User 3, Button "L3" => "Button 9"
    [INFO] RetroPad, User 3, Button "R3" => "Button 10"
    [INFO] RetroPad, User 4, Button "B (bottom)" => "Button 1"
    [INFO] RetroPad, User 4, Button "Y (left)" => "Button 2"
    [INFO] RetroPad, User 4, Button "Select" => "Insert Coin"
    [INFO] RetroPad, User 4, Button "Start" => "Start"
    [INFO] RetroPad, User 4, Button "D-Pad Up" => "Joystick Up"
    [INFO] RetroPad, User 4, Button "D-Pad Down" => "Joystick Down"
    [INFO] RetroPad, User 4, Button "D-Pad Left" => "Joystick Left"
    [INFO] RetroPad, User 4, Button "D-Pad Right" => "Joystick Right"
    [INFO] RetroPad, User 4, Button "A (right)" => "Button 4"
    [INFO] RetroPad, User 4, Button "X (up)" => "Button 3"
    [INFO] RetroPad, User 4, Button "L" => "Button 5"
    [INFO] RetroPad, User 4, Button "R" => "Button 6"
    [INFO] RetroPad, User 4, Button "L2" => "Button 7"
    [INFO] RetroPad, User 4, Button "R2" => "Button 8"
    [INFO] RetroPad, User 4, Button "L3" => "Button 9"
    [INFO] RetroPad, User 4, Button "R3" => "Button 10"
    [libretro INFO] [MAME 2003] Opening ROM file: 035820.02
    [libretro INFO] [MAME 2003] Opening ROM file: 035821.02
    [libretro INFO] [MAME 2003] Opening ROM file: 035822.02
    [libretro ERROR] [MAME 2003] 035822.02 NOT FOUND
    [libretro INFO] [MAME 2003] Opening ROM file: 035823.02
    [libretro INFO] [MAME 2003] Opening ROM file: 035824.02
    [libretro INFO] [MAME 2003] Opening ROM file: 035825.02
    [INFO] Environ SET_MESSAGE: Required files are missing, the game cannot be run.

    [libretro ERROR] [MAME 2003] Required files are missing, the game cannot be run.
    [libretro ERROR] [MAME 2003] readroms failed
    [ERROR] Failed to load content.
    [INFO] Unloading game..
    [INFO] Unloading core..
    [INFO] Unloading core symbols..
    [INFO] Saved core options file to "/opt/retropie/configs/all/retroarch-core-options.cfg"



  • @mha Im sure @mitu can decipher better than I but "required files are missing" makes me think your rom is corrupt. Do you have a back of the rom that you can replace it with?



  • in log.
    Opening ROM file: 035822.02
    [libretro ERROR] [MAME 2003] 035822.02 NOT FOUND

    did open my zip and file was named 035822.03.

    Any sources for probably working rom?



  • @mha Please see: https://retropie.org.uk/forum/topic/2/forum-rules

    We dont discuss where to get roms here. Do you not have a back-up of this rom from when it was working?


  • Global Moderator

    @mha said in Missile Command stop working:

    Any sources for probably working rom?

    Please read the forum rules - there's no ROM sharing here. The file may be there, but the CRC might not match

    		<rom name="035820.02" size="2048" crc="7a62ce6a" sha1="9a39978138dc28fdefe193bfae1b226391e471db" region="cpu1" offset="5000"/>
    		<rom name="035821.02" size="2048" crc="df3bd57f" sha1="0916925d3c94d766d33f0e4badf6b0add835d748" region="cpu1" offset="5800"/>
    		<rom name="035822.02" size="2048" crc="a1cd384a" sha1="a1dd0953423750a0fbc6e3dccbf2ca64ef5a1f54" region="cpu1" offset="6000"/>
    		<rom name="035823.02" size="2048" crc="82e552bb" sha1="d0f22894f779c74ceef644c9f03d840d9545efea" region="cpu1" offset="6800"/>
    		<rom name="035824.02" size="2048" crc="606e42e0" sha1="9718f84a73c66b4e8ef7805a7ab638a7380624e1" region="cpu1" offset="7000"/>
    		<rom name="035825.02" size="2048" crc="f752eaeb" sha1="0339a6ce6744d2091cc7e07675e509b202b0f380" region="cpu1" offset="7800"/>
    


  • @mitu I am so sorry, I should have been notice the basic rule!
    My problem must be inside my zip. I have no backup :(
    Have tried too many zips already to fix...
    Sieppaa.PNG


  • Global Moderator

    @mha Your zip file doesn't contain the file(s) reported as missing - take a look at the list of files I posted earlier - they are completely different (they look like they're from the 0.106 ROMset). Here's how the correct ROM looks like.

    f849ae36-e7cc-4b94-8878-b37ff2ca93c1-image.png

    Are you sure you didn't run this ROM before with advmame or other Mame core ?



  • @mitu I don´t know any more.
    There has been installed advmame1.4 too & mame4all and some others.
    I have tried to start with all ofthem already I believe.

    So romset series 0.78 should I try to find for Mame 2003, right?


  • Global Moderator

    @mha said in Missile Command stop working:

    So romset series 0.78 should I try to find for Mame 2003, right?

    Yes - https://retropie.org.uk/docs/Arcade/#step-2-select-the-right-rom-set.



  • @mitu Thanks for Your effort,
    feel myself so stupid now. Works like a charm!

    Which romsets goes fine to advmame latest version & advmame 1.4?


  • administrators

    @mha 0.106



  • @BuZz Marble Madness with advmame 1.4 drives me nuts.
    Starts normally and fine, Hi-Score lists shows up normally. But when I start to play picture goes crazy. Any clue, what makes this color error below?

    marblepic.png


  • Global Moderator

    @mha Have you looked at @markwkidd's reply in your original topic ?



  • @mitu I have.
    Another reason for trying in advmame is because I can get whole screen area used there.
    In mame2003 have a quite small box in the middle of my monitor only.
    I don´t know, how to scale there. In advmame it goes nicely directly from menu, but colors are "broken"...


  • Global Moderator

    @mha said in Missile Command stop working:

    In mame2003 have a quite small box in the middle of my monitor only.

    Try fiddling with the Video settings and disable 'Integer scaling' - the image should scale according to your screen size.



  • @mitu Thanks,
    will give it a try, if I am able to locate it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.