Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Bad resoltuion after hdmi_force_hotplug=1



  • Pi Model or other hardware: 3B+
    Power Supply used: Original 2.5V
    RetroPie Version Used: 4.4.4
    Built From: Retropie website
    Controller used: keyboard usb & Arcade usb
    Error messages received: N/A
    Guide used: N/A
    File: N/A
    Emulator: All
    Attachment of config files: N/A

    Hello, so I am building an Arcade machine and the monitor is a Dell E198FPF that according to Amazon has a resolution of 1280 x 1024 (56 to 76 HZ).

    I am using a HDMI to VGA adapter so in order to the screen to detect the pi I had to enable in the boot config: "hdmi_force_hotplug=1" My issue is when I powerone everything retropies stars with a low resolution but If I reboot the system via EmulStation it will restart with the optimal resolution.

    The next time I power one everything the same problem occurs, Is there a way to fix this? I already try adding "hdmi_group=36" to the config but it doesnt help either :(

    Here's my current config.txt

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=0
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=36
    #hdmi_mode=4
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    #overscan_scale=1
    enable_uart=1
    

  • Global Moderator

    Try adding

    hdmi_ignore_edid=0xa5000080
    hdmi_mode=2
    hdmi_group=36
    hdmi_ignore_edid_audio=1
    

    Also, when the resolution is correctly shown, exit Emulationstation and run

    tvservice -s
    

    to see which mode/group you're currently using.

    EDIT: you can try also

    hdmi_group=35 
    

    maybe 36 is not correctly rendered by the converter.



  • @mitu said in Bad resoltuion after hdmi_force_hotplug=1:

    Try adding

    hdmi_ignore_edid=0xa5000080
    hdmi_mode=2
    hdmi_group=36
    hdmi_ignore_edid_audio=1
    

    Also, when the resolution is correctly shown, exit Emulationstation and run

    tvservice -s
    

    to see which mode/group you're currently using.

    EDIT: you can try also

    hdmi_group=35 
    

    maybe 36 is not correctly rendered by the converter.

    Thank you very much, so after adding

    hdmi_ignore_edid=0xa5000080
    hdmi_mode=2
    hdmi_group=36

    It booted with perfect resolution but when the spalsh screen video (which is 1080p) started no image was show until emulstation started. So it pretty much solved as I could simply downscale the intro video to the monitor resolution.

    But I tried variations: with only the "hdmi_ignore_edid=0xa5000080" the monitor will began "Auto-Fiting" end with a not deliverables resolution. I dicided to make a last varation adding the group and mode and removing the ignore_edid code but then somehow my PC broke the boot partiting so now retropie is "broken"

    Plug in into the PC no longer shows a Boot partition :(
    I was going to backup after this :( :( :(


  • Global Moderator

    @X_Splinter You can try to see if the card still boots, but if you haven't enabled SSH previously, so you can access it from the network and fix the config file, then you're out of luck.



  • @mitu The Raspberry pi is not detecting it... I assume the boot partition is gone, the PC sees it as RAW and not FAT

    I am going to install in new card and see if I can rebuild Boot partition on the older one, If not I'll start over



  • After rebuild a new Retropie image the perfect solution was:

     hdmi_force_hotplug=1
     hdmi_mode=2
     hdmi_group=36
    

    Thanks again @mitu for your help



  • @X_Splinter i only use those settings and not the edid ones. If you are using an emulationstation theme that has clicking sounds and notice the first couple clicks lag enable this line:

    hdmi_drive=2


  • I just found that out that it only works if my audio amplifier is shutdown. I have no idea since that both adapter and amplifier are self powered.

    If I turn it on after the screen is show there is no problem, if on at the same the pi and monitor are turned on no image :(



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.