Please do not post a support request without first reading and following the advice in

Scraper only downloading 233 byte mp4 files

  • I'm doing a brand new RetroPie build. 4.4 Image, updated, on a pi3B.
    After running Selph's Scraper with videos enabled Every mp4 file is only 233 bytes and obviously doesn't run. I have tried all available sources with no success. I have also tried with an ethernet cable instead of wifi with no change. Any other ideas?
    (I also use a Mac. I know that may affect solutions.)

  • Global Moderator

    @DrMonroeJ4 What sources and systems are you scraping ? Can you give an example on how are you running the scraper ?

  • Scraper settings;
    Thumbnails only (Disabled)
    Prefer screenshots (Disabled)
    Arcade Source (Arcade Italia)
    Console Source (I Have ran all three, ScreenScraper, OpenVGDB, thegamesdb)
    ROM Names (the GamesDB)
    Gamelist (Overwrite)
    Use rom folder for game list & images (Enabled)
    Download Videos (Enabled)
    Download Marquees (Disabled)
    Max image width (400)
    Max image Height (400)

    I also ran the update, just to be sure.
    I've scraped NES, SNES, N64, and Sega CD.
    I only had limited success with the Sega CD, but the info and image files came out great for the others.
    But every mp4 says it's 233 bytes.

    Screen Shot 2019-02-25 at 11.20.34 PM.png
    I have also downloaded and manually installed a few game snaps just to check, and they work perfectly. But that's not really an option for 1000+ games.

  • Global Moderator

    OK, so you're scraping a console game. For videos, I think only ScreenScraper might have it. I'll give it a test and see, but my money's on the ScreenScraper returning an error and scraper inadvertently saving that error in a mp4 file. Can you try and open one of the mp4 files in a text editor and look at the contents ?

  • @mitu Yeah, there's an error.

    Screen Shot 2019-02-25 at 11.39.39 PM.png

  • Global Moderator

    There might have been some changes on their API site, hence the error, so I'd retry to scrape again.
    I don't have the games available, so I'm testing with empty files in my ROMs folder, but Skyscraper seems to download the videos fine right now:

    $ file /home/pi/RetroPie/roms/segacd/media/videos/Dune.mp4
    /home/pi/RetroPie/roms/segacd/media/videos/Dune.mp4: ISO Media, MP4 Base Media v1 [IS0 14496-12:2003]
    pi@retropie:~/RetroPie/roms/segacd $ ls -lh media/videos/
    total 3.0M
    -rw-r--r-- 1 pi pi 1.5M Feb 26 05:50 Dune.mp4
    -rw-r--r-- 1 pi pi 1.5M Feb 26 05:50 Snatcher.mp4

  • Hello,

    since yesterday I find the same problem with the scraping of consoles, the video files are 233k and contain the above error
    <br />
    <b>Parse error</b>: syntax error, unexpected end of file, expecting variable (T_VARIABLE) or ${ (T_DOLLAR_OPEN_CURLY_BRACES) or {$ (T_CURLY_OPEN) in <b>/var/www/html/scraper/api/mediaVideoJeu.php</b> online <b>157</b><br />

    selecting Screenscraper, I also tried to register on and use the command, but same problem

    sudo /opt/retropie/supplementary/scraper/./scraper -append -console_src ss -ss_user="yourusername" -ss_password="yourpassword" -download_videos -download_images -hash_file "/opt/retropie/supplementary/scraper/hash.csv" -lang="fr,en,jp"

    Is this a temporary problem in your opinion?

    Thank you

  • Global Moderator

    @ryuzaki75 said in Scraper only downloading 233 byte mp4 files:

    Is this a temporary problem in your opinion?

    Yes, I think it's temporary.

  • Well, it's reassuring to hear that I'm not the only one.

    I did get Skyscraper to work, so it looks like that's what I'll use.

    Thanks for the extra eyes.

  • Whoa... I googled "/var/www/html/scraper/api/mediaVideoJeu.php" which is found in the mp4 game video files from screenscraper, and found this thread!

    <br />
    <b>Parse error</b>: syntax error, unexpected end of file, expecting variable (T_VARIABLE) or ${ (T_DOLLAR_OPEN_CURLY_BRACES) or {$ (T_CURLY_OPEN) in <b>/var/www/html/scraper/api/mediaVideoJeu.php</b> on line <b>157</b><br />

    I'm so happy I'm not the only one with a problem with screenscraper!
    I spent all of last evening 6+ hours trying to figure out why my scrapped videos weren't playing.
    I ended up re-installed retropie, then tried a bunch of tricks thinking my es theme was bad, finally I looked and saw that the mp4 files downloaded were only a few bytes long.
    Sadly for me, I ended up formatting my SD card because I thought it was corrupt, while I had a bunch of systems on there from a few days prior that I scrapped. Sadly I don't have a good backup :(

  • I'd like to add to my above comment.
    When using Selph's Scrapper, when downloading videos from screenscraper, the mp4 files are only a few bytes in size.
    If I use SKYSCRAPER and also use screenscraper as source, the videos download fine.

    Appears to be a problem with Selph's Scrapper.

  • I confirm, Skyscraper works great with videos and I find it much better than the Selph (I did not know). Thanks for the tip

  • Global Moderator

    The temporary problem should be fixed now. Any of you guys/girls that tried SScraper and failed to download the videos - can you retry now and see if it's ok ?

  • @mitu Thank You. Seems to work (atleast on the two systems I tried). I came home from working during lunch just to try it :) Will do the other systems when I finish with work at the end of the day. Thanks for the heads up!

  • @mitu Tested, confirmed working with Universal XML scraper

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.