Please do not post a support request without first reading and following the advice in

  • When I start a german Inform game (.z6) from ES german Umlaute (äÄöÖüÜß) are not displayed correct. But when I start frotz from the shell, it works fine. My local settings are set to german via RaspConf. What could cause this problem?

  • Global Moderator

    @Kohlkarpfen said in Frotz/Inform with Umlaute (äÄöÖüÜß):


    Can you give more details about the ROM name and your system ( ? You can see in the Runcommand log file (/dev/shm/runcommand.log) how frotz is started vs. how are you starting it from the command line - can you attach the log file to your post ?

  • Raspberry Pi 3 b+
    RetroPie v4.4

    Executing: pushd /home/pi/RetroPie/roms/zmachine; frotz "/home/pi/RetroPie/roms/zmachine/starrider.z5"; popd

    When I start it from Shell I only change the directory to /home/pi/RetroPie/roms/zmachine/ and run

    frotz starrider.z5
  • Global Moderator

    What is the output of locale, when you run it from the terminal ? It looks like the game expects the terminal to have a Latin1 encoding, but I think that by default the locale settings set it to UTF8. I don't know how it works from the terminal - do you run the game (succesfully) after quiting Emulationstation or from a SSH session ?

  • Global Moderator

    OK, I found a workaround for this problem - which seems similar to this issue.
    Edit the /etc/default/console-setup file (sudo nano /etc/default/console-setup) and change the




    then reboot. After that, the game should run with the correct characters.


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.