Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Opinion on overclock settings



  • @GoldManSex778 ioQuake3 can be installed through retropie setup. It will show up in your ports section. Run a single player skirmish, load up about 8 or more bots and set frag limit and time limit to 0. Start the skirmish and then open the console by pressing ` and then type /team spectator. Close the console and press cntrl. You should now be in a first person view of one of the bots and the game will run indefinitely until you stop it or it freezes due to an unstable overclock. Most unstable overclocks will lead to a game freeze within a few minutes to a few hours. I would recommend only testing one overclock setting at a time otherwise you wont know which value to change. The quake 3 test has been recommended by the raspberry pi foundation because it works the pi's GPU, CPU (single thread), and SDRAM pretty hard.

    There are a couple things to note before running this test. First make sure you have sufficient cooling, this game will really heat up your pi and overclocking/over volting will only increase that heat. A good heatsink and/or fan are highly recommended. Second, be sure to back up your image before doing any overclocking and testing. Any unstable overclocks are likely to freeze up your pi and there is always a chance of SD card corruption. Third, if and when your pi freezes you usually can ssh into the pi and reboot safely. Only pull the plug as a last resort.



  • @quicksilver Thank you, very useful info. I have a good 5v Noctua fan but the heatsink is stock. I will take it slow and low and report the success I have.

    Cheers



  • @Dwarfboysim
    Well, I guess I'll share my config.txt.
    I have a RPI 3 B+
    Retroflag Megapi Case

    #hdmi_drive=2
    #hdmi_force_edid_audio=1
    disable_overscan=1
    disable_splash=1
    
    force_turbo=1
    boot_delay=1
    
    arm_freq=1500
    gpu_freq=500
    core_freq=500
    sdram_freq=500
    sdram_over_voltage=1
    #sdram_over_voltage_p=6
    #sdram_over_voltage_i=4
    #sdram_over_voltage_c=4
    over_voltage=2
    
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    dtparam=audio=on
    
    gpu_mem=512
    

    I recently changed it because of a undervolt warning, but I think it could have been because I was charging a controller.



  • @quicksilver thanks for posting I’ll give it a try



  • I don't know if there is a great difference in the RPI 3B and 3B+. I'm still experimenting, I think I set the sdram_freq or over_voltage too high so I'm trying a really high overclock with regular sdram_freq

    REM arm_freq=1600
    #gpu_freq=550
    core_freq=500
    sdram_freq=450
    sdram_over_voltage=1
    #sdram_over_voltage_p=6
    #sdram_over_voltage_i=4
    #sdram_over_voltage_c=4
    over_voltage=4
    

    Unstable; low voltage warning, freezes



  • @Efriim You have sdram_freq=450. Which is actually underclocking your ram. Pi3b+ default is 500mhz. Your arm_freq is also unrealistically high and I would bet that there are few to no pi3b+'s that can be set that high and be stable. It seems you are just picking random numbers. You need to restore your config.txt to default values and then only change one value at a time while properly testing for stability. You'll never be able to properly test the way you are doing it.



  • @Efriim said in Opinion on overclock settings:

    gpu_mem=512

    gpu_mem=512
    got issues if u play a psp game then quit it wont go to the game anymore...
    gpu_mem=320 change it too.
    or tell me if it just works fine with 512 (from your side).



  • @shavecat @Efriim GPU mem setting is best left at default which for a pi3 is 256mb. There are no emulators on RetroPie that need even that much. Setting higher than that will not improve performance and in fact is likelyto be a detriment because you are reducing the amount of ram available to the CPU.



  • @quicksilver
    yes but the theme getting gray box's , so this is the best way i found . (or just switch a theme ).



  • @shavecat What theme are you using? Something doesnt seem right here.



  • @quicksilver
    blueray



  • @shavecat This issue seems to be unique to your setup then. GPU memory on a typical retropie setup doesnt need to be higher than 256mb



  • @quicksilver
    Yeah, I am not exactly using an applied method or scientific method, I'll give you that.
    But sdram_freq=450 is default for RPI3 non B+
    the gpu_mem=512, I think it might not be very good for Firefox-ESR or Pixel Desktop, I had no problems with 256.
    Also like previously stated gpu_freq is an umbrella setting for; core, v3d, isp, h264, I didn't accurately take that into consideration.
    What is avoid_pwm_pll=1?



  • @Efriim I thought you said you had a 3b+? avoid_pwm_pll=1 is an obsolete setting (its ignored by current firmware) basically it would "borrow" a pll from the 3.5mm audio so that you could set an individual block of the GPU to a different and unrelated value. But the main takeaway is that its not used anymore and is not needed.



  • @quicksilver
    True, I am using a 3B+, OP was using a 3B. I think they're the mostly the same except for the wireless card, and default clocks.
    1600 has been stable, I've only run Dosbox and video screensavers for a couple hours with this configuration. It helps in Dosbox; Ultima 8 has significant less bogs, Masters of Orion 2 is quite a bit snappier. Is there a different game,emulator,app, other than quake that you would recommend for use test?

    Have you tested any over_voltage above 6? I read that force_turbo needs to be on, basically any value above 6 and I can't boot properly, but I can still SSH.



  • @Efriim Overclocks are detrimental if unstable. Quake 3 is a good test because it works your pi very hard. You are not going to easily replicate this by running dosbox or other console emulators. The freeware version can be installed easily from retropie setup.

    Max over voltage is 1.4v. On older models of pi an over voltage value of 8 was needed to reach this but the stock voltage of a pi3 is set higher which means that you are very likely already reaching 1.4v with an over volt value of <5.



  • So this is my overclock , cant get the force_turbo to work too (it will freeze the retorpie after couple of hours not hot temp' for me just getting it stuck )
    b0e13329-98db-4654-80a7-4cd49094bef0-image.png



  • Raspberry Pi config.txt documentation for default values and definitions.

    vcgencmd measure_temp
    vcgencmd measure_clock arm
    vcgencmd measure_clock core
    Is there a way to invoke vcgencmd to monitor and update?

    What other commands are known?



  • @shavecat judging by your recent posts you have had a lot of instability lately. Force_turbo simply disables the CPU governor and makes your pi operate at full speed even when idle. If this is freezing your pi then your overclock is unstable. If you aren't careful you are going to corrupt your SD card or it may be happening already.

    @Efriim with current firmware the sdram_schmo setting is automatically changed when you overclock sdram over 500mhz. So really isn't any reason to use that setting anymore unless you really have a good reason.

    Over_voltage and over_voltage_sdram are separate settings.



  • @Efriim yes if you actively monitor the CPU freq you will see that there are slight fluctuations. V3d, isp and h264 freq might return a 0 value if they aren't being used (for emulation isp and h264 aren't needed. Though h264 might be needed if you are also running Kodi)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.