Please do not post a support request without first reading and following the advice in

xbox controller undetectable after driver packages update - also weird white login screen with cursor after 'sudo apt-get install lightdm'

  • Hi,

    I'm really stuck with my playstation-like (but recognised as xbox controller) joypad recognition when starting emulation station- it won't detect it at all. I've tried many options, but reinstalling drivers or tweaking files don't do anything.
    Only one option seems to remain, and that's reconfiguration through gui, but I can't get there.
    Any thoughts anyone?

    Also, since reinstalling the xboxdriver the system wouldn't do a proper reboot, so naturally I went to retropie setup with cmd but I couldn't select option b4 anymore- the desktop boot with automatic login.
    The system recommended to do this by cmd 'sudo apt-get install lightdm' after that I got this stupid white windows-like login screen with mouse cursor. Shortly after that it pops to cmd again. So no boot to emulation station.

    Any help is highly appreciated. The problems keep adding up- the only thing i originally had to do is get the joypad to run properly (with ps1 games-almost 100% fixed) and get a decent performance on n64 games. But all these little bugs keep showing up and it`s annoying the hell out of me.

    Again, sorry for any incorrect grammar or spelling- I`m Dutch.

  • Global Moderator

    @Stag The lightdm installation has probably messed up your auto-login, it's not the proper solution -

    You don't need the xboxdrv to make the controller work, even if it's an Xbox compatible controller, but the xpad driver (which recognises most Xbox wired controllers). I already said that in the previous topic you opened - you can uninstall it from the RetroPie setup.

  • Hi @mitu,

    Thanks again for your fast reply and support!

    You indeed mentioned that xboxdriver is unnecessary but no alternative and I forgot to ask. As far as I can remember I had the xpad driver installed but my ps1 games wouldn't respond. But I'll unpack and re-run the proces again.

    I'll uninstall the lightdm installation, but as I mentioned I installed this because console autologin wouldn't work anymore and I couldn`t select it.
    As you can tell I am constantly checkmate with these problems and when you try out the options offered by all the tutorials there is always this interference with previously working settings.

    But I' ll get to work and will let you know if there's any progress.

  • Ok, so I uninstalled the lightdm and no weird white screen anymore, but I'm back to the same problem: can't autoboot with automatic login after selecting this option in raspi-config- it goes to cmd again.

    But I noticed a start-up error- failed to start /etc/rc.local Compatibility.

    Maybe that`s the problem?

  • Global Moderator

    @Stag I think your problem is that you added something in /etc/rc.local that prevents the startup - what's the content of said file ? Are you automatically logged in after you re-add the auto-login with raspi-config ?

  • @mitu

    Here`s the content:

    #!/bin/sh -e


    This script is executed at the end of each multiuser runlevel.

    Make sure that the script will "exit 0" on success or any other

    value on error.

    In order to enable or disable this script just change the execution


    By default this script does nothing.

    Print the IP address

    _IP=$(hostname -I) || true
    if [ "$_IP" ]; then
    printf "My IP address is %s\n" "$_IP"

    "/opt/retropie/supplementary/xboxdrv/bin/xboxdrv" --daemon --detach --dbus disabled --detach-kernel-driver --id 0 --led 2 --deadzone 4000 --silent --trigger-as-button --next-controller --id 1 --led 3 --deadzone 4000 --silent --trigger-as-button --next-controller --id 2 --led 4 --deadzone 4000 --silent --trigger-as-button --next-controller --id 3 --led 5 --deadzone 4000 --silent --trigger-as-button
    exit 0

    Still can`t get the pi to autoboot

  • @mitu,

    Also, my controller's running again- thanks for that! But i can't use the start button to get in gui and re-configure.

  • Global Moderator

    @Stag Delete the line with the xboxdrv - did you uninstall the driver from the setup ?

  • @mitu

    I did indeed- that worked. I deleted the xboxdriver line and no error anymore. But still no autoboot.
    New amazing problem is, when i go into emulation station and with my controller to the retropie menu- there are scrambled pieces of text (and pictures of joypads missing with neo geo and such) and when I select raspi-config the menu pops into cmd.

  • Global Moderator

    @Stag Sounds like some of your 'fixes' have messed up your system.

  • @mitu

    Guess so- is there any major sweep I can do like a big uninstall instead of re-installing retropie on the sd card?

  • Global Moderator

    @Stag Flash the card again, save your ROMs before.

  • @mitu

    Ok copy that.
    Ill try some other stuff since I got nothing to lose here- and if no succes Ill flash the card again.

    Thanks for your help so far!

  • @Stag

    One last tip for people who have messed up controls and can`t get them to change:
    when you got to: sudo ~/RetroPie-Setup/
    via cmd then --> configuration/tools --> emulationstation --> clear/reset emulation station configuration - you can reset the controller and do a new configuration at the start of emu station.

  • @mitu

    I`ve managed to fix the boot issue by going into emustation and change the boot options from there. This was only possible by fixing the controller issue first.

    Now, only thing left to do is- get the ps1 graphics smooth again (suddenly back to basic and in game tweaking of video options not working), get the best video options going for n64, fix the missing theme/picture problem.

    Sorry to go off topic- do you know of a way to get the open gl driver running? It seems incompatible with retropie and gives boot problems.
    Or is this not a good idea?

  • Global Moderator

    @Stag said in xbox controller undetectable after driver packages update - also weird white login screen with cursor after 'sudo apt-get install lightdm':

    Sorry to go off topic- do you know of a way to get the open gl driver running? It seems incompatible with retropie and gives boot problems.

    The OpenGL driver is not compatible with RetroPie.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.