Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dialog Boxes contain x's and q"s instead of shading



  • Hello All,

    I'd like to share the following image (please reference link) with you to see if anyone else has experience this and/or perhaps resolved it.

    My current Retropie setup is running without issues. I recently updated it to apply the fix for the scraper API fix. Afterwards all dialog boxes contain these x's and q's instead of the usual shading (see attached image as reference).

    It's not affecting the way Retropie works, just a minor gripe every-time there is a dialog box that appears onscreen.

    Any leads on how to correct would be greatly appreciated. Thanks in advance.

    Link to Dialog Box Image


  • Global Moderator

    Try re-configuring the fonts used in RetroPie from the consolefonts module - https://retropie.org.uk/docs/FAQ/#how-can-i-increase-the-console-font-size - and choose one of the Terminus fonts.



  • Hi Mitu,

    I followed your lead. And proceeded to make the adjustment to the consolefonts module. I used the simple walkthru located here:

    Method 1 was used.

    Console Font Edit Walkthru

    The pro now is that I have a font size double in size which makes it much better to read from tv to couch!

    The con is the dialog boxes still contain the x's and q's.

    Is the information that I used in Method 1 in the aforementioned link not the idea you had in mind?

    I appreciate your input, thanks in advance.


  • Global Moderator

    @papaxris said in Dialog Boxes contain x's and q"s instead of shading:

    Is the information that I used in Method 1 in the aforementioned link not the idea you had in mind?

    No, it's ok, but it's just some update in Raspbian that I think 'broke' this.
    Try selecting ISO-8859-1 as the Encoding in the first dialog that appear when doing the re-configuration, keep everything else the same, then reboot and see if the terminal works better.



  • Hi Mitu,

    I too agree that something in Raspbian broke the dialog box look and feel.

    I went ahead and tested the same procedure using ISO-8859-1 as the Encoding; as you mentioned.

    After the change and reboot, I noticed two things:

    1st - Now dialog box prior to loading a ROM looks correct. The option that shows for a few seconds prior to actually loading the ROM.

    2nd - I went into raspi-config via the retropie menu, and now it's worse off than before. More strange characters and artifacts showing in the menu options.

    I'm happy to Work with you and help find a resolution. Or perhaps a future Raspbian OS update will mitigate the issue.

    Please let me know how you would like to proceed. I appreciate the direction you have given me thus far. I now benefit from the larger Font sizing as a bonus.


  • Global Moderator

    @papaxris said in Dialog Boxes contain x's and q"s instead of shading:

    2nd - I went into raspi-config via the retropie menu, and now it's worse off than before. More strange characters and artifacts showing in the menu options.

    Do you have a screenshot ? After the changes I made, I get no problem in both dialogs. For reference, here's the config file from my system (/etc/default/console-setup):

     #CONFIGURATION FILE FOR SETUPCON
    
    # Consult the console-setup(5) manual page.
    
    ACTIVE_CONSOLES="/dev/tty[1-6]"
    
    CHARMAP="ISO-8859-1"
    
    CODESET=""
    FONTFACE="TerminusBold"
    FONTSIZE="16x32"
    
    VIDEOMODE=
    
    # The following is an example how to use a braille font
    # FONT='lat9w-08.psf.gz brl-8x8.psf'
    


  • Hi Mitu,

    After making the changes to the console setup for the 2nd time my /etc/default/console-setup looked like this:

    # CONFIGURATION FILE FOR SETUPCON
    
    # Consult the console-setup(5) manual page.
    
    ACTIVE_CONSOLES="/dev/tty[1-6]"
    
    CHARMAP="ISO-8859-1"
    
    CODESET="guess"
    FONTFACE="Terminus"
    FONTSIZE="16x32"
    
    VIDEOMODE=
    
    # The following is an example how to use a braille font
    # FONT='lat9w-08.psf.gz brl-8x8.psf'
    

    I went ahead and used your example configuration and matched it exact, then performed reboot.

    I still have the situation where the dialog box prior to loading a ROM looks correct. The option that shows for a few seconds prior to actually loading the ROM.

    But, the raspi-config menu looks strange. Photo Example below:

    Weird Raspi-Config Menu Fonts

    Thank you for helping investigate this with me.


  • Global Moderator

    @papaxris What's you're language/locale setting ?



  • @mitu said in Dialog Boxes contain x's and q"s instead of shading:

    language/locale setting

    /etc/default/locale

    states the following for me:

    #  File generated by update-locale
    LANG=en_GB.UTF-8
    
    

  • Global Moderator

    @papaxris Sorry, I can't find a solution right now. Using the default console setup seems to make raspi-config work fine, however it seems to break the RetroPie-Setup and the runcommand display. Switching to

    CHARMAP="ISO-8859-1"
    

    makes the opposite happen - raspi-config appears garbled while the RetroPie setup / runcommand work fine.
    Looks like something in RetroPie setup/runcommand changed that makes this look different.



  • Appreciate the details.

    I'm glad we were able to investigate this a bit, its mostly a nuisance; but it should work correct.

    I'm happy to revisit this if you want to dive deeper into this in the future.

    Thank you for your time and effort.



  • I have the same problem after updating the Raspbian packages, but it seems to affect only when using a monitor attached directly to the Raspberry Pi (both HDMI / Composite outputs), but not when login thru SSH.


  • Global Moderator

    @xoan Yes, I've seen it reported a few times. Did you also update the RetroPie scripts or just Raspbian ?



  • EDIT:sudo dpkg-reconfigure console-setup tab completion works for invoking some of the debian commands anyways it was console-setup not console-data
    utf-8 should work


  • Global Moderator

    @Efriim Did this fixed it for you ?



  • @mitu
    actually I tested it ISO-8859-1
    but then it fixed it with UTF-8
    I didn't try a reboot though.
    Will try ISO-8859-1 then reboot, UTF-8 works though.


  • Global Moderator

    @Efriim Sure, but how about raspi-config. If you look at the topic, you see that the problem is that there's no common setting to make this work for both raspi-config and RetroPie-Setup at once.



  • @mitu
    ISO-8859-1 wasn't even installed on mine, so I used the raspi-config update locales and checked all en-us, and now they both work.
    I didnt actually get x and qs though.
    Reading...


  • Global Moderator

    @Efriim said in Dialog Boxes contain x's and q"s instead of shading:

    I didnt actually get x and qs though.

    So, if you didn't experience the problem reported by @papaxris or @xoan ?



  • @mitu
    I was just trying to help. OPs second image upload is what I get when I set it to ISO-8859-1 before I installed ISO-8859-1. The question was almost answered, just needed to install locale ISO-8859-1 or change console to UTF-8. I don't know what give x and q.

    Cool font by the way, I think I'm going to keep it.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.