Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

WIFI issues



  • Hi guys, I am so upset that I have lost many hours of configurations on my Piv3. I am not sure what the best options are, but I need to SSH to my backup image to try to copy files, vs anything drastic.

    I tried to disable IPv6 as seen here, but everything listed produces no results:

    https://www.raspberrypi.org/forums/viewtopic.php?t=138899
    https://www.raspberrypi.org/forums/viewtopic.php?t=138899

    And, when going through the GUI under the WIFI section, the Pi will not connect to the WIFI network.

    What frustrates me is that I configured the, now, bad image with no problem, but now I am stumped trying to do it again

    Please any pointer will do. This forum is super helpful, so I have high confidence.

    I am unable to send any configs to you all since there is no network.


  • Global Moderator

    @rasp_renegade Are you sure you didn't disable the Wifi through rfkill ? Run sudo rfkill unblock all and try to connect to Wifi again. Are you using a Wifi dongle or do you have a Raspberry Pi 3 model with built-in Wifi ?



  • Thanks for the reply @mitu

    The output is
    sudo: UNable to resolve host MiPi2
    sudo: rfkill command not found

    Apologies for not stating this is onboard WIFI. Ifconfig shows an IPv6 address, so you would think it was working.



  • @rasp_renegade

    Also, to simplify things I moved closer to my router so also have a wired connection. That is jacked up too since I cannot ping the default gateway


  • Global Moderator

    @rasp_renegade said in WIFI issues:

    sudo: UNable to resolve host MiPi2

    That's not encouraging. Did you modify the /etc/hosts file ? What does ifconfig shows ?



  • @mitu said in WIFI issues:

    @rasp_renegade said in WIFI issues:

    sudo: UNable to resolve host MiPi2

    That's not encouraging. Did you modify the /etc/hosts file ? What does ifconfig shows ?

    Not encouraging indeed!!
    the hosts file is empty

    IFCONFIG
    "lo" only shows the loopback address 127.0.0.1 with mask of 255.0.0.0
    455 errors
    no MAC address is shown

    "wlan0" previously displayed two iPv6 entries, but I must have gotten rid of it with the reference posts above.
    700 errors
    MAC address is displayed


  • Global Moderator

    @rasp_renegade said in WIFI issues:

    the hosts file is empty

    It shouldn't be. Add the following to the file (assuming your hostname is mipi2.

    127.0.0.1	localhost
    ::1		localhost ip6-localhost ip6-loopback
    ff02::1		ip6-allnodes
    ff02::2		ip6-allrouters
    
    127.0.1.1	mipi2
    

    Normally you'd use sudo nano /etc/hosts to edit the file, if that doesn't work, try sudo su and then name /etc/hosts.



  • It looks like that now. Strange it had the very first hostname of MiPi, eventhough the outputs suggested the name I gave it "MiPi2".

    I can ping 127.0.0.1 if that helps.

    IFCONFIG shows less errors now, but still not able to ping the gateway

    Actually, I should mention that the Pi can see all SSIDs that are broadcasting (including my own). Just to eliminate assumptions, I did verify I have the correct network key by connecting from another device.


  • Global Moderator

    @rasp_renegade Try looking for errors in the WiFi service:

    sudo systemctl status wpa_supplicant
    dmesg | tail -n 20
    

    Ideally you should try reverting the changes you made for disabling IPv6, maybe inadvertently you disabled something else also.



  • @mitu said in WIFI issues:

    @rasp_renegade Try looking for errors in the WiFi service:

    sudo systemctl status wpa_supplicant
    dmesg | tail -n 20
    

    Ideally you should try reverting the changes you made for disabling IPv6, maybe inadvertently you disabled something else also.

    Here is the output:
    sudo: unable to resolve host MiPi02

    -wpa_supplicant .service - WPA supplicant
    Loaded: loaded (/lib/systemd/system/wpa_supplicant.services: disabled)
    Active: inactive (dead)

    --dmesg.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)

    As far as reverting , this file is back to where it was - etc/modprobe.d/ipv6.conf

    Unless I was in the wrong place before, cmdline.txt loks different, only has a single line.

    Is there a way to reset all connections to default?


  • Global Moderator

    @rasp_renegade said in WIFI issues:

    Is there a way to reset all connections to default?

    Edit the /etc/wpa_supplicant/wpa_supplicant.conf file and remove the contents related to your WiFi SSID. Edit /etc/network/interfaces and remove the stanzas related to wlan0.

    sudo: unable to resolve host MiPi02

    sudo not working seems still be a problem. If your /etc/hosts has the correct entries, check /etc/hostname and make sure the hostname is correctly set there. If it's not, try setting it using hostnamectl (you'll need root permissions to do that).



  • @mitu said in WIFI issues:

    @rasp_renegade said in WIFI issues:

    Is there a way to reset all connections to default?

    Edit the /etc/wpa_supplicant/wpa_supplicant.conf file and remove the contents related to your WiFi SSID. Edit /etc/network/interfaces and remove the stanzas related to wlan0.

    sudo: unable to resolve host MiPi02

    sudo not working seems still be a problem. If your /etc/hosts has the correct entries, check /etc/hostname and make sure the hostname is correctly set there. If it's not, try setting it using hostnamectl (you'll need root permissions to do that).

    You will have a good laugh at this... in the hosts file I had MiPi02, in the hostname file I had MiPi2. LOL

    Pinging MiPi02 now resolves to the loopback address. I can no longer see my WIFI network from the GUI of RetroPie now though. So be it.

    I am going to try to manually copy all info from the files listed in the quote above, from the good image into this one. This should work yes?



  • @mitu

    You forgot to ask me an important question, "Is there a copy of that image?"

    The answer is yes!!! I am now back in business. This time I will pay close attention to what the heck I am changing. This was a great learning opportunity, however, so thank you very much for your support. =)

    I have two cards for the sake of clustering, in case you were wondering.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.