Please do not post a support request without first reading and following the advice in

MAME 2003 Menu Config

  • I accidentally removed the TAB key from the menu that pops up for MAME when inside a game. Dont really need it, but want to fix anyway in case something comes up. Is there an XML file somewhere in retropie that I can go in and re-add so when I am in a game and want to open the MAME menu I can?

  • Technically is the MAME menu (inside game) even needed in most instances if using the ES control config? The only instance that I used it was when I changed control layout for Shinobi. Otherwise I havent needed to go into it like I did when MAME was on my PC. Any info much appreciated. THanks.

  • Global Moderator

    @common763 I think you're looking for the default.cfg , where mame2003 stores its configs - - which should be under a mame2003/cfg sub-folder of your ROMs folder. Delete the file and it should come back to defaults.

  • thanks.

  • that didnt work for me. I am hitting tab and the menu still not coming up.

  • Global Moderator

    @common763 Are you using Mame2003 or Mame2003-plus ?

  • MAME 2003. I found the file and deleted. On reboot when I hit the tab key in a game the menu isnt coming up. I have all my games stored in the Arcade folder so went to ROMS Arcade and MAME 2003. Deleted the config file and rebooted. It doesnt work so must be missing something.

  • @common763 this isn't a solution so much as a workaround, but in the latest versions of MAME 2003 you can activate the "MAME Menu" by turning on a Core Option after you press Start + Select.

    To update to the latest version of MAME 2003 you will need to update RetroPie-Setup and then build MAME 2003 from source. Again, this is a long way to go just to work around the problem, but for what it's worth, it's straightforward to access the MAME Menu in current builds via the core option even if you don't have a keyboard.

  • @markwkidd so I go into a game and hit start and select at the same time and it opens up this core option? I recently updated everything so it could work. This problem arose playing a game a couple weeks back and the controller went haywire, opened up menu and removed tab then closed.

  • It is listed among the other core options. Here's how it looks with RetroArch set to "XMB" menu driver. Yours should be similar:

    Screenshot 2019-03-17 15.48.13.png

  • this is kinda confusing. I dont see anything like that, but even if that was selected how would you get the MAME menu to display if the tab key or no other key is in the launch menu selection?

  • I didnt mention this, but when in the config folder there are a ton of files (games) other than default. do all of them need to be deleted for the MAME menu to reset?

  • Global Moderator

    @common763 Are they all .cfg files ? You might try deleting the .cfg file for the game you're starting.

  • Yes. I could just delete everything in the folder. I have it backed up so could just copy over afterwards. If I delete the default and leave the other files wouldnt it keep the tab key keep off since the other games may have that setting?

  • mitu-Your solution is the right one. This may help others, or I am just naive...There are a ton of these cfg files in there for specific games when I first put the pi together. Must have been messing with the MAME menu settings instead of retroarch in the beginning. When that tab key got accidentally removed it must have reflected all of those game configs in the same folder. Fix-I plan on removing all the files in this folder then rebooting. If anyone has a similar issue you may have to do the same because once that tab got removed it probably adjusted all those files too. thanks for your help mitu and markwkidd. appreciated.

  • works now. did as specified above and all set. thanks.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.