Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie w/ Analog config not working properly



  • Hey guys, I'm having a really weird problem in the PSX games. I'm using a DualShock4 and I set the controls to Retropie w/ analog, but when I boot any game only the digital buttons work, like if it was set to Retrpie only. The I open the quickmenu and it's correctly set to Retropie w/ analog. I then change it to Retropie and go back to the game, enter the quickmenu again and change back to Retropie w/ analog. Only then the analog sticks work. Why this happens?


  • Global Moderator

    I think you mean Retropad with analog. The settings are not persisted between games - if you want to have RetroPad with analog as default, then use the Core input remapping feature to save the configuration.



  • @mitu @ivooc
    When you play gran turismo, do you prefer to get european cars.
    I don't think I have any preference for american cars.

    Anyways, I tried to replicate this issue, all I found was that analog works regardless of the setting retropad or retropad w/ analog.
    For some games I do need to set the Pad Type under quickmenu>>options>>pad1type to dualshock or standard. and then save with the Create game-options file at the top.
    Hope this helps.

    I got a rx7 as my first car. I misread it and thought it was a '97 when it was a '90. You're kind of stuck getting a japanese used car, is there not used cars in the UK, I don't know I'm sure there are plenty for sale all over the world

    Its totally a licensing thing, the other companies couldn't form enough consent to allow their cars to be portrayed as used vehicles. It's kind of funny that kind of logic works backwards when you play the game and you're stuck buying a used Japanese car, and completely disinterested in the other makes. Until you want a muscle car... or a lamborghini.

    Really what I'm getting to is, I wouldn't mind having a used bug as my first car in gran turismo.



  • @Efriim said in Retropie w/ Analog config not working properly:

    @mitu @ivooc
    When you play gran turismo, do you prefer to get european cars.
    I don't think I have any preference for american cars.

    Anyways, I tried to replicate this issue, all I found was that analog works regardless of the setting retropad or retropad w/ analog.
    For some games I do need to set the Pad Type under quickmenu>>options>>pad1type to dualshock or standard. and then save with the Create game-options file at the top.
    Hope this helps.

    I got a rx7 as my first car. I misread it and thought it was a '97 when it was a '90. You're kind of stuck getting a japanese used car, is there not used cars in the UK, I don't know I'm sure there are plenty for sale all over the world

    Its totally a licensing thing, the other companies couldn't form enough consent to allow their cars to be portrayed as used vehicles. It's kind of funny that kind of logic works backwards when you play the game and you're stuck buying a used Japanese car, and completely disinterested in the other makes. Until you want a muscle car... or a lamborghini.

    Really what I'm getting to is, I wouldn't mind having a used bug as my first car in gran turismo.

    I actually wasn't aware of this configuration, don't know how I missed it. Guess I was focused on the Retropad part. This actually solved the problem, thanks

    @Efriim Lol, whats this rambling about Gran Turismo? haha



  • @ivooc no problem, I was in the same boat for a while trying to take on the layers of overrides.

    I wish the graphics were just a little better in gran turismo 2 the hi-res helps, I never used to be like that, just wan't a nice looking 60fps racer.



  • @mitu It was already my default configuration, that's why it was odd.



  • @ivooc it could be dynamically set, whether it detects retropad w/ joypad or not.



  • @Efriim I still don't fully understand the layers haha.
    Since I got my Pi 3B+, I have been a little disapointed with PSX emulation. I thought it was going to be pretty much flawless, but it isn't like that. Lots of games only run well in the original shaderless resolution, with only the bilinear filter making a bit better. CTR is great, but have slowdowns, specially in 2-player mode.



  • @Efriim said in Retropie w/ Analog config not working properly:

    @ivooc it could be dynamically set, whether it detects retropad w/ joypad or not.

    I think you mean with analog. Dynamically set? Hmm that I didn't know either.



  • @ivooc Yes, with analog.

    Two player worked for me, controllers didn't always, low voltage when charging and one of my old ds3s is burnt out. Toejam & earl for genesis, Marvel vs capcom 2 for dreamcast, darkstalkers3 for playstation, worked great. PSX emulation does well with an overclock.



  • I also upgraded from a rpi2 to rpi3b+ because of playstation emulation. I was disappointed but overclocking made almost all the unplayable games playable and everything else is really smooth. Though I miss that the rpi2 didn't need a fan at all.



  • @Efriim But does the Pi3b+ support overclocking? I always thought it was only up to the 3b.



  • @ivooc
    Yeah, overclocking is a thing on the rpi3b+. The config-tool raspi-config doesn't yet support setting overclock values, maybe because of various constraints like the rpi3b+ can get hotter than the earlier models and overclocking isn't at all feasible without some sort of cooling on the board.

    As per the raspi-config that sets the values for you, on the raspberry pi 3b+ you have to enter the values manually in the config.txt of the boot partition on your microsd. Ive read the warranty void bit is no longer a thing, but you should be aware that it may void the 1 or 2 year warranty from manufacturers or distributors.



  • @Efriim Hmm guess I'll take a look at this, maybe it'll improve PSX games and make some of N64 playable. You just did a CPU overclock or did you mess with other options like GPU clock, over volt, ARM clock etc? I've read that emulation on Pi benefits more from GPU core overclock.



  • @ivooc
    I borrowed the highest values that I've seen people use and sort of put them all together one by one.
    So yeah everything including voltage. I have a very minimal fan, and I think it would overheat if I put it on the carpet. I also have a powersupply with a very long cord, and sometimes 1/10 times on boot I will get low-voltage warnings when everything is maxed out. I'm hoping a different powersupply will solve this, but I could experiment more with the over_voltage and maybe figure out why it is only 1/10 times.

    The highest value's I use for the rpi3b+ are:
    arm_freq=1575 # I saw 1600 somewhere as the absolute max, but it proved unstable.
    gpu_freq=525 # v3d, h264 and isp all seem to share the highest value among these settings, I haven't tested any higher than this.
    core_freq=600 # I got this and the gpu_freq from shavedcat in this other thread https://retropie.org.uk/forum/topic/21519/opinion-on-overclock-settings/21 I went on a tangent about maximum voltages and the mistaken sdram_ over_voltage_sdram over my gpio powered case and no one pointed it out as the thread died.
    sdram_freq=600 #This was the last setting I adopted. the over_votage_sdram_p is an important part of making this stable.
    over_voltage_sdram_p=7 # (1.3750V) I've been using this value from the beginning and haven't had any crashes, p stands for physical. The default value is 1(1.2250V)
    over_voltage_sdram_i=3 # (1.2750V) I used 7 for the I/O and then changed it back to 3 since I noticed no difference in stability or boot time. The default is 2(1.2500V) and I think it works as well.
    over_voltage_sdram_c=3 # (1.2750V)The sdram controller is bumped up one as the default value is 2(1.2500V) as well.
    over_voltage=2 # (1.3875V) The cpu is fed from this but the rpi3b+ also dynamically increases the voltage for its needs. Due to a phase locked loop sometimes the voltage skews and I think this is part of the reason why I get low voltage only some of the time. I believe the maximum effective value is 3 and I believe that it is clamped to 1.3936V.



  • While those values were the highest, a lot of it isn't at all necessary for emulation, as well the configuration is a mash up and hasn't had any refining or fine tuning.

    I'm doing a few tests, underclocking without a fan, and seeing what I can play along with if I can stay under 60'C. I'm thinking I will be able to play quite a lot. I don't know about the temperature, using a stress test and cpu-burn the temp quickly jumps to 70' though it wont go much higher at all. I'm thinking emulation will stay cool as it is generally single core.

    so far with default gpu and
    arm_freq=900
    sdram_freq=450
    over_voltage=-2 # (1.2000V)
    Emulation is largely the same for psx, psp, n64, and dreamcast, the sound isn't quite perfect sometimes it is dropped at the likes of a transition or load screen, and maybe setting the sdram back to default will help.

    I tested
    PSX, Final Fantasy IX with hi-res, very nearly perfect. 54'C
    PSX, Breath of Fire III, very nearly perfect. 54'C
    ppsspp, Wild Arms XF, with 2xPSP, nearly perfect. 55'C
    ppsspp, Armored Core 3, frames dropped to 15. 55'C
    reicast, Deadly Skies, frames drop a little more than before. 55'C
    n64-gliden64, ocarina of time, stutters a finite amount in some places otherwise okay. 54'C
    n64-gliden64, majora's mask, I didn't get to gameplay, it was nearly perfect.

    I'm so surprised at these results, overclocking is overrated.



  • @Efriim wait, so are you saying you tested underclock with these games and barely noticed performance drops at all? I'm stunned by this! Most PSX games I've tried were unable to stay at 60fps with hi-res enabled at stock clock, including Crash Team Racing, Crash Bash (in the menus was already slow), World Soccer Winning Eleven 2002, FIFA 99 (this one dropped to an unplayable level). The only games that were stable (but even so stutter in cutscenes) were the Resident Evil series (1, 2 and 3). Again, all these with hi-res and stock clock. You think there might me something wrong with my Pi?



  • I haven't tried FIFA, and I forgot to test Gran Turismo again.
    I have played the RE series. I don't think you have anything wrong with your pi.

    I think it could be one of these retroarch settings,
    Run-ahead to reduce latency, or hard gpu sync frames, both found under latency.

    I switched back to my overclock, this time without the fan, I emulated for a bit and the temp slowly rose to about 61'C, but anything more intense or using multiple cores will definitely see the soft limit. I just wonder which emulator will do that.

    Also possibly, threaded rendering I would recommend this enabled.

    I think the temperature soft_limit must be ~60, as I notice the cpu being throttled to 1.2ghz.

    Yes the underclock was surprising, I used vcgencmd to confirm the cpu was 900mHz.



  • @Efriim But then the default latency options are bad? Because I have never messed with them.



  • @ivooc The settings and operating system updates are more likely than a pi being bad, what manufacture is it? Mine is an element14.
    Also what are those two latency settings now? and was threaded rendering enabled?
    I'm sort of unsure for them being default, I think you are right:
    Threaded enabled
    Hard GPU sync disabled
    Run-Ahead disabled



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.