Please do not post a support request without first reading and following the advice in

Odroid XU4 SDL Problem Emulationstation

  • Global Moderator

    @ray3d You seem to have the correct SDL library installed (2.0.8+1mali is installed by the RetroPie script).
    The advice about the OpenGL experimental driver on the PI doesn't apply to Odroid.

  • Yes it seems correct. I will try to look for more but Is very strange. Everything is there.

  • Global Moderator

    @ray3d Are you running Emulationstation from the terminal or from the desktop environment ?

    Try running it like this from the terminal

    SDL_VIDEO_EGL_DRIVER=/usr/lib/arm-linux-gnueabihf/mali-egl/ emulationstation --debug

    and see if you get a different result.

  • I’m running now all the tests via SSH: I gave your command and these are the results:

    SDL_VIDEO_EGL_DRIVER=/usr/lib/arm-linux-gnueabihf/mali-egl/ emulationstation --debug
    lvl2:   EmulationStation - v2.7.6rp, built Mar 31 2019 - 02:33:22
    lvl2:   Creating surface...
    lvl2:   Created window successfully.
    terminate called after throwing an instance of 'std::logic_error'
      what():  basic_string::_M_construct null not valid

    What means that?

  • Global Moderator

    @ray3d Looks to be working, you're using an older version of Emulationstation and there's something wrong with your installation.

    Did you install from the RetroPie-Setup script or from a 3rd party image ? Did you update your RetroPie-Setup script - what version are you using ?

  • I had from last year the image and I constructed carefully but I didn’t remember present these problems but now I’m a fool because I didn’t make the backup of some things :( Look this is the file: “” and it says _version="1.65 FINAL". What I did is go to:

    sudo ~/RetroPie-Setup/

    Then update retro pie script and that’s all because I don’t know how to update more. Well what I did also went to manage then core and update all from source that are the two things I did nothing else. How can I update maybe with commands and not the GUI? But I don’t know how.

  • Global Moderator

    @ray3d Can you show a screenshot after the start of the setup script - the version should be shown there. The script is not showing the version.

  • This is the picture of what I see:

  • Global Moderator

    @ray3d This is not the RetroPie-Setup script distributed by the RetroPie project - it's probably a 3rd party image (ORA maybe ?). We don't support those images, you should probably ask the creator(s) for support.

  • I installed everything as it says here with the latest version:

    I deleted from the retropie setup directory:

    Now I see:

    But same error emulationstation. or line for same error. When I installed the new retropie it took almost 3 hours it was a lot of time but did nothing. Same SDL error :(

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.