Please do not post a support request without first reading and following the advice in

lr-mame2003 Controls Issue

  • I have searched through many of the forum posts so far which has allowed me to get retropie setup on my Raspi3 with the IPAC2 controller. I have mapped my controls with both the EmulationStation configuration and also manually in the retroarch config settings and directly using the retroarch.cfg file. Everything is working exactly as I want except for the right d-pad direction using the joystick for player 1. It is not a physical issue because the right direction works in emulationstation however it does not work on any of the games I run using lr-mame2003. I have double checked that all of the keys are correctly mapped using both winIPAC and the retroarch.cfg file. I currently have the player 1 right button mapped to "m". I have changed it a few times to different keys (such as "u")thinking it might solve the issue but it has not. The problem only seems to be occurring in lr-mame2003. Any Idea as to what I might be doing wrong. It seems strange to me that it is a single button that is not functioning properly.

  • I have uninstalled/reinstalled retropie and reconfigured the controls in emulation station and retroarch.cfg. I am getting the same exact issue where all controls and buttons work except for player1_right in lr-mame2003. Is there anything pre-assigned or special about either the "u" or "m" keys in lr-mame2003 that would cause such an issue?

  • Global Moderator

    @Binger88 I think 'm' is bound to the Next Shader action in the default RetroArch keyboard mapping - Do you have a Hotkey set for RetroArch ?

  • @mitu I just tried to remap the key using winIPAC to "j" and also player1_right in retroarch.cfg to "j". I reconfigured the controller in emulationstation and I still have the same error where the right direction will work in ES but not in lr-mame2003. I have player1_start set as my hotkey with maps to different buttons for save,load, etc. The hotkey and all of my shortcuts are working perfectly.

  • Global Moderator

    I don't know if j is also a RetroArch action - have you tried pressing tab to get the Mame menu and map the inputs there - directly ?

  • @mitu I redid the controls again for the "v" key (from everything I can tell this is not used elsewhere). This time I used the in game menu with the tab key. Still the right direction does not work. Also I have several existing directional buttons mapped to keys that are used for other functions but all of those keys are functioning normally.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.