Please do not post a support request without first reading and following the advice in

  • @hhromic Thanks For getting back to me, i'll be away from my rasberry pi until tomorrow night so i cant get you the verbose logging file right away, but can when i am near it. (also i know where/ how to access it on the pi through the file browser, thats where i saw the "Value too large for data type" error, but not sure how to send it to my PC to post here.)

    My Retropie version is 4.4, (i know there's more to it, i will get you those details when im near my pi again). i last ran an "update setup script" and updated software on 3/29/19 if that helps. After doing that i also went to manage main packages, and updated all from source, so the lr-pscx-rearmed should be up to date as well.

    The games crash as soon as i launch. Both give me the option to open the boot menu, where i can change the resolution, default emulators and such, but after that a black screen for a second, then im back at the games list.

    To answer your edit question, i have updated the emulators from the source before and i'm familiar with the file manager on retropie, i've edited a few lines from my scraped games-list files, so if its similar to that then yes i am familiar with editing.

    I really appreciate the help.

  • @SteveXmetal sounds good! take your time and whenever you can just post that info, no rush.

    and updated all from source, so the lr-pscx-rearmed should be up to date as well.

    That is good. Just to confirm, open the RetroArch menu (HOTKEY + X) and write down what do you see in the down-left corner, the core version and git commit hash. Should be somethin like "r22 abcdefgh".

    The games crash as soon as i launch. Both give me the option to open the boot menu, where i can change the resolution, default emulators and such, but after that a black screen for a second, then im back at the games list.

    Ok then I definitively can confirm that it doesn't happen on my Raspberry Pi 3B. I will test later tonight with my Raspberry Pi 3B+, but I think it will also work.

    Also can you post later the file size of your PBP images that aren't launching?

    EDIT: one more question, are you using some sort of network share or USB mounting for your roms location? Or are you copying directly to the SD card?

  • Convert to PBP and rename each disc to hide them and write an .m3u

    Sorry for the misinterpreted advice, I edited this so it should work again, and remember it is all case sensitive. The period before the filename denotes a hidden file in unix, that is exactly why it is used to hide the PBP from Emulationstation.

    If an m3u index is made for each disc then it will allow you to both start the game on any disc and change discs in game.

    Final Fantasy 8 (Disc 1).m3u
    .FF8(Disc 1).PBP
    .FF8(Disc 2).PBP
    .FF8(Disc 3).PBP
    .FF8(Disc 4).PBP

    Order of each .m3u index changes. On disc 2 the index for disc 3 remains remains the same, you could employ your own research method here.

    Final Fantasy 8 (Disc 2).m3u
    .FF8(Disc 2).PBP
    .FF8(Disc 1).PBP
    .FF8(Disc 3).PBP
    .FF8(Disc 4).PBP
    Final Fantasy 8 (Disc 3).m3u
    .FF8(Disc 3).PBP
    .FF8(Disc 1).PBP
    .FF8(Disc 2).PBP
    .FF8(Disc 4).PBP
    Final Fantasy 8 (Disc 4).m3u
    .FF8(Disc 4).PBP
    .FF8(Disc 1).PBP
    .FF8(Disc 2).PBP
    .FF8(Disc 3).PBP

    Then symlink a memory card "" for each "*.m3u" name.

    for i in *.m3u; do ln -s "${i%.*}.srm"; done

    or with "Final Fantasy 8 (Disc 1).srm"

    for i in *.m3u; do ln -s "Final Fantasy 8 (Disc 1).srm" "${i%.*}.srm"; done

    Those will link all .m3u games in a folder to the .srm/.mcd; if there are already .srm entries then the link will not be created.

    The entirety can be done and used by ES in a sub-folder. Game Art can be added for the folder and for each disc though it is a rather manual process to get disc art.

  • Global Moderator

    @Efriim said in PSX "Value too large" to launch after update:

    I write multiple .m3u for every disc.

    Why ?

  • @mitu to start on a disc.
    If I think of a script for writing the .m3u I will share it.

    Why would I want to start disc 1 if I am on Disc 2.
    They share an index so index 4 is always disc 4 unless disc4.m3u and they share a memory card.

  • @Efriim thanks but that is not an appropriate solution for the original problem reported in this topic.

    Please do not post unrelated/misleading information until the actual problem is sorted out and resolved. In this way, we don't introduce noise into the topic. Thanks for understanding.

  • @SteveXmetal I tested Riven last night also on my RPI 3B+ and launches fine too.
    Let's see if we can reach to the bottom of this mystery.

  • @hhromic Thanks for continuing to look into my issue:

    im running retropie version: 4.4.11
    my retro-arch version/ emulator is : 1.76 - psxreARMed r22 588bf79

    I tried downloading another version of final fantasy 8, that does not work either.
    File sizes:
    Final fantasy 8 (used to work, played through disk1)- 2,160,718 KB
    FF8 new - 1,838,285 kb
    Riven - 2,580,553 kb

    This may not be a file size issue because i also have a FF9 .pbp and that does launch, it is bigger than the new FF8 file. My FF9 file is 1,844,731 KB

    Looking at this log file it may be a RAM issue?
    Also i have tried several BIOS files/versions, all fail.

    here is the pastebin for my issue:

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/ --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Final Fantasy8.PBP" --appendconfig /dev/shm/retroarch.cfg
    Memcard 2: enabled
    Use memcard 2: /home/pi/RetroPie/roms/psx//
    Starting PCSX-ReARMed 
    Running PCSX Version 1.9 (Apr  3 2019).
    psxMap: warning: wanted to map @80000000, got 0x6f4b4000
    Init new dynarec
    testing if we can run recompiled code..
    test passed.
    warning: RAM is not directly mapped, performance will suffer
    Mapped (RAM/scrp/ROM/LUTs/TC):
    Loading memory card /home/pi/RetroPie/roms/psx//
    found BIOS file: scph1001.bin
    RGB565 supported, using it
    plugin: plugins/builtin_gpu
    plugin: plugins/builtin_spu
    plugin: plugins/builtin_pad
    plugin: plugins/builtin_pad
    Plugins loaded.
    Could't open '/home/pi/RetroPie/roms/psx/Final Fantasy8.PBP' for reading: Value too large for defined data type
    Error opening CD-ROM plugin!

    Thanks again any help is appreciated!

  • Same issue with FFVIII in PBP format on RPI 3B+.
    Single CD .bin/.cue works without problems.
    Already tried updating retroarch, core, emulationstation from bin and from source with no luck.

    Here is the runcommand.log


  • @zeroblu3 quick question zeroblu3, did yours work before updating like mine did?
    IF so what disk where you on? i got up to and played partway through the beginning of disk 2.

  • @SteveXmetal
    yes it worked a few weeks ago before i updated retropie from the update script.
    I only tested if the game worked like 20 minutes into the first disc but now all i get is just a crash back to emulationstation.

  • Global Moderator

    What version of RetroPie are you using ? The 4.4 image or an older image updated to 4.4 ?
    @hhromic this looks suspiciously like a missing define for _FILE_OFFSET_BITS 64 (see Maybe caused by the recent zlib changes.

  • @mitu
    i started a fresh build using the latest 4.4 image

  • Global Moderator

    @zeroblu3 I don't fully understand your update - are you saying you started from a 4.4 fresh image, you updated and you got this problem ? Or that you're now, after noticing this problem, starting with a fresh 4.4 image ?
    Can you add more info about your system - ?

  • @mitu
    oh sorry for the confusing answer. ^^
    I initially started a fresh build using the latest 4.4 image, put my games library on the Pi and just tested a few games including FFVIII, then updated retropie with the update script. Yesterday i decided to start FF and run into this problem.
    Sorry for my english too btw, i'm not a native speaker.

  • @mitu
    I'm running a Raspberry Pi 3B+ with a 2.5A power supply.
    Linux retropie 4.14.98-v7+
    Here is the full verbose runcommand.log

  • @mitu I looked into the post that you linked to, this is what i suspected with large game files, however, this doesnt necessarily explain why a different and smaller FF8.pbp does not launch, while my larger FF9 file does. Aslo, i tested a few other larger files, like lunar star story 2, and all of those can work with no issues.

  • @SteveXmetal
    I tried to run the FFVIII.PBP with the "non libretro" PCSX Rearmed emulator and it runs with no problems. If i try to run it with pcsx-rearmed-libretro it crashes to ES.

  • @mitu said in PSX "Value too large" to launch after update:

    @hhromic this looks suspiciously like a missing define for _FILE_OFFSET_BITS 64 (see Maybe caused by the recent zlib changes.

    Yes that is my exact guess about what is going on. However it puzzles me that I can't reproduce it on my system and that now @SteveXmetal reported it works for other games that are large too.

    Yesterday I already backported the check for _FILE_OFFSET_BITS from the configure script in here:
    Anyway I want to confirm if this works for @SteveXmetal and @zeroblu3, and then submit the patch upstream. Thanks for the heads-up in any case.

    @SteveXmetal @zeroblu3 can you guys please try the following steps to patch the core and test the fix to confirm this helps with your problem?

    ((now fixed upstream, no need to manual patch anymore))

    During the build phase, make sure the flag -D_FILE_OFFSET_BITS=64 can be seen in the compiler commands output. Then test the games and let me know if they launch. Hopefully they do.

    If confirmed working, I will send the patch upstream and then report back when is merged. Thanks for testing guys!

    EDIT: @SteveXmetal @zeroblu3 guys can you confirm your roms are on th e SD card and not on a USB or network share? just to be sure of all the conditions. Thanks.

  • @hhromic Thanks for helping out.

    I ran the codesby exiting emulationstation, running typing them in order and reseting my machine when they were done (if there is a better way please let me know, still a bit new to this).

    Still did not work. Checking the log, I got the same error.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.