Please do not post a support request without first reading and following the advice in

Bricked Retropie?

  • Hello, I'm writing because my Raspberry pi b3+ running retropie seems to have bricked? Everything was running just fine, all up to date, and I was in retropie setup script managing packages, I accidentally installed "powerblock drivers" misreading it, and the second I did that it went black screen, I can boot my pi back up, but as soon as it shows the retropie logo it just goes to a blackscreen. I found a command to uninstall the driver, but the problem is that I can't get back into the terminal to run it. Like I said as soon as I boot, it shows the raspberry logo, then the retropie logo, then permanent black screen. Any help would be appreciated.

    Edit: was able to get a quick video to see what my pi says while booting below the 4 raspberry icons.
    [Failed] Failed to start Load Kernel Modules.
    See ' systemctl status systemd-modules-load.service' for details

  • Boot any linux distro, backup your ROMs folders and files, after, download the last retropie.img and flash it to sdcard, wait boot and restore your files. Simple.

  • Well the goal was kind of to avoid losing over 6 hours worth of updates, and another 3 days worth of custom settings, config edits, package installs, etc. Spent over 12 hours getting Bluetooth speakers setup and working with retropie as is. But since no-one had any input or ideas, yes sadly had to resort to a complete loss of everything and reinstall from scratch to get functionality back.

    ON a side note to your reply, there was zero possibility to backup any roms and or files due to the fact I could not access terminal once selecting retropi from noobs, nor could I access my files via ssh, pc, winscp, etc. Whatever happened seemed to completely total my sd card and somehow add an extra 8 partitions. Call it a freak accident or what not. But for anyone who finds this thread, DO NOT accidentally install powerblock drivers if not using it. Totally messed up my Pi and lost all progress.

    Only way out of that mess was to completely wipe old sd, and use a tool to clone original sd that came with purchase to swap noobs/retropie back over and start from scratch.

  • @coltenxxx

    I'm not familiar with the powerblock devices. It probably uses the systemd to start the service, there must be a way to circumvent this before boot. It would be worth checking the config.txt in case this added any dtoverlay to the config.

    I see... I read the posts, that is unfortunate. I think wmarcio was suggesting using a linux operating system to mount the sdcard partition and backup from there, or the possibility of finding and disabling the systemd service to restore your system.

    It is possible to migrate most of the retropie installation through winscp. Outlined here.

    Though libraries updated will need to updated again. Configurations would be saved.

  • Appreciate the insight, wasn't condemning him for his reply. Just explaining things since it seem he mis understood a tiny bit. But I'm not sure, I tried everything to recover it with no luck. I checked the config/cmdline text in noobs menu, nothing. Unfortunately, I had no other way to check the files/contents since I don't have any other linux os capable devices (that i know of). If I would've been able to gain access to the retropie section of the SD, it might have been possible, but that driver did something very strange. Like I said, I had roughly 4 partitions before, and after that driver messed things up, I had a total of 12 partitions on the sd. (8 additional created somehow after the driver incident). It was very strange. All I know is stay well away from that setting now lol. In the process of re-setting everything back up. Thanks for the input though.
    Also, I tried using "//RETROPIE via network sharing, and winscp as I noted above, but somehow was unable to gain access whatsoever. Not sure if the system was in a "non connected" state to wifi or what since it wouldn't access files via either way.

  • @coltenxxx
    That is strange, I'm not sure what the powerblock is, I think it connects to the GPIO and is used with the GameboyZero to provide a steady powersupply from the battery.

    There are Linux liveboots that are relatively small downloads, mostly universal and require no installation only writing to an empty USB drive.

    Anyways learn something new. I'll avoid unintended driver installations.

  • Global Moderator

    The powerblock driver is expecting the actual device to be present, its detection service is shutting down the PI - on boot - because it thinks the power off button is pressed.
    This problem has been solved at some point, so as inadvertent installations like yours would not 'brick' the OS - what version of RetroPie are you using ?

  • It was definitely strange. But I was on the very latest of absolutely everything. 4.4 I do believe.
    At least it should've been the very latest since I've done every single in menu update possible, I've done the apt-get update, apt-get upgrade, I've done apt-get rpiupdate etc.

  • Global Moderator

    @coltenxxx OK, so you actually installed it and enabled it - the modification I was talking about was the the driver was not automatically enabled after install, the user must explicitly enabled it.
    The only way to recover it is to read the card from another Linux installation and remove the powerblock service (/etc/init.d/powerblock) from the Linux partition.

  • @mitu Yep that's perfectly understandable now. That was a big whoops on my part misreading it (blame being up for 18 hours) and installing. At least now, people who run into the same issue have this thread as a reference page. Sucks to have lost it all with no other way to access linux for me, but now we know and hopefully others see this. Thank you all for the feedback and input. Tough learning lesson indeed.

  • @coltenxxx just download ubuntu and read how to put it on a thumb drive. Boot it and dont install it to your pc. just run it and in there you can remove that file.

  • Edit: So as to what mitu and the others spoke of, I feel so dumb. Like I said earlier, I was able to boot into noobs just fine, and I had raspbian full installed at the same time as my retropie. I tried accessing the files for retropie that way earlier to see if I could recover my retropie or change configs or remove powerblock drivers, etc... But the issue I had was nothing showed up under the Raspbian desktop file manager earlier. I reinstalled everything after having lost it all earlier, and when I reset up my raspbian desktop just now, I got a link for retropie on the desktop. GO FIGURE, it only showed up after updating and rebooting raspbian desktop....
    Since i rarely ever use the desktop os and mainly only ever use retropie, it didnt cross my mind to try updating and rebooting raspbian and see if I could access those files again. So to reiterate, as the others have mentioned if anyone ever stumbles across this and is in the boat I was in, if you're lucky enough to have raspbian installed as well as your retropi, you CAN access your retropie files and fix the mess as mitu said. Hopefully this saves someone else 6hrs+ of recovering lol.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.