Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie x86 - audio 'pop' when loading games



  • Every time when the actual game is loaded you hear a brief 'POP' out of my speakers.
    I have this with every game tested.

    Running Ubuntu 18.0.4.2 with the latest RetroPie, hardware is connected to my TV through HDMI.

    Anyone know how to fix this?



  • Any one have a clue?



  • @Panja I used to have my Retropie connected to a monitor with built in speakers, had the same issue. I turned down the Retropie volume a bit, helped a little. Switched to a different monitor, issue went away. Do you have another screen you could test it on? Check out this link, might provide a solution: https://dbader.org/blog/crackle-free-audio-on-the-raspberry-pi-with-mpd-and-pulseaudio Scroll down to read: Update: The problem seems to be fixed
    EDIT - Please back up your system before trying anything from this page, just in case something goes wrong. Not sure if this works for x86 retropie.



  • Thanks for the reply.
    Unfortunately that doesn't fix it for me.

    Also the problem is on multiple TV's.
    I have 2 TV's and tested on both.

    It's not a show stopper, it's just annoying.
    It's not really a cracking sound it's a (pretty loud) pop sound when the actual game loads.



  • I don't know if it's related but I'm also seeing an error message when loading games:

    lvl0: VolumeControl::init() - failed to find mixer elements!
    


  • @Panja said in RetroPie x86 - audio 'pop' when loading games:

    failed to find mixer elements!

    Found a link here describing the same error. The user at the bottom of the topic found a solution that worked for them: https://retropie.org.uk/forum/topic/11256/failed-to-find-mixer-elements/6



  • Thanks again!
    Already set the Audio Device to PCM.
    Though I did it through Sound Settings in ES menu.
    After checking the file through SSH, it's indeed change to PCM.

    But without luck, problem remains.



  • @Panja Is this Stretch or Jessie? My research seems to indicate this issue happened with Jessie, but was fixed with Stretch.



  • I'm running Ubuntu 18.04.2 (Bionic Beaver), not running Debian or Rasbian.
    (It's running on x86 hardware)



  • @Panja Apologies my friend, I've gotta tap out. Beyond my level of knowledge. Hopefully one of the smarter people on this board chime in.



  • No worries man. Thanks for trying! Appreciated.



  • I just did a fresh install of Ubuntu 18.04.2 and a fresh install of RetroPie.
    With this new installation I have found the problem (bug?)!

    When I disable navigation sounds in sounds settings (EmulationStation) the problem returns. When loading a game and the game starts: POP!
    When I enable navigation sounds in sounds settings (EmulationStation) the problem is gone!

    To be honest it's a but frustrating because I do not like the navigation sounds in my ES Theme but it's good that I found the problem...

    [update]
    Fixed it by creating a silent WAV file and replaced the navigation sound files in:
    /etc/emulationstation/themes/carbon/art
    There are 2 WAV files in there which I replaced. Probably only one was the culprit for me but I changed them both.



  • @Panja

    Had originally replied over on the 18.04.1 thread which you posted on, but will reply here - glad to see you have a workaround for it.

    I (think) my navigation sounds are turned on, need to check - also the theme I use (Chicuelo) doesn't have any wav files or scrolling sounds though, so I don't think i've ever played around with that setting. I don't get any pop or ALSA errors.

    Do you still get ALSA related errors with the navigation sounds turned on? Or does that only appear when the option is turned off?



  • Sorry, been away from the keyboard for a few days.

    Thanks for your replies!
    I re-installed and I do not have any errors anymore.
    Though I still have the POP sound when launching a game.
    But fixed (workarounded) with a silent WAV file.



  • @Panja said in RetroPie x86 - audio 'pop' when loading games:

    Sorry, been away from the keyboard for a few days.

    Thanks for your replies!
    I re-installed and I do not have any errors anymore.
    Though I still have the POP sound when launching a game.
    But fixed (workarounded) with a silent WAV file.

    Well i switched to Kubuntu 19.04 at work this morning and came across your issue and since i remembered this post thought it would be nice to list my fix.

    So the issue seems to be that after a few seconds of silence it would put the audio chip in sleep mode causing a pop whenever any audio file was being played afterwords...drove me nuts for the first few minutes setting up this thing and hearing a pop with every ding noise!

    I came across this when googling it: Pop noise

    If it goes down do the following:
    sudo nano /etc/modprobe.d/alsa-base.conf

    and at the very bottom add the following line:
    options snd-hda-intel power_save=0 power_save_controller=N

    Then probably reboot.

    I hadn't been able to reproduce this before because my main machine is AMD and this problem is Intel specific.



  • Thanks for helping out mate, appreciated!
    Will have a go with this in a few days and let you know.
    Cheers.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.