Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

DOSBox - Keyboard mapping issue - works while outside emulationstation, all wrong keys while in ES



  • I originally had Lr-Dosbox installed and I think that its possible Retroarch messed up the configuration for ES.

    Now, only Dosbox is installed. When start dosbox inside emulation station, they keys are all mapped wrong.

    instead of "asdf" it types "uiop"
    Delete key types 5 and qwer types 7890

    I am using the same .conf file each time and yet somehow it only does this when launching from inside ES.

    Here is the first part of the .conf

    fullscreen=false
    fulldouble=false
    fullresolution=original
    windowresolution=original
    output=surface
    autolock=true
    sensitivity=100
    waitonerror=true
    priority=higher,normal
    mapperfile=mapper-SVN.map
    usescancodes=true

    the mapper-SVN.map file is in the normal place.

    Any ideas on why this works at the command line or in Pixel desktop but doesnt work when launched in ES?



  • @doubleeuroz Set usescancodesto false.

    Any reason why it's set to true? The DOSBox scriptmodule sets it to false.



  • I tried both values for the usescancodes and both failed.

    However, i was able to finally make it work by setting the Keyboard type to us instead of auto.

    I dont know why this would break based on if it is run from inside ES vs command line. My locale is set right.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.