Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Random 'Ghost' input despite using Bluetooth dongle



  • Hello all.

    My setup is detailed in my signature. When I first started using RetroPie, I had terrible trouble with my Wii U Pro controllers causing 'ghost' inputs (random button presses which kicked me out of games). This problem was resolved by using a Bluetooth dongle, and disabling the on-board Bluetooth (adding dtoverlay=pi3-disable-bt to my config.txt file) and all my 'ghost' issues went away...until last night...

    I was playing the PlayStation version of Final Fantasy 6 using lr-pcsx-rearmed and went to create a save state (Select + Right Trigger), and got booted back to EmulationStation. Re-loading up the game confirmed I hadn't cleanly exited as my .srm file (or in-game save file) was an older version. I should add that I had successfully created a save state about 5 mins beforehand (just before a boss fight), so luckily didn't lose much progress as could just load that state. I also should say that following this I was able to create a save state again, and cleanly exit after using an in-game save point (using Select + Start). So before and after worked ok.

    So this could just be a completely random event (I have had many hours of trouble-free gaming), or maybe the issue is returning. So, just to rule this out, is there any command I can enter on the command line that would allow me to confirm the on-board Bluetooth is definitely disabled? And if so, what should I be looking for in the resultant output?

    Yesterday I just lost a little bit of confidence in my setup, and am slightly worried that this could happen again, and that I could lose more progress on games when I get kicked out. Or am I just being a bit over-dramatic??

    Anyone else had a similar situation? Especially with a Wii U Pro controller but having a dongle?

    Thanks.

    P.S. Ah, the only thing that I've changed since I last played was I enabled SSH and set up Putty on my PC. Could this have caused anything to go awry? I didn't have an active session but upon shutting down the system I did see some messages about SSH but it was too quick for me to read them (I wasn't expecting them to appear). I think I'll disable it anyway until I actually need to use it, just in case that had something to do with it.


  • Global Moderator

    @omen_peter said in Random 'Ghost' input despite using Bluetooth dongle:

    P.S. Ah, the only thing that I've changed since I last played was I enabled SSH and set up Putty on my PC. Could this have caused anything to go awry?

    No, that wouldn't affect things. If you have disabled the onboard BT via the config file, then it should be disabled, but if you want to check, just unplug the USB dongle and check if your controller can connect.



  • @mitu thanks for the speedy reply! Good to know that SSH shouldn't be affecting anything. Yes, removing the dongle and testing makes perfect sense to me! I'll do this and let you know how I get on (may not be for a couple of days).



  • @omen_peter said in Random 'Ghost' input despite using Bluetooth dongle:

    Hello all.

    My setup is detailed in my signature. When I first started using RetroPie, I had terrible trouble with my Wii U Pro controllers causing 'ghost' inputs (random button presses which kicked me out of games). This problem was resolved by using a Bluetooth dongle, and disabling the on-board Bluetooth (adding dtoverlay=pi3-disable-bt to my config.txt file) and all my 'ghost' issues went away...until last night...

    I was playing the PlayStation version of Final Fantasy 6 using lr-pcsx-rearmed and went to create a save state (Select + Right Trigger), and got booted back to EmulationStation. Re-loading up the game confirmed I hadn't cleanly exited as my .srm file (or in-game save file) was an older version. I should add that I had successfully created a save state about 5 mins beforehand (just before a boss fight), so luckily didn't lose much progress as could just load that state. I also should say that following this I was able to create a save state again, and cleanly exit after using an in-game save point (using Select + Start). So before and after worked ok.

    So this could just be a completely random event (I have had many hours of trouble-free gaming), or maybe the issue is returning. So, just to rule this out, is there any command I can enter on the command line that would allow me to confirm the on-board Bluetooth is definitely disabled? And if so, what should I be looking for in the resultant output?

    Yesterday I just lost a little bit of confidence in my setup, and am slightly worried that this could happen again, and that I could lose more progress on games when I get kicked out. Or am I just being a bit over-dramatic??

    Anyone else had a similar situation? Especially with a Wii U Pro controller but having a dongle?

    Thanks.

    P.S. Ah, the only thing that I've changed since I last played was I enabled SSH and set up Putty on my PC. Could this have caused anything to go awry? I didn't have an active session but upon shutting down the system I did see some messages about SSH but it was too quick for me to read them (I wasn't expecting them to appear). I think I'll disable it anyway until I actually need to use it, just in case that had something to do with it.

    Do you have the dongle plugged into the upper left hand port ( Port 0) ?
    Rasp Pi usb ports.png

    I have one official Wii U Pro and 4 knockoffs (all connected using a Mayflash adapter) and as the same as you..had ghost connections using the onboard BT. Disabled the onboard BT..I then configured it with the dongle plugged into a diff port other than port 0. No go. I finally plugged into that port and voila..works fantastic. Very good all around controller for all sorts of emulators / consoles and the other knockoff ones work as well.
    (official Wii U Pro is very new to the family) :-)



  • Hi @mitu I just turned on my pi without the bluetooth dongle attached and my controllers wouldn't connect. Plugged it in and they did connect. So thanks that has proven that I correctly disabled the onboard bluetooth!

    Hi @ByteThis I was very interested in your post. In fact, my bluetooth dongle is actually in port 2 (using your pic, so upper right) with my mini keyboard wireless adapter in port 0 (looks like I use port 3 for my portable HDD). From what you suggest, I am going to swap my adapter and dongle round, so that my dongle is in port 0. Fingers crossed! Thank you! What happened when you used a different port then? Still random inputs?



  • @omen_peter I think this can help too.
    This script disables or enables WiFi on the fly.
    https://retropie.org.uk/forum/topic/19734/enable-disable-wifi-with-rfkill



  • @cyperghost thanks will check that link out!

    I switched everything round, loaded up a random playstation game (2002 Fifa World Cup) and hit various hotkey combos (save state, load state, retroarch menu, exit emulator) a few times. All seemed to work without issue. The main test will be a longer play with testing throughout so will see how it goes.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.