Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Pi Model or other hardware: Pi 3b
    Power Supply used: Ankru 5v 3a
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.4.12
    Built From: pre made from retorpie
    USB Devices connected: Lexar 32gb USB Drive
    Controller used : iNNEXT Snes Style USB

    Hi, so i have had my Pi 3 running for awhile without any problems (snes,nes and megadrive roms) scraped using steven selph
    i added some Mame roms and again everything was working smoothly.
    so i used skyscraper for the Mame roms only and that worked fine.

    i know have an issue with mastersystem and Megadrive roms will only load into a black screen when selected, i've tried changing the emulator and have used - lr-fbalpha-sms, lr-genesis-plus-gx, and lr-picodrive all resulting in either a black screen or just backing straight back into rom selection.

    however, if i reload my saved image before using skyscraper to scrape the mame roms, everything works fine.

    any suggestions, or is it just a case of not using skyscraper for the mame roms?.

  • Global Moderator

    So you've scraped the arcade ROMs and then the Sega MasterSystem/Megadrive games won't work ? Doesn't seem like there's a relation between the 2 events.

    Can you get the log from the emulator starting one of those ROMs:

    • start the game and use the Runcommand launch menu to select the Launch with verbose option (use lr-picodrive, I think that's the default emulator).
    • after the emulator returns to Emulationstation, get the /dev/shm/runcommand.log file from the Pi and post it on pastebin.com.

  • okay, so i can see the log file. i am at a total loss on how to get the log into pastebin.. been trying to find a guide, but had no luck so far.

  • Global Moderator

    @shayne66 Copy the file to your PC and then open it in a text editor, then copy/paste the contents.
    Alternatively, run the following command from the command line and post the link shown by the command

    cat /dev/shm/runcommand.log  | curl -F 'f:1=<-' ix.io
    

  • shayne66 Copy the file to your PC

    thats the bit i can't figure out how to do.


  • @shayne66 My preferred method is run the cat /dev/shm/runcommand.log command in a SSH session from a PC. From there, it is a straightforward task of copying the output to pastebin.

    You can find more info on SSH here: https://retropie.org.uk/docs/SSH/

  • Global Moderator

    @shayne66 said in rom's load into black screen.:

    thats the bit i can't figure out how to do.

    You either use WinSCP to get the file or copy the file to the ROMs folder (cp /dev/shm/runcommand.log $HOME/Retropie/roms), from where you can open it with a text editor from your PC.


  • Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/megadrive/retroarch.cfg "/home/pi/RetroPie/roms/megadrive/Sonic The Hedgehog 2 (W) (REV01) [!].gen" --verbose --appendconfig /dev/shm/retroarch.cfg
    [INFO] RetroArch 1.7.6 (Git 9750719)
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/megadrive/Sonic The Hedgehog 2 (W) (REV01) [!].srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/megadrive/Sonic The Hedgehog 2 (W) (REV01) [!].state".
    [INFO] === Build =======================================
    Capabilities: NEON VFPv3 VFPv4
    Built: Apr 30 2019
    [INFO] Version: 1.7.6
    [INFO] Git: 9750719
    [INFO] =================================================
    [INFO] Loading dynamic libretro core from: "/opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so"
    [INFO] [overrides] no core-specific overrides found at /home/pi/.config/retroarch/config/PicoDrive/PicoDrive.cfg.
    [INFO] [overrides] no content-dir-specific overrides found at /home/pi/.config/retroarch/config/PicoDrive/megadrive.cfg.
    [INFO] [overrides] no game-specific overrides found at /home/pi/.config/retroarch/config/PicoDrive/Sonic The Hedgehog 2 (W) (REV01) [!].cfg.
    [INFO] Shaders: preset directory: /home/pi/.config/retroarch/shaders/presets
    [INFO] Shaders: no game-specific preset found at /home/pi/.config/retroarch/shaders/presets/PicoDrive/Sonic The Hedgehog 2 (W) (REV01) [!].cgp.
    [INFO] Shaders: no game-specific preset found at /home/pi/.config/retroarch/shaders/presets/PicoDrive/Sonic The Hedgehog 2 (W) (REV01) [!].glslp.
    [INFO] Shaders: no content-dir-specific preset found at /home/pi/.config/retroarch/shaders/presets/PicoDrive/megadrive.cgp.
    [INFO] Shaders: no content-dir-specific preset found at /home/pi/.config/retroarch/shaders/presets/PicoDrive/megadrive.glslp.
    [INFO] Shaders: no core-specific preset found at /home/pi/.config/retroarch/shaders/presets/PicoDrive/PicoDrive.cgp.
    [INFO] Shaders: no core-specific preset found at /home/pi/.config/retroarch/shaders/presets/PicoDrive/PicoDrive.glslp.
    [INFO] Environ SET_VARIABLES.
    [INFO] Remaps: remap directory: /opt/retropie/configs/megadrive/
    [INFO] Remaps: no game-specific remap found at /opt/retropie/configs/megadrive/PicoDrive/Sonic The Hedgehog 2 (W) (REV01) [!].rmp.
    [INFO] Remaps: no content-dir-specific remap found at /opt/retropie/configs/megadrive/PicoDrive/megadrive.rmp.
    [INFO] Remaps: no core-specific remap found at /opt/retropie/configs/megadrive/PicoDrive/PicoDrive.rmp.
    [INFO] Redirecting save file to "/home/pi/RetroPie/roms/megadrive/Sonic The Hedgehog 2 (W) (REV01) [!].srm".
    [INFO] Redirecting savestate to "/home/pi/RetroPie/roms/megadrive/Sonic The Hedgehog 2 (W) (REV01) [!].state".
    [INFO] Environ PERFORMANCE_LEVEL: 0.
    [INFO] Environ GET_LOG_INTERFACE.
    [INFO] Environ SET_DISK_CONTROL_INTERFACE.
    [INFO] Environ GET_VARIABLE picodrive_input1:
    [INFO] 3 button pad
    [INFO] Environ GET_VARIABLE picodrive_input2:
    [INFO] 3 button pad
    [INFO] Environ GET_VARIABLE picodrive_sprlim:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE picodrive_ramcart:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE picodrive_region:
    [INFO] Auto
    [INFO] Environ GET_VARIABLE picodrive_aspect:
    [INFO] PAR
    [INFO] Environ GET_VARIABLE picodrive_overscan:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE picodrive_overclk68k:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE picodrive_drc:
    [INFO] enabled
    [INFO] Environ GET_VARIABLE picodrive_audio_filter:
    [INFO] disabled
    [INFO] Environ GET_VARIABLE picodrive_lowpass_range:
    [INFO] 60
    [INFO] Content loading skipped. Implementation will load it on its own.
    [INFO] CRC32: 0x7b905383 .
    [INFO] Environ SET_PIXEL_FORMAT: RGB565.
    [INFO] Environ SYSTEM_DIRECTORY: "/home/pi/RetroPie/BIOS".
    [libretro INFO] 00000:000: couldn't open carthw.cfg!
    [libretro INFO] 00000:000: sram: 200000 - 203fff; eeprom: 0
    [INFO] Environ SET_INPUT_DESCRIPTORS:
    [INFO] RetroPad, User 1, Button "B (bottom)" => "B"
    [INFO] RetroPad, User 1, Button "Y (left)" => "A"
    [INFO] RetroPad, User 1, Button "Select" => "Mode"
    [INFO] RetroPad, User 1, Button "Start" => "Start"
    [INFO] RetroPad, User 1, Button "D-Pad Up" => "D-Pad Up"
    [INFO] RetroPad, User 1, Button "D-Pad Down" => "D-Pad Down"
    [INFO] RetroPad, User 1, Button "D-Pad Left" => "D-Pad Left"
    [INFO] RetroPad, User 1, Button "D-Pad Right" => "D-Pad Right"
    [INFO] RetroPad, User 1, Button "A (right)" => "C"
    [INFO] RetroPad, User 1, Button "X (up)" => "Y"
    [INFO] RetroPad, User 1, Button "L" => "X"
    [INFO] RetroPad, User 1, Button "R" => "Z"
    [INFO] RetroPad, User 2, Button "B (bottom)" => "B"
    [INFO] RetroPad, User 2, Button "Y (left)" => "A"
    [INFO] RetroPad, User 2, Button "Select" => "Mode"
    [INFO] RetroPad, User 2, Button "Start" => "Start"
    [INFO] RetroPad, User 2, Button "D-Pad Up" => "D-Pad Up"
    [INFO] RetroPad, User 2, Button "D-Pad Down" => "D-Pad Down"
    [INFO] RetroPad, User 2, Button "D-Pad Left" => "D-Pad Left"
    [INFO] RetroPad, User 2, Button "D-Pad Right" => "D-Pad Right"
    [INFO] RetroPad, User 2, Button "A (right)" => "C"
    [INFO] RetroPad, User 2, Button "X (up)" => "Y"
    [INFO] RetroPad, User 2, Button "L" => "X"
    [INFO] RetroPad, User 2, Button "R" => "Z"
    Failed to open /home/pi/RetroPie/roms/megadrive/Sonic The Hedgehog 2 (W) (REV01) [!].srm: No such file or directory
    [INFO] Skipping SRAM load..
    [INFO] Version of libretro API: 1
    [INFO] Compiled against API: 1
    [INFO] [Audio]: Set audio input rate to: 44100.00 Hz.
    [INFO] [Video]: Video @ 960x720
    [INFO] [Video]: Starting threaded video driver ...
    [INFO] [EGL] Falling back to eglGetDisplay
    [INFO] [EGL]: EGL version: 1.4
    [INFO] [EGL]: Current context: 0x1.
    [INFO] [GL]: Found GL context: videocore
    [INFO] [GL]: Detecting screen resolution 1920x1080.
    [INFO] [EGL]: eglSwapInterval(1)
    [INFO] [GL]: Vendor: Broadcom, Renderer: VideoCore IV HW.
    [INFO] [GL]: Version: OpenGL ES 2.0.
    [INFO] Querying EGL extension: KHR_image => exists
    [WARN] [GL]: GLES implementation does not have BGRA8888 extension.
    32-bit path will require conversion.
    [INFO] [GL]: Using resolution 1920x1080
    [INFO] [GL]: Default shader backend found: glsl.
    [INFO] [Shader driver]: Using GLSL shader backend.
    [WARN] [GL]: Stock GLSL shaders will be used.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] [GLSL]: Found GLSL vertex shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Found GLSL fragment shader.
    [INFO] Shader log: Compiled
    [INFO] [GLSL]: Linking GLSL program.
    [INFO] Resetting shader to defaults ...
    [INFO] [GL]: Using 4 textures.
    [INFO] [GL]: Loaded 1 program(s).
    [INFO] [Font]: Using font rendering backend: freetype.
    [INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver.
    [INFO] [udev]: Keyboard #0 (/dev/input/event0).
    [INFO] [udev]: Mouse #0 (/dev/input/event1).
    [INFO] [udev]: Mouse #1 (/dev/input/mouse0).
    [INFO] [udev]: Plugged pad: USB Gamepad (121:17) on port #0.
    [INFO] [udev]: Pad #0 (/dev/input/event2) supports 0 force feedback effects.
    [INFO] [Autoconf]: 2 profiles found.
    [INFO] [autoconf]: selected configuration: /home/pi/.config/retroarch/autoconfig/USB Gamepad .cfg
    [INFO] [Joypad]: Found joypad driver: "udev".
    [WARN] [udev]: Full-screen pointer won't be available.
    [INFO] [Video]: Found display server: null
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/2xsal-level2-crt.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/2xsal.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/2xScaleHQ.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion_lanczos4.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion_phosphor.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion_snes.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/Brighter-with_Contrast.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/bsnes_gamma_ramp.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/crt-pi-curvature-vertical.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/crt-pi-curvature.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/crt-pi-vertical.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/crt-pi.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/gameboy-screen-grid.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/gameboy.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/gameboy2.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/gba-color.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2x&lcd3x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2x2.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2x_lcd3x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2x_phosphor.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2xwaterpaint.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq2xwaterpaintscanline.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq4x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/hq4x_lcd3x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/nds-color.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/nds.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/nedi.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/palm-color.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/phosphor.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/psp-color.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/sharp-bilinear-2x-prescale.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/sharp-bilinear-scanlines.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/sharp-bilinear-simple.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes2.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_hq2x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_hq2xwaterpaint.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_hq2xwaterpainthicontrast.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_hq2xwaterpaintscanline.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_lcd3x.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_phosphor.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_scanline.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/snes_waterpaint.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/stock.glsl"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/super-2xsai.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/super-eagle.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/vba-color.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/xbr-lv1-noblend.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/zfast_crt_curve.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/zfast_crt_curve_vertical.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/zfast_crt_standard.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/zfast_crt_standard_vertical.glslp"
    [INFO] Found shader "/home/pi/.config/retroarch/shaders/zfast_lcd_standard.glslp"
    [INFO] ALSA: Using signed 16-bit format.
    [INFO] ALSA: Period size: 384 frames
    [INFO] ALSA: Buffer size: 1536 frames
    [INFO] [LED]: LED driver = 'null' 0x22d790
    [INFO] [MIDI]: Initializing ...
    [INFO] [MIDI]: Input disabled.
    [INFO] [MIDI]: Output disabled.
    [INFO] [MIDI]: Initialized "alsa" driver.
    [INFO] Loading history file: [/opt/retropie/configs/megadrive/content_history.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/megadrive/content_favorites.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/megadrive/content_music_history.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/megadrive/content_image_history.lpl].
    [INFO] Environ SET_GEOMETRY.
    [INFO] SET_GEOMETRY: 320x224, aspect: 1.429.
    [INFO] Environ SET_GEOMETRY.
    [INFO] Environ SET_GEOMETRY.
    [INFO] Unloading game..
    [INFO] Unloading core..
    [INFO] Unloading core symbols..
    [INFO] Saved core options file to "/opt/retropie/configs/all/retroarch-core-options.cfg"
    [INFO] Threaded video stats: Frames pushed: 6802, Frames dropped: 4.

  • Global Moderator

    The log shows no error, so unfortunately there's no hint to why the problem occurs.
    Did you set any specific video mode for the emulator to run ?
    Try re-installing the lr-picodrive emulator and see if the issue persist.


  • yeah, tried updating lr-picodrive and still the same. however the rom will load using dgen.


  • right, so decided stuff it and start all over again.
    redownloaded 4.4 and started afresh.
    roms workeing fine, so following eta prime guide, i used steven selp scraper.
    snes, megadrive etc all scraped fine, arcade is missing loads, but no issue playing roms after.
    am i okay to now just use skyscraper for arcade only or do you have to delete the previous steven selp arcade scrape info first.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.