Please do not post a support request without first reading and following the advice in

  • I tried again after updating and it doesn't work. I may have made a schoolboy error though. When I first set up my Pi with my old image I modified a script to allow my then Xbox One pad to work. Does a PS3 pad also require this modification to the Bluetooth settings?

  • @George-Spiggott
    The PS3 driver sort of does this on its own, and replaces the bluetooth stack with one that was written to work with PS3 controllers

    The sixaxis helper driver doesn't need any additional script, and it doesn't replace the bluetooth stack so you can use it with other bluetooth devices sidebyside.

    I don't know about the updates, I no longer have a pi to try them out.
    sudo rpi-update will give you the absolute latest. And when I tried it, it seemed to work fine.
    And then the RetroPie setup, is suggested as it now upgrades to a working kernel.

    With xbox controllers, one of the drivers might be interrupting the other controllers(the xpad one I think that emulates a controller), could try disabling it and rebooting.
    Maybe though a similar script that was written for the xboxpad could be written for the ps3 and then they would work sidebyside with the xpad driver.

  • Global Moderator

    @George-Spiggott Post the result of

    dpkg -l | grep raspberrypi-kernel

    The sixaxis helper doesn't need any modifications to the Bluetooth settings, it uses the normal Bluetooth stack, unlike the ps3controller driver which - as @Efriim said - replaced the Bluetooth stack with its own.

  • Hi.
    How i can unninstall this script, and make permanent changes to auto update options update all my setup?
    I AM on a rpi 3 B+.

  • Global Moderator

    @wmarcio See the usage instructions at

    sudo ./ unblock

  • Hello All,

    I can't seem to get my PS3 controllers paired with this new update. I recently bought a new 64gb Sandisk Extreme microSD card to use on my RPi3b+ just for RetroPie. I downloaded the most recent img file (4.5.1) from the download site. I have followed the directions found in the PS3 controller docs for setting up a PS3 controller. I have tried on a clean install after installing the sixaxis drivers, and have tried after following some of the suggestions found within this thread. The PS3 controllers don't seem to register on the bluetooth device list for some reason.

    I have 4.4.14 running on a smaller sd card, so I know the controllers work. Just can't seem to get them to connect on the new update. Any suggestions?

  • @mitu Sorry only just noticed this.

    "@George-Spiggott Post the result of dpkg -l | grep raspberrypi-kernel"

    I get this:

    hi raspberrypi-kernel 1.20190401-1 armhf Raspberry Pi bootloader
    hi raspberrypi-kernel-headers 1.20190401-1 armhf Header files for the Raspberry Pi Linux Kernel

  • I have the same issue as @jbob. I'm on 4.5.1 and have a Pi 3 B+ and I can't get the dualshock controllers to show on the bluetooth devices list.

  • I don't know if it is related, but I'm using a DS4 and sometimes it doesn't show up on the bluetooth devices list when I'm trying to pair with it.

  • Global Moderator

    @ivooc It's not related, the DS4 uses BT exclusively and doesn't need the sixaxis driver.

  • I've tried the downgrader script and I still can't get the pad to show in the Bluetooth devices list.

    As an experiment I tried swapping driver to PScontroller. The pad still doesn't show in the Bluetooth devices list but it does connect via Bluetooth. The buttons don't work properly (some do, some don't) so I can't remap the buttons within Retropie. However I may be able to remap them with a text editor.

  • I had another go this evening. I removed PScontroller and reinstalled Sixaxis. After a couple of attempts to reconnect it now works fine. No idea why Sixaxis wasn't working before when I reinstalled it but it works now.

    Thanks for all your help.

  • @George-Spiggott cool ill try when i get home my kids wanted to play avp and couldnt get to work only paired thank you.

  • Is this still an ongoing issue? I have just installed the latest weekly build for the Pi4 (4.5.11). If it is I now what the fix is but I'd rather not turn off updates if I don't have to.

  • It seems this still is a problem.
    I tried to follow the instructions shown (unplug controller, press PS Button, replug). Next, I select the corresponding MAC address. When RetroPie asks for Security Mode, no option works at all (they all time out or get canceled). I guess it's time to go back to ps3controller, even though I wanted to use multiple bluetooth devices....

  • I updated last night to 4.5.13 and it still doesn't connect. I only have one bluetooth device at the moment so I'll try Ps3controlleer.

  • I installed ps3controller and removed sixaxis. The controller works fine under bluetooth.

  • @George-Spiggott
    Hey, for some reason I don't get it running on Pi4. I followed the instructions - plugged in Controller, it gets logged in as Player 1. Then unplug it and press PS button. It doesn't connect. I'm using the onboard bluetooth and I'm suspecting it's because of that. Did you get it running with the onboard bluetooth?

  • @HansWorst7 Yes I'm using the internal Bluetooth with ps3controller as the driver.

  • @George-Spiggott Thanks for the reply.
    I managed to get one controller working now after trying this method for about 5 times. Now on to the second one...

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.