Please do not post a support request without first reading and following the advice in

Latest update and PS3 sixaxis controller

  • Hello All,

    I can't seem to get my PS3 controllers paired with this new update. I recently bought a new 64gb Sandisk Extreme microSD card to use on my RPi3b+ just for RetroPie. I downloaded the most recent img file (4.5.1) from the download site. I have followed the directions found in the PS3 controller docs for setting up a PS3 controller. I have tried on a clean install after installing the sixaxis drivers, and have tried after following some of the suggestions found within this thread. The PS3 controllers don't seem to register on the bluetooth device list for some reason.

    I have 4.4.14 running on a smaller sd card, so I know the controllers work. Just can't seem to get them to connect on the new update. Any suggestions?

  • @mitu Sorry only just noticed this.

    "@George-Spiggott Post the result of dpkg -l | grep raspberrypi-kernel"

    I get this:

    hi raspberrypi-kernel 1.20190401-1 armhf Raspberry Pi bootloader
    hi raspberrypi-kernel-headers 1.20190401-1 armhf Header files for the Raspberry Pi Linux Kernel

  • I have the same issue as @jbob. I'm on 4.5.1 and have a Pi 3 B+ and I can't get the dualshock controllers to show on the bluetooth devices list.

  • I don't know if it is related, but I'm using a DS4 and sometimes it doesn't show up on the bluetooth devices list when I'm trying to pair with it.

  • Global Moderator

    @ivooc It's not related, the DS4 uses BT exclusively and doesn't need the sixaxis driver.

  • I've tried the downgrader script and I still can't get the pad to show in the Bluetooth devices list.

    As an experiment I tried swapping driver to PScontroller. The pad still doesn't show in the Bluetooth devices list but it does connect via Bluetooth. The buttons don't work properly (some do, some don't) so I can't remap the buttons within Retropie. However I may be able to remap them with a text editor.

  • I had another go this evening. I removed PScontroller and reinstalled Sixaxis. After a couple of attempts to reconnect it now works fine. No idea why Sixaxis wasn't working before when I reinstalled it but it works now.

    Thanks for all your help.

  • @George-Spiggott cool ill try when i get home my kids wanted to play avp and couldnt get to work only paired thank you.

  • Is this still an ongoing issue? I have just installed the latest weekly build for the Pi4 (4.5.11). If it is I now what the fix is but I'd rather not turn off updates if I don't have to.

  • It seems this still is a problem.
    I tried to follow the instructions shown (unplug controller, press PS Button, replug). Next, I select the corresponding MAC address. When RetroPie asks for Security Mode, no option works at all (they all time out or get canceled). I guess it's time to go back to ps3controller, even though I wanted to use multiple bluetooth devices....

  • I updated last night to 4.5.13 and it still doesn't connect. I only have one bluetooth device at the moment so I'll try Ps3controlleer.

  • I installed ps3controller and removed sixaxis. The controller works fine under bluetooth.

  • @George-Spiggott
    Hey, for some reason I don't get it running on Pi4. I followed the instructions - plugged in Controller, it gets logged in as Player 1. Then unplug it and press PS button. It doesn't connect. I'm using the onboard bluetooth and I'm suspecting it's because of that. Did you get it running with the onboard bluetooth?

  • @HansWorst7 Yes I'm using the internal Bluetooth with ps3controller as the driver.

  • @George-Spiggott Thanks for the reply.
    I managed to get one controller working now after trying this method for about 5 times. Now on to the second one...

  • AFAIK ps3controller only lets you add one controller. sixaxis allows more than one but doesn't seem to be working at the moment.

  • I've been wrestling this for a few days now. I have two PS3 controllers that I want to get working with RetroPie so the sixaxis driver appears to be the way to go. The controller works fine when connected with USB but I am unable to pair it using Bluetooth - in fact running a scan via bluetoothctl doesn't pick up my controllers at all, but I can see other bluetooth devices. I am using the onboard bluetooth on a Pi Model 3 B but also tried two different dongles as well as different versions of RetroPie. The controllers work fine wirelessly with a PS3. I have now realised that they are in fact Sixaxis controllers rather than DS3; Wikipedia says they lack Bluetooth discovery mode, which may account for my difficulties. Not sure if there's going to be any way around that.

  • Global Moderator

    @skm said in Latest update and PS3 sixaxis controller:

    Not sure if there's going to be any way around that.

    The lack of discovery is worked around by the driver - did you follow the instruction on how to pair it from the documentation ? Are you using the genuine Sony controllers or a clone of it ?

  • Yes, they are genuine Sony controllers which came with the PS3. (Even if it was a clone I should still have been able to see it when I ran a scan.) I have been through the pairing instructions numerous times - unplug USB when instructed (all lights flash), press PS button, plug back in (light 1 comes back on), wait, nothing detected. I can even see neighbours' Bluetooth devices show up on occasion, but no PS3 controller. I have also attempted to reset the controller with the paperclip method, to no avail.

    As you suggest, though, I can't find any evidence that a DS3 actually has Bluetooth discovery mode either, so that may have been a red herring. I will try to detect the controller with a Bluetooth scan using a different Pi later on.

  • I thought my controllers were Sixaxis because they had never vibrated and I was sure they said Sixaxis on them. On closer inspection, they say "DualShock 3" as well as "Sixaxis" so they are proper DS3 controllers after all. Tried to pair a controller again using the sixaxis driver on a Pi Zero this time, with a fresh install of RetroPie 4.5.1, but it was not detected. Then I tried the ps3controller driver, after removing sixaxis and rebooting, and it was detected straight away (and vibrated) - D-pad still worked via Bluetooth although the other buttons didn't, which wasn't unexpected. There is actually very little evidence that only one controller can be connected via Bluetooth when using ps3controller, so I'll press ahead with that, since I don't need to use Bluetooth for anything else.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.