Please do not post a support request without first reading and following the advice in

[SOLVED]Problem with shanwan controller bluetooth connection on Retropie 4.4.12

  • Pi Model or other hardware: 3B+
    RetroPie Version Used: 4.4.12
    USB Devices connected: None
    Controller used: Shanwan PS3 controller


    This is my first post ever, usually I find answers from previous threads but this is an exception now.

    I haven't used my retropie in awhile and powered it on yesterday to check for updates. I updated RP to latest commit 4.4.12 without any issues BUT after the update I couldn't connect my third-party Shanwan controllers via bluetooth anymore. My previous setup was sixaxis + custombluez and it worked just fine. I tired to reinstall sixaxis + custombluez and reconnect, but it didn't work. The controllers however showed up in the device list. I also tried with ps3controller driver (with shanwan driver from config) but no luck. The controllers works just fine via cable. So any idea how to fix this, possibly manually?

    Thanks in advance.

  • Global Moderator

    @4uvak91 there's a regression introduced in the latest Raspbian kernel which breaks Bluetooth for the controllers. @psyke83 posted a script to downgrade the kernel and the accompanying packages, look in his post history and you'll find it.

  • @mitu Thank you for a quick reply. Yeah, I was guessing this also.


    Here is the link for others. Will test later.

    E: Downgrading worked.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.