Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Pi Zero W Issues - Won't Boot Without a Keyboard??



  • Ok, I'm prepping a Pi Zero W and literally only did the below list of things. I have no idea how doing any of it triggered this issue, but I can't boot into the system without connecting a keyboard and hitting Enter.

    I've attached a couple of pics of what it looks like before I need to hit Enter, which afterwards, starts Emulation Station and loads everything just fine.

    • I flashed a new 64GB card with the Pi 0 image.
    • Hooked it up to my TV w/ the Pi Zero W. I did connect an OTG cable to get my USB keyboard attached.
    • Loaded fine. Setup the keyboard as a controller.
    • Turned on the OMX player acceleration
    • Downloaded a few themes.
    • Turned on SSH
    • Went into WiFi and set my Country and entered my Wi-Fi network password
    • Transferred a ton of roms, art, and snap files over.

    That's it. It even asks me to hit Enter if I turn on the Pi Zero W without the keyboard attached (OTG is still connected though, if that matters.)

    I really do appreciate any help. Thank You.

    IMG_20190609_055855.jpg

    IMG_20190609_055904.jpg


  • Global Moderator

    @WishItWas1984 This looks like the filesystem is re-checked after rebooting - did you safely shutdown your PI after configuring it ?



  • @mitu said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    @WishItWas1984 This looks like the filesystem is re-checked after rebooting - did you safely shutdown your PI after configuring it ?

    I think I did. This is actually the 2nd time doing the exact same steps. The 1st time had the same result. I waited for the final scrolling data to go away on my TV screen. Perhaps I should've waited for the light to go out on the Pi Zero W board before pulling the plug?

    I'll definitely be more careful going forward, but is there a way to stop the Pi from doing this check?


  • Global Moderator

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    I'll definitely be more careful going forward, but is there a way to stop the Pi from doing this check?

    Unless there's a problem with the card, it's enough to shutdown from the Emulationstation's menu. Once the screen is out of signal, the PI is stopped - though the power LED might still be on.



  • @mitu said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    I'll definitely be more careful going forward, but is there a way to stop the Pi from doing this check?

    Unless there's a problem with the card, it's enough to shutdown from the Emulationstation's menu. Once the screen is out of signal, the PI is stopped - though the power LED might still be on.

    Gotcha. I did a little digging for Linux file systems cause a total shutdown didn't work. I just sudo'd into fstab and set the end of each line to 0 so it would stop checking.


  • Global Moderator

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    I just sudo'd into fstab and set the end of each line to 0 so it would stop checking.

    That's not a solution - you could end up with a corrupt filesystem and run into other problems. I wouldn't recommend doing this.



  • @mitu said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    That's not a solution - you could end up with a corrupt filesystem and run into other problems. I wouldn't recommend doing this.

    I figured as much. Just wanted to get past that so I can finalize everything else. Once I make sure all of my setup works, and the system runs quickly (for a zero), I'm going to do it all over again on my backup microSD rather than make an image of this.

    I'll be super-careful in regards to shutdown. If I don't run into issues on that one, I will image it and flash the original card.

    I appreciate you pointing me in the right direction on a solution. :)


  • Global Moderator

    @WishItWas1984 Look like you might be stumbling into this, also detailed in this topic forum.
    Try running an update of your system before anything else - while connected to the network. This should update the OS and packages and there may be correction to systemd to improve this situation. Otherwise you can try the workaround from the 2nd link, in the RaspberryPi forums.



  • I had a problem like this when combining noatime and copying the config.txt on windows. The second link mitu posted was missing I think, but in the first in case it was missed.

    As an alternate approach, as long as you aren't copying the config.txt from windows directly to the drive. Changing the fstab mount /boot/ to add the option ,noatime could work, while then disabling the fake-hwclock
    sudo systemctl stop fake-hwclock.service
    sudo systemctl disable fake-hwclock.service
    This won't completely uninstall it,
    to enable again use.
    sudo systemctl enable fake-hwclock.service
    Maybe...

    Of course the fake-hwclock is kind of cool.


  • Global Moderator

    @Efriim Thanks, corrected the link.
    There's no need to disable the service, recent systemd packages are modified - as described in the forum link - and the forced fsck should not happen anymore.



  • @mitu said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    @WishItWas1984 Look like you might be stumbling into this, also detailed in this topic forum.
    Try running an update of your system before anything else - while connected to the network. This should update the OS and packages and there may be correction to systemd to improve this situation. Otherwise you can try the workaround from the 2nd link, in the RaspberryPi forums.

    First of all, thank you and everyone else for responding with additional help.

    This weekend I was going to do my backup microSD from scratch, but do you think I should just update RetroPie on the one I have now, where I manually set the fstab lines to 0, and then image that instead?

    Or should I install RetroPie on the backup card, immediately update it, then proceed to set it up, and then use an image of that to flash my 1st card?

    I don't understand Linux enough to know what's going on with what was found out or the 2nd solution, but I'm getting the gist that nothing's wrong with the card where zeroing out the lines is a real problem if I'm just gaming on this and will never tough it again, no?

    Anyway, thanks again everyone!


  • Global Moderator

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    Or should I install RetroPie on the backup card, immediately update it, then proceed to set it up, and then use an image of that to flash my 1st card?

    This looks like a safe bet, if you have a 2nd card to experiment. Install on the backup card, update everything - but without adding any ROMs or customizing - and make sure you also update the OS and packages (it's a prompt in the RetroPie-Setup script). Reboot and see if the issue you reported re-appears.

    EDIT: you can also start with an updated image from http://files.retropie.org.uk/images/weekly/ instead of getting the 4.4 base image, less updates to download and install.



  • @mitu said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    Or should I install RetroPie on the backup card, immediately update it, then proceed to set it up, and then use an image of that to flash my 1st card?

    This looks like a safe bet, if you have a 2nd card to experiment. Install on the backup card, update everything - but without adding any ROMs or customizing - and make sure you also update the OS and packages (it's a prompt in the RetroPie-Setup script). Reboot and see if the issue you reported re-appears.

    EDIT: you can also start with an updated image from http://files.retropie.org.uk/images/weekly/ instead of getting the 4.4 base image, less updates to download and install.

    After imaging the card w/ Retropie I booted it up and turned on SSH and then connected to my Wi-Fi network.

    I then went into Retropie Setup and updated everything. Took a while, but when it was done I rebooted.

    On boot, a bit after the splash screen, it halted on "retropie login:"

    I typed in pi/raspberry and Emulation Station then started and it went into the system. I rebooted again. Same issue. I then completely shutdown and restarted. Same issue.

    So while the update didn't cause an endless loop of file system checking, I now have this.

    Any suggestion on how to re-implement automatically logging into the default user/pass during boot?


  • Global Moderator

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    So while the update didn't cause an endless loop of file system checking, I now have this.

    It's because systemd updates break auto-login - see https://retropie.org.uk/docs/FAQ/#why-emulationstation-doesnt-start-automatically-after-an-update for an explanation and solution.

    Thanks for testing this, it means the original problem is solved by updating the Raspbian packages.



  • @mitu said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    @WishItWas1984 said in Pi Zero W Issues - Won't Boot Without a Keyboard??:

    So while the update didn't cause an endless loop of file system checking, I now have this.

    It's because systemd updates break auto-login - see https://retropie.org.uk/docs/FAQ/#why-emulationstation-doesnt-start-automatically-after-an-update for an explanation and solution.

    Thanks for testing this, it means the original problem is solved by updating the Raspbian packages.

    Thanks! That did the trick.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.