Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

In need of help setting up Pegasus on Raspberry Pi 3 B.



  • Re: Announcing Pegasus Frontendbolded text

    I've been searching through the forum for more advice on how to set up the systems and games in Pegasus. I currently have emulationstation on my Pi aswell and installed Pegasus. It found my es_systems file and added all my games but some of them are missing images even though they were all scraped. Also is Saturn, Turbografx-16 and CD supported under the themes? They have no logos in Pegasus and i can't figure out how to edit the theme.



  • @MJHScorpio87 Hi, just noticed this thread (I only get notified when someone @-mentions me -- I wonder if there's a "subscribe to keyword" feature somewhere...).

    It found my es_systems file and added all my games but some of them are missing images even though they were all scraped.

    Check (or upload) the log file ~/.config/pegasus-frontend/lastrun.log to see if there've been any problems. If you have example images, I'd be interested in taking a look on them.

    Also is Saturn, Turbografx-16 and CD supported under the themes? They have no logos in Pegasus and i can't figure out how to edit the theme.

    Every possible platform is supported, but not all of them have a built-in logo yet. To add one, first download the theme from here and extract it to your theme directory (see the Installation part). Place your logos under assets/logos/, then open Pegasus and change the theme under the Settings menu to the another Pegasus Grid entry. Hope that helps!



  • @fluffypillow ill upload my log file. It says for some of my game art images "error not a JPEG file: starts with 0x89 0x50 ". Even though all my box arts are jpg files. Also i noticed a file called readme shows up in the game list on grid view but theres no such file in my rom folders. I downloaded grid view theme manually and extracted to the assets/logos/ folder directory under themes. I already have the default grid view theme so was not able to choose any other under settings. What file format do the system logos need to be? JPEG or SVG?!



  • error not a JPEG file: starts with 0x89 0x50

    This means the file is a PNG image with a .jpg file extension. At the moment files with the wrong extension may fail to load, this should be fixed in the future.

    I already have the default grid view theme so was not able to choose any other under settings.

    If it's at the correct place, it will appear in the list, even if the name is the same (which is a bit confusing I know, will make it prettier eventually).

    What file format do the system logos need to be?

    SVG, like the others.



  • @fluffypillow thanks for the help. I changed all the image files that didn't load to png and they show up now. Now I just gotta get the system logos to work. Do you have any plans on adding TurboGrafx 16 and CD logos in the future?



  • @MJHScorpio87 Yes, there've been a few logo request, I plan to go through them all some time.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.