Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

4.5 Reicast BT PS3 controller setup not working correctly.



  • Setting up a clean 4.5 image, can't see to get Reicast to configure controllers at all. Ran the controller setup utility, and all the button presses are detected, but in the actual emulator, only the analog stick works and the PS button is mapped to A.

    Oddly though, the controller works fine when plugged in USB.

    I tried manually changing the values on the .cfg file for the PS3 controller in reicast, but it doesn't seem to re-act to the changes, or at least the values I have are not corresponding to what reicast is expecting.

    How can i get values that reicast would expect? Something like JS test, but those values don't seem to work.



  • @WildkatCT said in 4.5 Reicast BT PS3 controller setup not working correctly.:

    Setting up a clean 4.5 image, can't see to get Reicast to configure controllers at all. Ran the controller setup utility, and all the button presses are detected, but in the actual emulator, only the analog stick works and the PS button is mapped to A.

    Oddly though, the controller works fine when plugged in USB.

    I tried manually changing the values on the .cfg file for the PS3 controller in reicast, but it doesn't seem to re-act to the changes, or at least the values I have are not corresponding to what reicast is expecting.

    How can i get values that reicast would expect? Something like JS test, but those values don't seem to work.

    Hello, I am experiencing this problem too, can't get any of my ps3 bt controllers to work with Reicast after the retropie 4.5 update, please help!

    I have already configured the "emu.cfg" as showed below and my mappings inside the "mappings" folder are correct for my controllers.

    '''
    [input]
    MouseSensitivity = 100
    VirtualGamepadVibration = 20
    device1 = 0
    device1.1 = 1
    device1.2 = 1
    device2 = 0
    device2.1 = 1
    device2.2 = 1
    device3 = 0
    device3.1 = 1
    device3.2 = 1
    device4 = 0
    device4.1 = 1
    device4.2 = 1
    maple_/dev/input/event5 = 0
    maple_/dev/input/event6 = 1
    maple_/dev/input/event7 = 2
    maple_/dev/input/event8 = 3
    '''



  • @WildkatCT said in 4.5 Reicast BT PS3 controller setup not working correctly.:

    Setting up a clean 4.5 image, can't see to get Reicast to configure controllers at all. Ran the controller setup utility, and all the button presses are detected, but in the actual emulator, only the analog stick works and the PS button is mapped to A.

    Oddly though, the controller works fine when plugged in USB.

    I tried manually changing the values on the .cfg file for the PS3 controller in reicast, but it doesn't seem to re-act to the changes, or at least the values I have are not corresponding to what reicast is expecting.

    How can i get values that reicast would expect? Something like JS test, but those values don't seem to work.

    @WildkatCT said in 4.5 Reicast BT PS3 controller setup not working correctly.:

    Setting up a clean 4.5 image, can't see to get Reicast to configure controllers at all. Ran the controller setup utility, and all the button presses are detected, but in the actual emulator, only the analog stick works and the PS button is mapped to A.

    Oddly though, the controller works fine when plugged in USB.

    I tried manually changing the values on the .cfg file for the PS3 controller in reicast, but it doesn't seem to re-act to the changes, or at least the values I have are not corresponding to what reicast is expecting.

    How can i get values that reicast would expect? Something like JS test, but those values don't seem to work.

    Hello, I am experiencing this problem too, can't get any of my ps3 bt controllers to work with Reicast after the retropie 4.5 update, please help!

    I have already configured the "emu.cfg" as showed below and my mappings inside the "mappings" folder are correct for my controllers.

    [input]
    MouseSensitivity = 100
    VirtualGamepadVibration = 20
    device1 = 0
    device1.1 = 1
    device1.2 = 1
    device2 = 0
    device2.1 = 1
    device2.2 = 1
    device3 = 0
    device3.1 = 1
    device3.2 = 1
    device4 = 0
    device4.1 = 1
    device4.2 = 1
    maple_/dev/input/event2 = 0
    maple_/dev/input/event3 = 1
    maple_/dev/input/event4 = 2
    maple_/dev/input/event5 = 3
    


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.