Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved] "Remove emulator choice for ROM" item doesn't work?



  • This would happen to me in the past when I had the run command set to show box art. After I stopped showing box art it would allow me to remove it. However, I haven't tested it since upgrading to 4.5 and have my boxart enabled. I'll test it when I get home.



  • I don't even know what boxart is and unless I was very, very tired, I don't think I enabled this ever. I only have had Retropie for 2 days. I'm still installing emulators and trying to get a new version of Mini vMac installed, I didn't mess with anything in Retropie settings yet. If I had enabled this without knowing, how would I proceed to disable it?


  • Global Moderator

    Check the permissions on /opt/retropie/configs/macintosh/emulators.cfg - if they're not writeable by the pi user, then no modifications on them will work.
    Can you post the file's contents, just to make sure there's nothing wrong with its format ?



  • I did not change any file permissions at all.

    alt text

    default = "basilisk"
    basilisk = "/opt/retropie/emulators/basilisk/bin/BasiliskII --rom /home/pi/RetroPie/BIOS/BasiliskII-Performa.rom --disk /home/pi/RetroPie/roms/macintosh/Mac\ OS\ 7.5.3.dsk --extfs /home/pi/RetroPie/roms/macintosh --config /opt/retropie/configs/macintosh/basiliskii.cfg"
    minivmac = "pushd /opt/retropie/emulators/minivmac; /opt/retropie/emulators/minivmac/minivmac /home/pi/RetroPie/roms/macintosh/Mac\ OS\ 6.0.8.dsk %ROM%; popd"
    minivmac-new = "pushd /opt/retropie/emulators/minivmac-new; /opt/retropie/emulators/minivmac/minivmac-new /home/pi/RetroPie/roms/macintosh/Mac\ OS\ 6.0.8.dsk %ROM%; popd"
    minivmac2 = "pushd /opt/retropie/emulators/minivmac2; /opt/retropie/emulators/minivmac/minivmac2 /home/pi/RetroPie/roms/macintosh/Mac\ OS\ 7.5.3.dsk %ROM%; popd"
    minivmac2-new = "pushd /opt/retropie/emulators/minivmac2-new; /opt/retropie/emulators/minivmac/minivmac2-new /home/pi/RetroPie/roms/macintosh/Mac\ OS\ 7.5.3.dsk %ROM%; popd"
    


  • The box art I am referring to is when you launch a game it shows the scraped image instead of the run command.


  • Global Moderator

    @marc-tremblay said in "Remove emulator choice for ROM" item doesn't work?:

    I did not change any file permissions at all.

    Can you also check the /opt/retropie/configs/all/emulators.cfg ? The associations done by runcommand are stored there.



  • @mitu said in "Remove emulator choice for ROM" item doesn't work?:

    Can you also check the /opt/retropie/configs/all/emulators.cfg ? The associations done by runcommand are stored there.

    Interesting, never edited this file before. Is this a Retropie bug? There seems to be a bunch of NULL characters in the middle of the file?

    alt text


  • Global Moderator

    If it's a bug, it's not something that happens often - I've seen similar problems, but not something that can be reproduced. If it happens regularly and can be reproduced, then we can try and fix it.



  • But can you confirm if the NULL characters are abnormal and if I should try to manually remove them from the file or if this is normal behavior and I should not edit this file?


  • Global Moderator

    @marc-tremblay I thought you already removed them - yes, that's a simple text file and you can edit it and remove the extra line from it.



  • OK, I hereby confirm that removing all the NULL characters from the /opt/retropie/configs/all/emulators.cfg file fixes the issue! Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.