Please do not post a support request without first reading and following the advice in

Coco (Tandy) loading .CAS on Retropie - Cant't do it...

  • Re: Tandy Color Computer (XROAR) - how to load cassettes?

    Pi Model or other hardware: 3+
    RetroPie Version Used (4.4.5):
    Built From: (original image - written on SD)
    USB Devices connected: BT Dongle, USB controller
    Controller used: Retrolink
    Error messages received: None
    Emulator: XRoar
    How to replicate the problem: Put the bas13.rom on BIOS folder and all .CAS inside the ROMS folder. No special configs.

    It's still tricky to load .CAS on Retropie.
    The games list is shown when I get to Coco collection, but launching is something else...
    When I select the game it goes black screen, do some flickering and back to the menu.
    Apparently one would say it's a BIOS issue. But it's not cause it runs perfectly on XRoar for Windows.
    Do I have to manually config any .CFG file?
    Not a clue o what's wrong.

  • Global Moderator

    Are all CoCo Roms not loading, or just the .cas files not working ?

  • @mitu I just tested with .cas files, from a credited repository, which is the largest set of games.
    Have you suceeded on running cas files directly from Petropie?

  • Global Moderator

    @Manyuck Yes, I have some time ago, but there might be an issue with the current version - which might affect all types of ROMs (not only .cas files), that's why I'm asking.
    Also, please - no links to ROM site or copyrighted material - it's in the Forum rules.

  • @mitu Thank you. Just edited the post.
    That´s exactly my impression, as it happens to .CAS, .CCC, .DSK.

  • Global Moderator

    I may have a fix for that, but I'll have to give it a test first.

  • Global Moderator

    Ok, a fix has been committed to the RetroPie xroar module. Can you update the RetroPie setup script, then try re-installing the emulator from source ?

    After the update and re-installation, you should be able to load any supported Rom formats - including cassette images.

  • @mitu Thanks for that! It worked out for the .CAS files and some of the .CCC ones.
    DSK files weren't loaded, returning "S/N error" on basic screen.
    In every case I couldn't return to Retropie Menu, by using the HOTKEY. Had to turn the system on/off everytime.

  • Global Moderator

    @Manyuck you need to use a keyboard to exit, I think 'Ctrl+q' exits. Standard Retroarch controls do not work in xroar.

  • @mitu Thanks! The keyboard exit worked fine.
    Do you think CCC and DSK will be playable?

  • I’m having the same issue when loading .dsk files. The standard green screen comes up and throws an SN error. No .dsk files will load. No issues with .cas files though.

    Today I installed the emulator from the latest source, dropped the bas13.rom in the BIOS folder, and dropped .dsk files in the coco folder under roms. Retropie version 4.5.1 installed.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.