Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller hijacks my audio



  • Hi
    Ive been tinkering on the RetroPie for a while, all good so far, but this latest question has stumped me now.
    I bought a new controller, a PS4 third party wired controller. After plugging it in, the audio doesn't play through the audio jack. I have another controller exactly the same kind, have been using it for a while with no issue. It seems like when I plug the second one in (in the "player two" USB slot) this happens.

    I've gone through all the discussions I could fi d and do all the audio settings suggested. But I suspect it's a specific issue with the controller in that second USB slot. When I go to RetroPie settings (RetroPie setup> configuration/tools >audiosettings >mixer) it shows that the "PS4 fun controller" is the card. Even if I select another sound card here, it is just back to the controller again (like if I exit and then go back to check) I choose the 3.5mm jack in the menu anyway buy and do the same in the few other places you can choose this option, but to no success.

    I can play sound through the controller (plugging the audio cable into it) but I want it to work through the pi's audio jack.

    Any clever ideas about what is happening?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.