Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Two Thoughts: Auto-boot RetroPie into a Game / into a Slideshow


  • Global Moderator

    @OneSwitch In order for the 'auto-boot' to work, you first have to make the game work normally - from ES, using the Runcommand menu to choose the right emulator for the ROM. After that, using the Runcommand from the auto-start script will run the game normally - using the chosen emulator. If this part is not working, then the 'auto-boot' will not work.



  • @mitu said in Two Thoughts: Auto-boot RetroPie into a Game / into a Slideshow:

    you first have to make the game work normally - from ES, using the Runcommand menu to choose the right emulator for the ROM. After that, using the Runcommand from the auto-start script will run the game normally - using the chosen emulator. If this part is not working, then the 'auto-boot' will not work.

    Not quite sure what you mean. The test gorf.zip rom works in Emulation Station/RetroPIe when I select it manually as I would any other game with a joypad. Works in Mame 2003 and 2010 libretro.

    Do you mean starting the game after pressing F4?


  • Global Moderator

    @OneSwitch said in Two Thoughts: Auto-boot RetroPie into a Game / into a Slideshow:

    Not quite sure what you mean. The test gorf.zip rom works in Emulation Station/RetroPIe when I select it manually as I would any other game with a joypad. Works in Mame 2003 and 2010 libretro.

    I mean if the game doesn't run normally, it would also not run during 'auto-boot' - this is what @BJRetro was referring also (I think).

    Do you mean starting the game after pressing F4?

    That's something you can try with the runcommand command from the autostart.sh file, to verify that it works.



  • @mitu @OneSwitch yes, mitu was right about what I meant. In any event OneSwitch here is an alternative see if it works for you since you are running gorf with Lr-mame and the rom is in the arcade folder and it works from emulation station. Content of the autostart.sh:

    (All one line, no line breaks): /opt/retropie/supplementary/runcommand/runcommand.sh 0 SYS mame-libretro ~/RetroPie/roms/arcade/gorf.zip && emulationstation —no-splash #auto

    Before no splash that big dash is two hyphens. Make sure you accurately capture where there are spaces. The SYS in italics just has two underscores before and after it with no spaces as in @mitu’s example.

    If this does not work for you I am at a loss as it is the exact contents of my autostart file. I just pulled it up.



  • @BJRetro

    (All one line, no line breaks): /opt/retropie/supplementary/runcommand/runcommand.sh 0 SYS mame-libretro ~/RetroPie/roms/arcade/gorf.zip && emulationstation —no-splash #auto

    Before no splash that big dash is two hyphens. Make sure you accurately capture where there are spaces. The SYS in italics just has two underscores before and after it with no spaces as in @mitu’s example.

    That's bad! If the ROM would fail to load than emulationstation will also not start. Furthermore the command switch are two dashes....

    @OneSwitch
    This will run the emulator setted up. I don't know what's your config now! (arcade, mame, check pathes and emulator call on yourself ....) - I think @mitu suggested more correct of your current config so I took his command line.

    wait command could be usefull (you can try to remove it)

    # you suggested
    #/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ mame-libretro ~/RetroPie/roms/mame-libretro/gorf.zip
    # mitu suggested
    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ arcade ~/RetroPie/roms/arcade/gorf.zip
    wait $!
    emulationstation --no-splash #auto
    


  • It works!!

    Thank you both so much for sticking with me. I'm not quite sure what the precise issue was but having the gorf.zip in arcade,

    (0) Drop gorf.zip in the arcade folder, with MAME2010 config files.
    (1) Go to terminal (F4 on keyboard)
    (2) Type sudo nano /opt/retropie/configs/all/autostart.sh
    (3) Edited as follows...

    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ arcade ~/RetroPie/roms/arcade/gorf.zip
    wait $!
    emulationstation --no-splash #auto
    

    (4) CTRL+X > yes to save and return to save as the file name is suggests.
    (5) Restart the Pi.
    (6) Gorf auto loads.

    Thanks so much. I'll get this working for Space Invaders, ideally once I've found a way to flip the screen so that it works in a mirror so I can use a CRT monitor vertically. That would be so nice. Then I can flick my arcade on at the wall, and have it all auto-boot.

    Huge thanks again, I really appreciate it. Excellent community here.



  • Trying to do the same with advmame 0.94 (to autoboot Asteroids), but finding the game hangs at the title-screen, or I get a blank screen. I managed once to get the game working by pressing some keys on a keyboard, but mostly, it fails to start.

    Advmame 0.94 is the only emulator that runs Asteroids well I've found (good resolution, and no lag on the sound effects). Would love to get this working.



  • @OneSwitch Think it was running in 1.4. Changed to 0.94 and it's working now. Had to use Filezilla to get into the autostart.sh file to edit it via a PC, as the system had locked up.



  • @OneSwitch said in Two Thoughts: Auto-boot RetroPie into a Game / into a Slideshow:

    ...so that it works in a mirror...

    Did you try display_rotate in config.sys? I found this explanation on the web:

    "Can be used to rotate or flip the screen orientation; the default value is 0.
    display_rotate result
    0 no rotation
    1 rotate 90 degrees clockwise
    2 rotate 180 degrees clockwise
    3 rotate 270 degrees clockwise
    0x10000 horizontal flip
    0x20000 vertical flip
    Note that the 90 and 270 degree rotation options require additional memory on the GPU, so these won't work with the 16MB GPU split.
    You can horizontally flip the display by adding
    display_rotate=0x10000"

    I use "display_rotate=1" at home for my arcade cocktail cabinet.



  • @IanDaemon Thanks, Ian. This doesn't work on a CRT monitor (at least not with Pi2Scart). More here:



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.