Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+



  • Hi All,

    I need help.

    So I brought a cheaper 2nd hand Dell monitor 1907fPT, 19 inch monitor. I have a rasberry pi 3 B+. I installed retropie and got it working on my dell monitor, using a dvi to hdmi connector so DVI cable plugs into Dell monitor while the connect plugs to the HDMI on the Pi.

    It worked. I also brought a VGA to HDMI cable (no connector, just a cable) so I wanted to see if the VGA works. Big mistake as once I took out the DVI and replaced with VGA, didn't work so I swapped it back to the DVI as it seem DVI worked by not VGA.

    However, when I switched back to DVI, all I got was blank screen. with the Message:
    "2: Digital
    Input In Power Save Mode
    Press computer Power button
    or any key on keyboard or mouse move"

    I can hear my rasberry pi working as the back ground music was coming on as I had speakers plugged in but blank screen apart from the message above.

    I first thought, maybe I broke the DVI and HDMI cable when I took it out but I then plugged it in my TV and my 4k monitor, worked perfect, DVI to HDMI cable worked fine and even played a few games on retro pie to test it. (On the DVI end, had the DVI to HDMI connector on, plugged to the monitor and the other end, HDMI to the rasberry pi)

    But for some reason, my Dell monitor keeps showing blank. The reason I brought the DELL 19inch monitor is, I am building a arcade cabinet so wanted to get retropie working before I build it. Bit disappointed as after a few tries and errors, buying cables/connector, finally got it to work on the DELL monitor.

    Also, when I saw the DVI cable was not the issue, I thought maybe the DELL monitor broke so I tested it out, using the same DVI to HDMI cable with my PC and what do you know, it worked, the DELL was showing windows, everything was working so now I know the DELL monitor and cable is working but when you plug into rasberry, I get nothing.

    Does anyone understand why this happened and how to fix it? I am hoping to get this resolved as I really don't want to buy another monitor, I was fortunate to be able to get this monitor on the cheap and it's perfect for my arcade build.

    Summary

    • Rasberry pi 3 b+ works

    • DVI to HDMI works (tested using tv and pc on dell monitor)

    • Dell monitor works as tested with PC

    • Problem: DELL monitor doesn't recognise rasberry but works fine with my PC. Get blank screen and this message:
      "2: Digital
      Input In Power Save Mode
      Press computer Power button
      or any key on keyboard or mouse move"

    • Please note, I am a noob when it comes to rasberry pi, so learning things on the go.

  • Global Moderator

    You're confusing things a bit - you have a HDMI to DVI cable (in-HDMI, out-DVI), but that's not so important.
    Can you post the /boot/config.txt configuration file ? It should be accessible either via SSH or by plugging the SD card into your PC (don't format the card if asked) as a boot partition.



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    You're confusing things a bit - you have a HDMI to DVI cable (in-HDMI, out-DVI), but that's not so important.
    Can you post the /boot/config.txt configuration file ? It should be accessible either via SSH or by plugging the SD card into your PC (don't format the card if asked) as a boot partition.

    Hi, I copied the text from the config.text

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1
    
    

    Thanks for the help


  • Global Moderator

    Try un-commenting the line with config_hdmi_boost so it reads:

    config_hdmi_boost=4
    

    and see if you get an image when booting. Do you see the 4 raspberry showing up on boot ?



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    Try un-commenting the line with config_hdmi_boost so it reads:

    config_hdmi_boost=4
    

    and see if you get an image when booting. Do you see the 4 raspberry showing up on boot ?

    Hi, tried that, see nothing on my screen, I get the digital Input message but when I turn on the pi, screen goes blank and nothing shows up but I can here sound coming from my speakers (speakers which is plugged in pi) but no picture

    thanks,


  • Global Moderator

    Can you run, from a SSH session:

    tvservice -s
    tvservice -p
    

    and post the output ?



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    Can you run, from a SSH session:

    tvservice -s
    tvservice -p
    

    and post the output ?

    Hi I don't have ssh enabled, watching a tutorial on how to do it. Since rasberry pi doen't connect to my dell, I have connected to my tv via HDMI/DVI cable and will get ssh enabled before connecting it back to my dell monitor using ssh



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    Can you run, from a SSH session:

    tvservice -s
    tvservice -p
    

    and post the output ?

    Hi, finally enabled SSH and installed WinSCP on my PC so my pi and PC showing same network. I switched my rasberry pi back to my dell monitor and have SSH ready to use

    Going to be a noob here, how do I get the output?


  • Global Moderator

    You need to use Putty, not WinSCP, to run those commands.



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    You need to use Putty, not WinSCP, to run those commands.

    Hi, thankfully I installed Putty before, finally got it working

    
    pi@retropie:~ $ tvservice -s
    state 0x12000a [HDMI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive
    pi@retropie:~ $ tvservice -p
    Powering on HDMI with preferred settings
    pi@retropie:~ $
    
    

    Thanks



  • @mitu Also, I connected my raspberry pi to my TV as it works but for some reason, no signal from my pi to the TV. Used the same cable as before but since the changes I made, tv is blank as well, no signal.

    Regards,


  • Global Moderator

    @mumihp You can back-out the changes you've made (the config.txt modification), but I don't see how that would impact the TV image. The commands you ran are not changing any settings, they only probe and power up the display.
    What version of RetroPie are you using ?



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    @mumihp You can back-out the changes you've made (the config.txt modification), but I don't see how that would impact the TV image. The commands you ran are not changing any settings, they only probe and power up the display.
    What version of RetroPie are you using ?

    Hi, I am using retropie v4.5.1

    Thanks,


  • Global Moderator

    Looking at the specs of your monitor, it looks like the native resolution is 1280 x 1024. Try forcing this resolution by modifying the config.txt file with the video mode for this resolution - see https://www.raspberrypi.org/documentation/configuration/config-txt/video.md and look for hdmi_group and hdmi_mode.
    Add also

    hdmi_ignore_edid=0xa5000080
    config_hdmi_boost=4
    

    to those configuration and then try again to see if you get any video.



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    Looking at the specs of your monitor, it looks like the native resolution is 1280 x 1024. Try forcing this resolution by modifying the config.txt file with the video mode for this resolution - see https://www.raspberrypi.org/documentation/configuration/config-txt/video.md and look for hdmi_group and hdmi_mode.
    Add also

    hdmi_ignore_edid=0xa5000080
    config_hdmi_boost=4
    

    to those configuration and then try again to see if you get any video.

    Hi, it seems my HDMI has stopped recognising anything. Since the changes, pi won't work on my tv or hdmi monitor (did before) so I basically did a fresh install of retropie. No matter what I do, I get the no signal on the tv/monitor. I don't understand if I did a fresh install, surely it my pi should be as I never changed anything so me connecting to the TV or my other monitor should work.

    Honestly, it's frustrating, spents hours over the week, tryig to fix it after work. Worked great at first but now, nothing on anything. Atleast if it didn't work on my dell monitor, still could use it on my tv or other monitor but nothing now.


  • Global Moderator

    Could it be that your cable or HDMI port are damaged ?



  • @mitu said in Dell Monitor - 2: Digital - Input In Power Save Mode - Rasberry Pi 3b+:

    Could it be that your cable or HDMI port are damaged ?

    Hi cable works fine, tested it with my other devices but nothing with rasberry pi. I don't know if it broke recently with me pulling it out often but decided to buy a new one, but will wait until the prices comes down, which it should since pi 4 came out recently.

    Anyway, thanks for the help.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.