Please do not post a support request without first reading and following the advice in

Reicast Won’t Load

  • Hi all,

    I'm running Retropie x86 on a repurposed computer using Bodhi Linux. I have been using it for just arcade games so far and basically everything has run without issues. I decided to give Dreamcast games a try and installed Reicast via source from Retropie Setup. Then I SSH'd into the system and loaded the BIOS files into the correct folder as noted in the documentation (/home/sasuke/RetroPie/BIOS/dc). After restarting EmulationStation, I selected Start Reicast from the menu in order to set the time and format the VMUs. The window opened to indicate it was starting to load, then the screen flashed green and went back to the EmulationStation select menu.

    I checked the md5 sums of the files and they match the ones listed on the RetroPie wiki for Dreamcast. I even have tried a few different sets just in case. None of them seem to work. I have updated everything from the Setup Script to the installed packages in order to rule out that possibility.

    Hardware: X86 PC running Bodhi Linux 5
    RetroPie Version: 4.5.3
    Built From:
    USB Devices connected: Two Zero Delay Encoders, wireless Logitech keyboard dongle, TP-Link WiFi adaptor
    Controller used: Arcade sticks and buttons
    Error messages received: N/A
    Guide used:
    Emulator: Reicast

    Any help would be appreciated, thank you.

  • Global Moderator

    What format are your ROMs/Games ? Can you also install the lr-flycast emulator and see if it works ?

  • @mitu The ROMS are .cdi files. I tried installing lr-flycast and it does the same thing. Obviously there’s no “Start Reicast” for that but the ROMS just crash back to the select screen.

    My main issue is that I haven’t even been able to do the setup of the date and VMUs like every guide mentions before even starting to play a game.

  • Global Moderator

    Any errors logged in /dev/shm/runcommand.log ?

  • This is my /dev/shm/runcommand.log file

    Executing: bash "/home/sasuke/RetroPie/roms/dreamcast/+Start"
    /opt/retropie/emulators/reicast/bin/ line 89: 28460 Trace/breakpoint trap (core dumped) "$rootdir/emulators/reicast/bin/reicast" "${params[@]}" > /dev/null

  • Global Moderator

    @GreatSyxsuke I was looking for the Flycast log, it should be more detailed if you use the Runcommand launch menu and choose `Debug logging'.
    For Reicast, what are the BIOS files you copied to the BIOS folder ? Are you sure they match the ones described in the docs ? I think that with the latest version you're not required to change the date/time anymore.

  • This is the log after running Flycast. I don't see an option for Debug Logging when I select "Run Command Configuration" in the RetroPie menu.

    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-flycast/ </dev/null --config /opt/retropie/configs/dreamcast/retroarch.cfg "/home/sasuke/RetroPie/roms/dreamcast/E-SPAWN.CDI" --appendconfig /dev/shm/retroarch.cfg

    The BIOS files are dc_boot.bin and dc_flash.bin. I checked the md5 sums again and they match the ones in the docs:

    e10c53c2f8b90bab96ead2d368858623 for dc_boot

    0a93f7940c455905bea6e392dfde92a4 for dc_flash

    I know they are good files because I am able to use them to run Reicast via RetroArch on the PS Classic.

    Even if I don't have to update the date and time, I would still need to format the VMUs, right?

  • Global Moderator

    @GreatSyxsuke said in Reicast Won’t Load:

    Even if I don't have to update the date and time, I would still need to format the VMUs, right?

    No, that's not required. I don't see a detailed log - did you choose 'Verbose Logging' before starting the game with 'lr-flycast' ?

  • This is the log after running it with Verbose Logging.

  • Global Moderator

    You GPU seems to be the problem, it doesn't support OpenGL 3, needed by Flycast.

    [INFO] Requesting core OpenGL context (3.0).
    [INFO] [Video]: Using HW render, OpenGL driver forced.
    [INFO] [GL]: Vendor: Intel Open Source Technology Center, Renderer: Mesa DRI Intel(R) G41 .
    [INFO] [GL]: Version: 2.1 Mesa 19.0.8.

    I'm not sure why Reicast doesn't work, but it wouldn't surprise me if it was the same type of error.

  • @mitu Oh ok, that’s a bit of a bummer. At least I know why it doesn’t work though. No big deal, I mainly use it for MAME anyways. Thanks for all your help!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.