Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Getting AdvanceMAME to run on FKMS builds



  • [Note that Retropie for the Raspberry Pi 4B is unofficial (as of this post date) and end-user support is not provided by the Retropie development team]

    Not long ago, I noticed in the fkms_rpi4 branch, that several Retropie modules were flagged so they won't display in Retropie Setup. AdvanceMAME modules were included. Understood, since after installing AdvanceMAME, it errors out with a video error, shown in /dev/shm/runcommand.log.

    Found support on this thread for getting things up and running after installation: https://sourceforge.net/p/advancemame/discussion/313511/thread/af544abbbb/?limit=25

    Basically, if you modify ~/.advance/advance.rc with the following lines - each referencing the SDL driver, AdvanceMAME should function properly with fkms/Buster on rpi4s:

    device_keyboard sdl (from raw)
    device_mouse sdl (from auto)
    device_video sdl (from fb)

    Not sure if SDL is the way to go long-term. **Video appears a bit degraded ** (in-game font, scanline filters noted) but it does render and play.

    I hope this information is useful for the [fantabulous] Retropie dev team. It's been fun watching their herculean effort and loving all of the amazing progress.


  • Global Moderator

    Thanks for the instructions - @pjft already has a PR for enabling this.
    Note that the module flag that disables the installation on the Pi4 has been there before the Pi4 was released, so it's not something added right not to block the installation.

    Do you care to elaborate on the Video appears a bit degraded part ? I confess I didn't use advmame before, so I don't have a past reference, I just test it out on the Pi4 - the 3.9 version - to see how it works.



  • @mitu said in Getting AdvanceMAME to run on FKMS builds:

    Do you care to elaborate on the Video appears a bit degraded part ? I confess I didn't use advmame before, so I don't have a past reference, I just test it out on the Pi4 - the 3.9 version - to see how it works.

    Sure mitu,

    Overall, it looks like anti-aliasing doesn't work with the SDL driver. Examples:

    • Vector game lines are not anti-aliased
    • System menu font appears jagged
    • Video Rgb Effects, such as scan2horz do not blend nicely with the game screen.

    The setting display_antialias is set to yes, but there is no visual difference when it's disabled or enabled.

    One of the draws of using AdvanceMAME is for the clean high-res Vector images, so that's a bit of a miss. But having AdvanceMAME available for rendering raster games like Cotton 2 and Baku Baku is a must-have.

    There are also some issues going in and out of the settings menu (Tab). Sometimes, when returning to the game, the screen blanks. Also, gets very sluggish and occasionally hangs. Might not be related to the driver, but different from running this on a 3B+ without Buster.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.