Please do not post a support request without first reading and following the advice in

Screen goes black randomly during playing

  • The screen goes black randomly during playing, it takes no matter which emulator. I can use Kodi or any other Linux application without this problem. I tried another TV and HDMI cable to be sure, also I experimented with different settings in the /boot/config.txt for the HDMI output.
    I use a raspberry 4 with the last emulation station code.

  • Global Moderator

    Please add more info about your setup, as detailed in

    Note that Pi4 support is ongoing and there might be quirks when using the development branch - how did you install your system ?

  • @chriej
    I just reported something similar but it only started happening when I just recently updated to a newer version of Retroarch. Does the entire screen go black and does the game continue to run... music continues? In my case about 20% of the left side of the screen remains ok.

  • New poster, and brand new retropie user here. I am having the same issue. I do know my manifestation of it is caused by the OS blanking for lack of mouse movements, as jiggling a mouse wakes the screen again. Mine is an install on top of Raspbian (all manual installation, no pre-installed image as I am running a rPi4), launched via the desktop (direct boot doesn't play well for me yet in several ways, but launching from terminal works pretty well so far). I went ahead and set it in retropie settings to disable the screen blanking. No go. I also went ahead and found a tutorial to do it on an OS level (disabling the screensaver for the desktop environment). Also no go. I did notice in the tutorial how to set it from blanking in the terminal, though the file does not exist, so I did not set it (would this be something that is needed for RetroPie to stop the OS from blanking the screen every so often? If so, do I just create the file with the contained code?) Any ideas what could be preventing the setting from taking effect?

  • I used for the basic setup this guide link text
    For me, it looks like the problem is on the emulation station site, thus all other applications work without this issue.
    When I press select on the X-Box controller or on the keyboard the screen appears again. In the time the screen was black I can hear the game music, it looks the game is still running.

  • Global Moderator

    I used for the basic setup this guide link text

    From the 'guide':

    For this setup, you will have to install RetroPie manually as of this date as RetroPie does not officially support the Raspberry Pi 4 yet. We will be constantly looking out for updates on the RetroPie system for the Raspberry Pi 4 and updating this blog as it goes!

    If you want an official setup, you will have to use a Raspberry Pi 3B+ instead.

    For me, it looks like the problem is on the emulation station site, thus all other applications work without this issue.

    EmulationStation doesn't run while you're playing games, it's suspended when any emulator/port is running, so that's not the issue here.

    The problem is that RetroPie doesn't support running in a desktop environment, like the 'guide' instructs, and most likely the screensaver kicks in after some time.

    RetroPie support for the PI4 is still a work in progress, but if you'd like to test it out, then use the Manual installation method and install it starting from a Raspbian Lite image.

  • @mitu Do you have any idea why setting it in the os and app settings it wouldn’t work? Is there a manual workaround that you or anyone else is aware of? I get it’s not officially supported yet, but there has got to be some way to disable the screensaver.

  • Global Moderator

    @StigNasty said in Screen goes black randomly during playing:

    Do you have any idea why setting it in the os and app settings it wouldn’t work

    No, I don't. I don't use the desktop environment for RetroPie, so that's not something I have experience with.

  • administrators

    I think we need to put in the sticky topics about this - we keep getting people using incorrect 3rd party guides reporting issues. So much bad information out there. Not sure why people expect us to support it!

  • administrators

    @mitu I have amended the first sticky topic to include for now "Do not report issues with running on a RPI4 - it's not yet officially supported, and there are many 3rd party guides with incorrect instructions out there. We can't support installs based on these." - not that people will bother to read it but :-) Feel free to reword.

  • I found a workaround for the black screen issue: Switch from the X-Windows season to TTY with Ctrl+Alt+F1 start emulationstation, play your games exit emulationstation, switch back to your X-Windows system with Ctrl+Alt+F7

  • @chriej Or you install sudo apt-get install xscreensaver
    and set the screen safer appearance time higher, worked for me, now I can use retropi above X-Windows.

  • @chriej i’ll try that.

  • @BuZz Read it. Know it. Was just looking for a workaround to use till it eventually is supported (for the most part, most has been working on retropie, I’m happy to report). I’ll try the other package that was suggested.

  • Hi, I'm having this same problem on the Raspberry Pi 4.

    I have a couple of extra things I can add if it can help diagnose. I really think this is just an issue with a controller not being able to wake a screen time out, and there's some setting that just needs to be configured -- I don't know where it is though.

    If I start a game from emulationstation, I can play it for awhile, and after a certain period of time the screen will go black but the music will still be playing. So the emulation is still running. If I go to a keyboard connected to my RPi4 and hit any key, the screen comes back up. So it's some sort of screen timeout issue that responds to a keyboard but not a controller. I have a PS3 controller connected through the ps3controller package.

    When running emulationstation, if i leave it alone for awhile, the screen will dim but no go black, and the screen undims when I touch the controller. So no issues there. When running Kodi I don't have this problem either.

    One thing differently is that since I had to install Raspbian Buster first, I've been starting emulationstation from the terminal in the Raspbian Buster GUI (is that what it's called? the desktop environment? I'm not that well-versed with Linux, so any corrections are apprectiated). When I had an RPi3, the system would boot directly to emulationstation, which was probably pre-configured by the downloadable RetroPie image. Since I am installing on an RPi 4 and doing it manually, there are probably some configurations that need to be done manually, and I assume one of them has to do with a screen timeout.

  • Global Moderator

    @deaftlolight Retropie is not configured to run from a desktop session - just like on the Pi3, if you want to manually set-it up, use the Lite version of Raspbian and install over. I see that despite the read-me-first topic warning, people still report 'bugs' for unsupported configuration.

  • @deaftlolight look earlier in the post. The aforementioned install works fine. Also, I think the newest version of Raspbian now allows the screen blanking/screen save to be disabled completely.

  • I've found a work around, if you are using a ps4 controller you could use the middle touch pad to "wake" raspberry pie. As i said, it is a work around but it is working :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.