Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • I am testing RetroPIe Buster weekly image in a RPI 3B. All the emulators that i am using are working ok!.
    The only problem i have is with the overscan settings(black boarders around screen) but only when i am in the terminal or during boot. In ES everything is fine.

    Any suggestions to test and fix overscan problem are welcome. Thanks!

    Pi Model or other hardware: 3 B
    Power Supply used: Official
    RetroPie Version Used : retropie-buster-4.5.9-rpi2_rpi3.img.gz/12-Jan-2020.
    Built From: RetroPie website

    config.txt :

    .***.     Sunday, 19 January 2020, 06:16:28 PM
         *****     Linux 4.19.75-v7+ armv7l GNU/Linux
         `***'
          |*|      Filesystem      Size  Used Avail Use% Mounted on
          |*|      /dev/root       6.9G  2.4G  4.2G  37% /
        ..|*|..    Uptime.............: 0 days, 01h53m33s
      .*** * ***.  Memory.............: 433564kB (Free) / 765604kB (Total)
      *******@@**  Running Processes..: 114
      `*****@@**'  IP Address.........: 192.168.1.3
       `*******'   Temperature........: CPU: 50°C/122°F GPU: 50°C/122°F
         `"""'     The RetroPie Project, https://retropie.org.uk
    
    pi@retropie:~ $ sudo nano /boot/config.txt
      GNU nano 3.2                    /boot/config.txt                    Modified
    
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    overscan_left=-18
    overscan_right=-18
    overscan_top=-33
    overscan_bottom=-33
    
    # uncomment to force a console size. By default it will be display's size minus
    # For more options and information see
    

    fbset :

    mode "1220x690"
        geometry 1220 690 1220 690 32
        timings 0 0 0 0 0 0 0
        rgba 8/16,8/8,8/0,8/24
    endmode
    

    firmware:

    Sep 24 2019 17:37:19
    Copyright (c) 2012 Broadcom
    version 6820edeee4ef3891b95fc01cf02a7abd7ca52f17 (clean) (release) (start)
    
  • Global Moderator

    Do you get the same issue with the 4.5.1 image ?
    Is that the whole config.txt - I think the RetroPie images have overscan_scale set in the config.txt file, which I don't see in your output.


  • @mitu
    I am using the same config.txt settings in the 4.5.1 image without overscan problems.

    Sorry, the whole config.txt :

    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=1
    hdmi_mode=19
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable infrared communication.
    #dtoverlay=gpio-ir,gpio_pin=17
    #dtoverlay=gpio-ir-tx,gpio_pin=18
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    
    [pi4]
    # Enable DRM VC4 V3D driver on top of the dispmanx display stack
    dtoverlay=vc4-fkms-v3d
    max_framebuffers=2
    
    [all]
    #dtoverlay=vc4-fkms-v3d
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    overscan_scale=1
  • Global Moderator

    Can you add back overscan_scale=1 and see if it makes a difference ?


  • @mitu

    overscan_scale=1 was here from the beginning, i post the half config.txt by mistake.

    i try also to uncomment disable_ overscan = 1 and the image was bigger from the tv screen, in the teminal and in the Emulationstation.

  • Global Moderator

    This kind of problem (overscan mis-match) is one of the reasons the 4.5.1 image still uses the 4.14 kernel. Unfortunately this is not a simple thing to diagnose (or report upstream), because it depends on the display used.
    If you want to pursue this further, then the place to report it would be the Raspberry PI firmware repository (github.com/raspberrypi/firmware) if you have a Github account. Before opening an issue there, you should try the latest kernel/firmware by using rpi-update, just to make sure the issue hasn't been already fixed in a recent update.

  • administrators

    @mitu I can personally confirm an rpi-update fixed the overscan settings on my Samsung. Obviously I don't recommend rpi-update as it can cause other system issues but in this case overscan was a specific issue it fixed for me.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.