Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Sorting out RetroArch, Libretro, Mame, Versions, and Configuration files


  • Global Moderator

    @Tango said in Sorting out RetroArch, Libretro, Mame, Versions, and Configuration files:

    If I just downloaded RetroPie a few weeks ago, how did I end up with an older version of RetroArch? Are the downloadable images behind development? Can I update them easily with apt?

    RetroPie is constanly updated - you can update your packages and RetroPie without writing a new image - https://retropie.org.uk/docs/Updating-RetroPie/.

    RGUI - the RetroArch menu interface, the one you've opened by pressing 'Hokey + X' and appearing in the screenshots.

    I tried RGUI from the command line, but I get "-bash: RGUI: command not found" and when I try it in lower case, I get the same thing.

    Please re-read what I've said in the previous topic - RGUI is not a command, but the RetroArch menu which you have already opened and it's shown in the screenshots you posted.



  • I updated my system, both RetroPie and Debian, and fixed the “forced to log in” issue I’ve seen others write about.

    I have specifically gone through and changed these files:

    • /home/pi/.config/retroarch/config/RetroArch-0222-212144..cfg
    • /opt/retropie/configs/all/retroarch.cfg
    • /opt/retropie/configs/mame-libreto/retroarch.cfg

    With each one I loaded it into RGUI, went to Settings->Input->User 1 and changed the Mouse Index to 0 and saved them. I also verified that when I did cat /dev/input/mouse0 and moved the trackball, I got data from there. I also verified this after my upgrade of the entire system by checking Settings->Input->Port 1 Binds and, again, checked the Mouse Index and it’s set to 0.

    But when I go to play Centipede, the trackball is not recognized in any way I can tell.



  • @mitu said in Sorting out RetroArch, Libretro, Mame, Versions, and Configuration files:
    ...

    RGUI - the RetroArch menu interface, the one you've opened by pressing 'Hokey + X' and appearing in the screenshots.

    I have to go through the RetroPie menu on ES. For some reason, that combination has never brought up RGUI.

    I tried RGUI from the command line, but I get "-bash: RGUI: command not found" and when I try it in lower case, I get the same thing.

    Please re-read what I've said in the previous topic - RGUI is not a command, but the RetroArch menu which you have already opened and it's shown in the screenshots you posted.

    RGUI looks like a CURSES based interface, like the Debian configuration menus used for some configuration functions (like setting up wifi or networking). So is it part of ES and not a separate program that can be launched on its own?


  • Global Moderator

    I have to go through the RetroPie menu on ES. For some reason, that combination has never brought up RGUI.

    Did you set up a Hotkey when you configured your input in EmulationStation ? If you didn't , then Hotkey + X will not open up the menu.

    Please re-read what I've said in the previous topic - RGUI is not a command, but the RetroArch menu which you have already opened and it's shown in the screenshots you posted.

    RGUI looks like a CURSES based interface, like the Debian configuration menus used for some configuration functions (like setting up wifi or networking). So is it part of ES and not a separate program that can be launched on its own?

    No, it's not part of ES - it's part of RetroArch.

    For your actual issue - the mouse not getting detected or used - try loading a game with verbose logging enabled from the Runcommand launch menu, exit the game and then post the /dev/shm/runcommand.log on pastebin.com to take a look.



  • @mitu said in Sorting out RetroArch, Libretro, Mame, Versions, and Configuration files:

    I have to go through the RetroPie menu on ES. For some reason, that combination has never brought up RGUI.

    Did you set up a Hotkey when you configured your input in EmulationStation ? If you didn't , then Hotkey + X will not open up the menu.

    Yes. I use HotKey+1Player all the time to get out of games.

    Please re-read what I've said in the previous topic - RGUI is not a command, but the RetroArch menu which you have already opened and it's shown in the screenshots you posted.

    RGUI looks like a CURSES based interface, like the Debian configuration menus used for some configuration functions (like setting up wifi or networking). So is it part of ES and not a separate program that can be launched on its own?

    No, it's not part of ES - it's part of RetroArch.

    Wow - surprised it's not command line based. Interesting that EmulationStation does so much without things like X or curses, for the text based RetroArch.

    For your actual issue - the mouse not getting detected or used - try loading a game with verbose logging enabled from the Runcommand launch menu, exit the game and then post the /dev/shm/runcommand.log on pastebin.com to take a look.

    Done. It's right here.


  • Global Moderator

    Wow - surprised it's not command line based. Interesting that EmulationStation does so much without things like X or curses, for the text based RetroArch.

    RetroArch is not 'text based'. I think you're greatly oversimplifying things and confusing what 'text based' means. Just because you can't use a mouse in an interface or it doesn't use an X session, it doesn't make it 'text based'.

    For your actual issue - the mouse not getting detected or used - try loading a game with verbose logging enabled from the Runcommand launch menu, exit the game and then post the /dev/shm/runcommand.log on pastebin.com to take a look.

    Done. It's right here.

    I see in the log about 3 mice type devices detected, change the index from 0 to 1 or 2 and see if it makes a difference.

    [INFO] [udev]: Mouse #0 (/dev/input/event4).
    [INFO] [udev]: Mouse #1 (/dev/input/mouse1).
    [INFO] [udev]: Mouse #2 (/dev/input/event5).
    [INFO] [udev]: Mouse #3 (/dev/input/mouse2).
    [INFO] [udev]: Mouse #4 (/dev/input/event1).
    [INFO] [udev]: Mouse #5 (/dev/input/mouse0).
    


  • Tried all three mouse connectors. Trackball not recognized. But there’s more that might help:

    /dev/input/mouse0: Trackball
    /dev/input/mouse1: Mouse
    /dev/input/mouse2: Spinner

    The mouse is a battery powered mouse. It doesn’t work through bluetooth, but connects to a USB dongle that the keyboard also connects to. So I have to keep the dongle plugged in for the keyboard to work. Whether the mouse is on or off, the dongle is still there and still looks like it’s a mouse.

    When I changed the input to 2, which is the spinner, it worked. The spinner works in Tempest and I never configured it. But when I tried using mouse0 or mouse1, the whole arcade system doesn’t seem to recognize a thing. I tried Centipede with all 3 inputs and nothing happened at all with 0 or 1.

    Should I note that Centipede does respond to the joystick?

    I’m wondering if I may need to do some remapping of the trackball in some way - make it send a different signal for each direction than it already does? (But that wouldn’t make sense - I’m sure the mouse is standard in terms of connection and that doesn’t work through RetroArch either.)

    Also, right now, I’m finding I need to edit the retroarch.cfg in /opt/retropie/configs/mame-libretro to have an effect. I realize this is because it’s hierarchical and the most immediate one applies. Is there a way to remove this setting from this particular retroarch.cfg so the one on /opt/retropie/configs/all will be used instead?


  • Global Moderator

    @Tango

    Also, right now, I’m finding I need to edit the retroarch.cfg in /opt/retropie/configs/mame-libretro to have an effect. I realize this is because it’s hierarchical and the most immediate one applies. Is there a way to remove this setting from this particular retroarch.cfg so the one on /opt/retropie/configs/all will be used?

    the mame-libretro cfg settings will always override the all cfg settings, but typically you should have hardly anything in the former file, other than the settings you wish to override from /all/retroarch.cfg. you certainly wouldn’t expect to see any mouse settings in it by default.

    if you’ve gotten yourself into a mess, have a look at the retroarch.cfg.rp-dist file in /opt/retropie/configs/mame-libretro - this is the default skeleton version of the file that you can copy over the retroarch.cfg file to return to normal behaviour. if it’s not there, update lr-mame2003 and it will be generated.



  • @dankcushions

    @dankcushions said in Sorting out RetroArch, Libretro, Mame, Versions, and Configuration files:

    @Tango

    Also, right now, I’m finding I need to edit the retroarch.cfg in /opt/retropie/configs/mame-libretro to have an effect. I realize this is because it’s hierarchical and the most immediate one applies. Is there a way to remove this setting from this particular retroarch.cfg so the one on /opt/retropie/configs/all will be used?

    the mame-libretro cfg settings will always override the all cfg settings, but typically you should have hardly anything in the former file, other than the settings you wish to override from /all/retroarch.cfg. you certainly wouldn’t expect to see any mouse settings in it by default.

    if you’ve gotten yourself into a mess, have a look at the retroarch.cfg.rp-dist file in /opt/retropie/configs/mame-libretro - this is the default skeleton version of the file that you can copy over the retroarch.cfg file to return to normal behaviour. if it’s not there, update lr-mame2003 and it will be generated.

    I'm going to take a closer look at those configurations for that version of Mame, in case that's what's messing up the trackball. Thanks!



  • I went through config files and even used the rp-dist in /opt/retropie/configs/mame-libretro to replace the modified one in the retroarch.cfg in that directory. Still no luck.

    But I've come upon a frustrating issue that does not seem to fit in with the situation. It's so different from what I'm dealing with, I started a new thread and went into long and careful detail of what I did and what's going on. It's here.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.