Please do not post a support request without first reading and following the advice in

No sound in EmulationStation or games

  • Everything worked fine yesterday and I did a shutdown. Today I cannot get some sounds out of ES. I use the audio out jack to a powered bluetooth speaker using the 3.5mm jack. Game-play videos within ES play fine with sound. Navigation sounds are enabled and do not play. Arcade games have no sound. Volume is 90%. I have tried numerous ideas found on this site including forcing the audio out the 3.5mm jack, hdmi_ignore_edid_audio=1 and various alsactl options. I was overclocked at 1.4 and set it back, still no sound.

    Thank you in advance for your consideration.

    Pi Model or other hardware: 3 B+
    Power Supply used: 5V 3A
    RetroPie Version Used: 4.5.13
    Built From: Image on Retropie website
    USB Devices connected: 2 USB Controller boards, Keyboard
    Controller used: 2x Joystick 20 buttons
    Error messages received: During the troubleshooting steps I have seen two errors but could not identify how to reproduce them.

    1. Once, after pressing F4 to exit ES i saw this:
      ALSA lib control.c.1373:(snd_ctl_open_noupdate) Invalid CTL local. lv10 VolumeControl::init() -Failed to attach to default card!
    2. Trying to do alsactl store i saw this:
      alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: file exists

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.