Please do not post a support request without first reading and following the advice in

DragonRise N64 USB Controller Not Mapping

  • I am having an issue with a DragonRise Generic USB N64 controller I purchased from Amazon. The "A" and "B" buttons map correctly when in RetroPie using the AutoConfig feature, but then when a game loads the "A" button functionality can only be accessed by using the "B" button, and the other button does nothing at all.

    I tried to map them in the inverse through the autoconfig hoping maybe it was just a cheap trick and backwards which gets the "A" button working by mapping it incorrectly, but still renders the "b" button useless.

    I have read multiple posts in this forum which all seem to have the same issue, but no one ever really clearly states what the solution is to the problem.

    Any help would be appreciated.

    Pi Model or other hardware: 4 B
    Power Supply used: 5V 3A
    RetroPie Version Used : RetroPie 4.5.1
    Built From: RetroPie
    USB Devices connected: Cana Wifi, Rii Wireless Keyboard, DragonRise N64 Controller
    Controller used: DragonRise N64 Controller

  • Hey bud, we are in the same boat. Run jstest and write down all the inputs and corresponding numbers. Use your Rii to hit f1 while in lr-mupen64plus-next to open the retroarch GUI and scroll down to "controls", then remap everything according to you jstest results. This got me to the point where every button works except for c-up and c-right. Please let me know if you can get any further or if you've already solved the issue.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.