Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • I have a raspberry pie 3b+ with retropie and I'm trying to rotate emulationstation by editing the autostart.sh file to include the following: "--screensize 1080 1920 --screenrotate 3". I have updated emulationstation from binary and successfully entered those options. It DOES work. It rotates and sizes my ES screen perfectly! But when I reboot or switch from attract mode back to ES, the autostart.sh files gets rewritten to its original state which deletes those options. I have tried editing the file via SSH and through sudo nano commands on the command line. It still gets rewritten. What's the deal??


  • Well after a few days of searching files and experimenting on the pi, I think I've got this figured out. Apparently the problem was occurring when switching from AttractMode to EmulationStation. This is the point that the autostart.sh file was getting re-written to it's original state and cancelling out my changes. I wanted to post my solution here in case anyone ever has the same issue.

    How To Start EmulationStation With Rotated & Modified Display Settings

    • Update EmulationStation by going to: retropie setup > manage packages > manage core packages > emulationstation > update from binary
    • Make sure you have root access to the pi and log in to RetroPie as a root user through SSH (find tutorials on youtube)
    • Go to /opt/retropie/configs/all
    • Find autostart.sh
    • Edit to add the following at the bottom: emulationstation --screensize 1080 1920 --screenrotate 3 --screenoffset 000 00
    • I only needed screensize & screenrotate in the example below and the numbers will differ according to your personal needs as well.
    autostart.JPG

    • Go to /home/pi/RetroPie/roms/setup
    • Find EmulationStation.sh
    • Edit to make it look like the following:
    EmulationStation.JPG
    • Reboot the pi

  • Global Moderator

    The autostart.sh is rewritten only when you change the autostart option though the configuration/tools menu, you only need to take care of updating it only after you've performed this step. The file is not re-written at runtime.

    There's no such file in stock RetroPie setup, even if you install Attractmode. Are you using a 3rd party image ?


  • Mitu,

    Yes I am using a 3rd party image. I am aware of the policy here but I didn't know that it was the image causing my problem. I'm new to RetroPie and I honestly had no idea that EmulationStation.sh was something generated by my image and that it would not exist in a stock RetroPie. Now I know. My apologies if I have violated policy. It was an honest mistake. So if I were to have a stock RetroPie with only AttractMode installed, would I be able to use the SetUp menu within AttractMode to switch back and forth from AttractMode to EmulationStation without this happening?

  • Global Moderator

    @shadetree77 said in autostart.sh being re-written:

    Yes I am using a 3rd party image. I am aware of the policy here but I didn't know that it was the image causing my problem

    Why do you think we have this policy to begin with ?

    So if I were to have a stock RetroPie with only AttractMode installed, would I be able to use the SetUp menu within AttractMode to switch back and forth from AttractMode to EmulationStation without this happening?

    You can use the autostart configuration to switch between them. Given you're using some parameters for EmulationStation, you'd have to edit the file after you switch to EmulationStation to add your parameters.


  • @mitu Meanwhile every second posting is related to this "in da houz" images.

    Well after a few days of searching files and experimenting on the pi, I think I've got this figured out.

    What else could I say?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.