Please do not post a support request without first reading and following the advice in

new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!)

  • @dmmarti awesome ! can you please clone my git repo, add your scripts, and issue me a pull request ? thanks!!!!

    some i just added myself

    • lr-mess-fm7 (Fujitsu FM7, fully working)
    • lr-mess-multivision (Othello Multivision, fully working)
    • lr-mess-mz700 (Sharp MZ700, fully working)
    • lr-mess-svi318 (Spectravideo 318/328, fully working)
    • lr-mess-vc4000 (Interton VC4000, partially working)

    i also added the new version of dosbox:

    • lr-dosbox-svn

  • @valerino So I took the plunge and finally decided to install your script. I followed the instructions on this page to the letter : link text

    I manage to launch the script but I can't see any new packages/modules anywhere. Am I missing something?

  • I'm not sure if this will be of any use at all, but there was work on some of these emulators (e.g. BBC's beebem), done in the past, in the (now abandoned) Zerojay RP Extra repository -

  • @Zering you probably haven't followed the instructions well.

    # make backup of your existing retropie-setup
    cd /home/pi
    mv ./RetroPie-Setup ./RetroPie-Setup.bck
    # now clone mine in place of the original
    git clone
    # now proceeed as normal running
    sudo ~/RetroPie-Setup/


  • @valerino Whenever I use the second command, it says RetroPie-Setup is not a valid directory, or that it cannot write over the existing file.

    Also I'm pretty positive I saw your RPS get cloned yesterday, but my RetroPie-Setup shows as unchanged in WinSCP ; the last changes are from the 28th.

    I'll try again and let you know.

    Edit : I tried again and I get the following error after typing in the second command :

    fatal : Not a git repository (or any of the parent directories): .git

    Edit 2 : Does lr-mess have to have been installed from source for this to work? Or will a binary install do?

  • @Zering wtf...... ure right :) my bad, i mistyped. its obviously 'git clone' not 'git pull' !!! i corrected the post above.

    about lr-mess, i had to install it from source, didnt find the option to install from binary in the retropie menu. anyway, it deosnt matter if you install from binary or source, except the latter takes about 3hrs on an rpi4 (and significantly longer on rpi3, i presume....).

  • @valerino I can't even compile from source on my rpi3, it never finishes building. I'm glad to hear it can work from binary. But your previous guide says that installing the 'fake cores' is done through the 'install from source' option? Can you clear that up?

  • @Zering one thing is to install lr-mess itself (which, as i said, you can do from binary or sources, as you prefer).
    another thing is to install the fake cores, which depends from lr-mess (indeed, they check for lr-mess installed in their install procedure, and exit if not found).
    you see 'install from source' in the fake cores because that's what the retropie install script display by default (i never thought of changing it....), just click it.

    'fake cores' do not install anything, they just create and setup a separate lr-mess configuration to trick emulationstation/retroarch that the lr-mess system you're going to install is a separate independent core (which is not).

  • @valerino So where do the 'fake cores' appear once I run your script? I can't find them in the main, optional, experimental or even the core modules.
    I tried your commands again, even after your edit, and I still get a fatal error report. However, when I follow the instructions on your github, I see your repository being cloned, but I can't see anything beyond that after I run the script.

  • @Zering the fake cores are under experimental, right after lr-mess. they're called lr-mess-blabla.
    sorry, but it's surely something your side, i can't know :(
    the instructions here are the only thing you need to setup everything.

  • @valerino Hi, I've installed the lr-vice-xvic scriptmodule. It works fine with tapes and disks, but I can't make it work with cartridges. Is there a specific setting that I'm missing?

  • @saccublenda hi, this is dependent on vice itself, it has nothing to do with the lr-vice setup script. try others, i experimented that myself, some carts works and some not. there may (i haven't checked deeply) be core options in lr-vice affecting it, they may be set via command line options (so you could theoretically modify the installer script to add them), but i sincerely don't know. just experiment yourself :)

  • @valerino It is indeed a problem of lr-vice itself.
    When you install vice it creates several emulators, including vice-x64 (which just runs x64 %ROM%), vice-xvic (which runs xvic %ROM%), and vice-xvic-cart (which runs xvic %ROM% -cartgeneric).
    The Vic-20 cartridges so run fine with vice-xvic-cart, and lr-vice runs fine C64 cartridges, but it fails to run Vic-20 cartridges.

  • This has my hopes up to play a couple of bbc games.
    I’ve followed the instructions, but I fear my bios files for bbc may not be correct. Whenever I try to start a game I just get a white outline box with a tiny word (which I can’t read because it’s a small screen) and cannot do anything from there. Can anyone confirm the md5sum for,, and
    I have to reboot the system each time I try:(

  • Hi

    how straightforward is it to add Atom, Apple 1 and 3 and other machines via mess, and your script? No doubt I can run it via mess but i thought i'd ask if there was a self-serve option, or, if you please had plans to add others to your script?

    thank you v much for what you've done! adding the 2 casio PV's and apple2 GS to my pi 3 now - thanks again!

    (BTW! I've had bbc micro and electron working pretty well via advmame /advmess for some time inc sound, and auto-loading disk and tapes. There's a thread on retropie forums about it, if the issue with sound here isn't resolved. Atom,I've never got working right in advmame)


  • does lr-mess emulate the sharp x1? if so, is there some guidance someone could point me to? i've been using lr-x1, but i have some roms that won't open in that emulator and looking for other emulator options.

  • This is really nifty, nice job @valerino!

    For anyone who wants to play Arcadia, Creativision and Astrocade stuff I walked through button mappings here: (scroll down past the MESS setup instructions).

  • @roslof
    Can you provide a checksum for your MESS BIOS files for the TI99/4A?

    I've been working on getting the *.rpk files running. They start just fine and I get the main screen where I have to pick a number for the game. So at that point, everything works good.

    After I chose, it just goes to a blank teal screen and sits there, the actual game never starts.

    I'm thinking it's a BIOS problem. I've tried a few different ZIP BIOS files from various MAME/MESS versions .. but so far, I've not have any luck.

  • @dmmarti no problem, but to me, it sounds more like a symptom of the .rpk itself. You've tried multiple from different sources?

    Here are the BIOS md5 checksums:

    19350381a062a70feff18748eb6692fa \retropie\bios\
    26e6f317aff0f120cea2d7bcf69c3a6b \retropie\bios\
    92a4ac9559874cf7116709421d8ba63d \retropie\bios\

    Of course, these are ZIPs of several files, so possible the checksums will be different if ZIP itself was compressed with a different tool or compression method.

    FWIW: My file contains:
    folder: ti99_4ev
    folder: ti99_4qi
    file: 994a_grom0.u500
    file: 994a_grom1.u501
    file: 994a_grom2.u502
    file: 994a_rom_hb.u610
    file: 994a_rom_lb.u611

    Hope this is helpful.

  • @roslof Thanks!

    I haven't tried other *.rpk files as the ones I have work with stand alone MESS.

    I'll verify my BIOS files versus yours and hunt down some other game files.


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.