Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!)



  • @roslof
    Can you provide a checksum for your MESS BIOS files for the TI99/4A?

    I've been working on getting the *.rpk files running. They start just fine and I get the main screen where I have to pick a number for the game. So at that point, everything works good.

    After I chose, it just goes to a blank teal screen and sits there, the actual game never starts.

    I'm thinking it's a BIOS problem. I've tried a few different ZIP BIOS files from various MAME/MESS versions .. but so far, I've not have any luck.



  • @dmmarti no problem, but to me, it sounds more like a symptom of the .rpk itself. You've tried multiple from different sources?

    Here are the BIOS md5 checksums:

    19350381a062a70feff18748eb6692fa \retropie\bios\ti99_4a.zip
    26e6f317aff0f120cea2d7bcf69c3a6b \retropie\bios\ti99_evpc.zip
    92a4ac9559874cf7116709421d8ba63d \retropie\bios\ti99_speech.zip

    Of course, these are ZIPs of several files, so possible the checksums will be different if ZIP itself was compressed with a different tool or compression method.

    FWIW: My ti99_4a.zip file contains:
    folder: ti99_4ev
    folder: ti99_4qi
    file: 994a_grom0.u500
    file: 994a_grom1.u501
    file: 994a_grom2.u502
    file: 994a_rom_hb.u610
    file: 994a_rom_lb.u611

    Hope this is helpful.



  • @roslof Thanks!

    I haven't tried other *.rpk files as the ones I have work with stand alone MESS.

    I'll verify my BIOS files versus yours and hunt down some other game files.

    Thanks



  • @valerino I have got to ask Can you add a script for the Atari Jaguar CD? Also this has answered some of my prayers. Can't thank you enough.



  • hello

    I have a pi4, and am having difficulty installing at least GSplus from from repo (details copied below, from your post just above). Please can someone help advise what I am doing wrong and what is the fix?

    Pi4, official retropie build.

    switch to your repo, git clone (as below)

    install gsplus from experimental

    reboot

    emulationstation will no longer boot. get this error in the shell:

    Creating config directory "/home/pi/.emulationstation"
    Config directory could not be created!

    if I go look in /opt/retropie/ the configs folder is now missing

    there are now 2 folders, configs.crt and configs.hdmi. its possible, but unverified, its renaming my config folder and breaking startup.

    there is a symlink for 'configs' pointing to, I think, configs.hdmi

    however it will no longer run emulationstation

    my pi4 btw, connects to a screen using a hdmi to DVI cable with audio from the 3.5mm jack. I have no choice.

    *EDIT: just tried again, installing one of the mess scripts causes the same error.

    EDIT2: brand new retropie buster image for pi4 off the retropie site. different micro sd card. added wifi. swapped to the git as per instructions. installed lrmess. reboot.ok. installed a mess script - no longer boots to emulationstation. opt/ retropie/configs is no longer there. configs.crt and configs.hdmi are there.*

    why is this?

    @valerino said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    make backup of your existing retropie-setup

    cd /home/pi
    mv ./RetroPie-Setup ./RetroPie-Setup.bck

    now clone mine in place of the original

    git clone https://github.com/valerino/RetroPie-Setup

    now proceeed as normal running retropie_setup.sh

    sudo ~/RetroPie-Setup/retropie_setup.sh



  • Narrative continues:

    Over on github i see this in the readme. Sorry I didnt see this in this thread.

    --

    CONFIGURATION MENU

    • CRT/HDMI: provides autoconfiguration of HDMI or CRT/PAL/NTSC outputs, needs reboot. this currently needs my retrovpie configuration to work correctly.
      --

    I hadnt seen that, so as well as gsplus and mess, it automatically changes hdmi/crt configs without any user request? I'll go look now. I definitely had not executed such an option.

    has anyone had such a problem? I'm stuck



  • @roslof

    I would love those .gsp if I can get them.

    I am having problems gett lr-mess-apple2gs t work. When I run it says initialization and just gets stuck on that screen. Any suggestions?



  • @roslof if you could be a star and please share those .gsp files? dropbox or google or other? I know these were for the standalone gs, but I have to get it working.

    thanks if thats possible it'd be a great resource.

    thank you!



  • @iainjh @pacpir Hmmm. A few things you'll need to know, since a .gsp (GSPlus configuration file) doesn't solve everything. You'll need to be sure everything is named correctly and in its place. A lot of this information is in an earlier post.

    For any of my .gsp configuration files to work for you, you'll either need to edit them, or create this exact structure:

    1. GSP Location: ~/RetroPie/roms/apple2gs/
    2. IIGS 2mg files (unzipped): ~/RetroPie/roms/apple2gs/[Disk Images]/
    3. GSOS6.0.1.img location: ~/RetroPie/roms/apple2gs/

    For #2, the EXACT file names required are listed in each .gsp file. Rename accordingly.

    For #3, some games require a HD image with OS 6.0.1 installed. you'll likely need to create the hard drive image manually. It's a bit of a pain, but there are videos describing the process.

    LINK TO GSP (GSPlus Configuration) FILES

    Other Notes:

    WARNING: Never launch non-gsp files! GSPlus will assume any referenced file is a gsp configuration file and treat it as such. CLARIFYING: If you try to launch a .2mg file or .zip file with this method, it will CORRUPT it and you'll need to replace it with the original. So use care. You may opt to remove .zip and .2mg references from your es_settings.cfg if you're otherwise worried about this.

    DO NOT USE ROM3. ONLY USE ROM1. Some games are otherwise incompatable. ROM1 works with everything.

    If you cannot see the .gsp files in EmulationStation, then you'll need to add the .gsp extension to your es_systems.cfg file. If you're not going to use lr-mame for IIGS, then I recommend removing .zip and .2mg from es_systems.cfg (see "WARNING" above).

    I use a DualShock 4 controller to play games. In each gsp you'll notice these lines:

    g_joystick_scale_factor_x = 281
    g_joystick_scale_factor_y = 281
    

    Remove them if they cause trouble with your controller, or override them with GSPlus F4 settings.

    Here is the VERY simple emulation.cfg info for the emulator:

    gsplus = "/opt/retropie/emulators/gsplus/gsplus.sh %ROM%"
    default = "gsplus"
    

    Hope this helps.

    @roslof if you could be a star and please share those .gsp files?

    @iainjh now that I'm "a star", you owe me a beer.



  • Roslof, thank you! We have beer on tap, just pop round:)

    Thats a fantastic resource, and the guide. Thanks again for sharing. iain

    I'll get that set up, once I've rebuilt my setup without the config.hdmi folder messup above. CURRENT STATUS as of sunday: I used a new retropie buster, connected to the github, installed all the scripts as before, the config.hdmi and config.crt appeared and retropie no longer starts ES. FTP'ed out the stubs/Lr-mess fake emulator folders, config folders, emulator.cfg's and run_mess script. FTP'ed those over to a booting build so as not to break ES, and apple 1 at least boots so that is progress! Several other setups - coco etc - presently stick mid-boot with a distorted 'initialising' message, I'll check the BIOS locations are correct.



  • @iainjh said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    I'll check the BIOS locations are correct.

    If it helps, ROM.01 must be renamed (or be symlinked) as a file called "ROM" that lives with the executable.

    Here is how mine is setup (as I like all BIOS for all systems in the same location):

    GSplus executable location:
    /opt/retropie/emulators/gsplus/

    Symlink GSplus ROM (bios):
    /opt/retropie/emulators/gsplus/ROM (points to "Actual path" below)

    Actual path of ROM (bios):
    /home/pi/RetroPie/BIOS/apple2gs/ROM.01

    So, basically, the GSplus executable directory should look something like this:

    -rw-r--r--   pi   pi    config.gsp
    -rwxr-xr-x   pi   pi    GSplus
    -rwxr-xr-x   pi   pi    gsplus.sh
    drw-r--r--   pi   pi    lib
    -rwxr-xr-x   pi   pi    partls
    -rw-r--r--   pi   pi    retropie.pkg
    lrwxrwxrwx   root root  ROM -> /home/pi/RetroPie/BIOS/apple2gs/ROM.01
    

    ...or just rename ROM.01 to ROM and put it in this folder if you don't want to deal with symlinks.



  • Very helpful thank you. I have GS now running under both lr-less and gsplus. One question - what format should the hd image be and how did you create that, I didnt yet find any useful guide on youtube or elsewhere. In the past, I've created .po files etc using ciderpress.. I dont see how to create an .img.. i can certainly download pre-made 2mg /po/hdv hd images but .img has me stumped.

    thanks again. Hopefully someone else will also find this useful!

    iain



  • @iainjh said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    I didnt yet find any useful guide on youtube or elsewhere. In the past, I've created .po files etc using ciderpress.. I dont see how to create an .img.. i can certainly download pre-made 2mg /po/hdv hd images but .img has me stumped.

    If you can find a pre-made Hard Drive image that boots system software 6.0.1, just rename it GSOS6.0.1.img (to match with the .gsp files I provided.

    Otherwise, this video helped me go through the painful process of installing system software on a blank image:

    Here is another one, narrated by somebody who sounded 13-years old that was even more beneficial:



  • Another few things about Apple IIGS emulation on the Raspberry Pi 4B:

    You mentioned using both lr-mess and GSPlus. I noticed a few things.

    GSPlus handles multiple disks very well. Haven't figured out how to handle this on lr-mess.

    ...but lr-mess seems to be a bit more compatible. An example is Zany Golf. For me, there were mouse issues where you could not navigate the entire screen in GSPlus, but it worked great in lr-mess (once getting the mouse to work correctly for all of RetroArch).

    Double-check your emulators.cfg file. Be sure you have all of the necessary command-line arguments. Here is the end of line:

    apple2gsr1 /home/pi/RetroPie/BIOS -gameio joy -flop3 %ROM%"
    

    This will ensure proper joystick support, which is also better on lr-mess (try jumping over a ledge in Thexder in both EMUs and you'll see what I mean).

    Lastly, lr-mess takes advantage of libretro functionality, so you can [among other things] have an overlay and use shaders if desired. I cobbled together this overlay (thanks to @Orionsangel for the background) which makes me quite happy.

    prodos.png
    thexder.jpg
    apple iigs.png

    Hope these last few tips help you get fully rolling.



  • hi guys, sorry if i didnt replied lately or posted anymore.

    i kept updating my fork here and there (i usually keep it in sync with the upstream repo), and as one of you noticed i added an option to switch CRT/HDMI configurations.

    basically, it keeps 2 copies of all /opt/retropie/configs folder (one for crt, one for hdmi .... since i use some system with an old crt and some with a bigger hdmi monitor).
    it lets you switch configurations (so you can set up i.e. the hdmi one with shaders and all, which aren't needed on the crt) and manage them.

    it's not perfect, requires reboot, but well .... take a look, it does its job for what i needed.

    cheers!
    v.



  • Hi Valerino!

    Could you please explain how to switch CRT/HDMI configurations? On my pi4 (and also my pi 3 with an older build) after reboot i get the error I listed above - ES will not run - I seem to have no option but to wipe the sd card and start again...



  • @iainjh make sure you have /opt/retropie/configs.hdmi and /opt/retropie/configs.crt symlinks. if not, you are using an old version of the script, update my fork.

    basically, first time you use this feature (assuming you just installed my fork from scratch) it defaults to HDMI. you have to use the option to COPY THE HDMI CONFIGURATION OVER CRT (to have initially the same configuration for all), then you can freely switch between the two and the changes you make i.e. when using the HDMI configuration will not 'pollute' the CRT one.

    The option to MERGE the configurations are, indeed, to merge them. i.e. if you installed some emulators when in HDMI mode, you will miss such configuration in CRT mode so you can use the merge option to keep the /opt/retropie/configs.crt in sync.

    hope it clears everything :)



  • VALERINO - thanks, I'll have another go this weekend. I see one symlink to config.hdmi but ES still fails with unable to create /home/pi/.emulationstation on boot. I shall update and retry.

    Is there an option to NOT change anything? I dont want 2 folders crt or hdmi.

    Regardless, thanks again for your scripts, lots of fun being had. I shall add a few more. I already had bbc and electron working very well with advmame/mess before btw so if lr-mess breaks runcommand there is an alternative. One other thing I need do this weekend is find how to change the hotkey bindings.. my keyboard doesnt have a scrolllock for a start!

    cheers

    ROSLOF - thanks again for your GS guide!



  • Thanks for your new scriptmodules!

    Is it ok for add FM TOWNS (fmtowns/fmtmarty)? Of course MESS has incomplete emulation and cpu demanding for that system, but it's the only way to run FM TOWNS games in non-Windows and many games are playable.



  • @iainjh

    Is there an option to NOT change anything? I dont want 2 folders crt or hdmi.

    no, but shouldn't be needed. just don't use the crt/hdmi configuration menu and shouldn't make any difference.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.