Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Not able to login via SFTP after IP address change



  • Hi, first-time poster and recent RetroPie enthusiast here.

    I got a Raspberry Pi 3B with RetroPie about a week ago. Getting it set-up went very well, including connecting to my wifi network and transferring the first few ROMs from my pc (running Windows 8) via SFTP....

    However, sometime during the week I had to reset my router. Usually that's nothing special, but when I wanted to login to my RP again the next day I noticed it didn't work. I checked the IP address and noticed it had changed. I changed the address in my FTP client, assuming I could then continue transferring ROMs. Unfortunately, since that moment I can't login via SFTP, no matter what I try. I double checked the login details (but obviously only the IP address had changed), I rebooted my pc, the PI and the router, I tried different FTP clients, I tried some port forwarding options on my router, I created a rule in my firewall to open up port 22 (just in case), I updated all packages on the Pi.... It doesn't make any difference.

    Any idea what could be wrong? How could the change of the IP address mess things up? HELP! :-)


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.