Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Is a better framerate possible in eduke32 on Pi3B, or Pi4, using retropie?


  • I'm trying to run eduke32, but the framerate is too choppy... well under 30fps.

    I have a Pi 3 B, i'm running Retropie 4.6, and I made sure to update the setup script. I've tried changing to a lower resolution in-game, which causes an immediate crash when I try to 'apply settings'.

    I've tried editing the resolution in the .cfg file, but this causes a crash at launch.

    I've even tried pressing a button during startup, and chose a lower resolution video mode. This also causes a crash at launch.

    I've tried all the above steps on a Pi 4, and have the exact same results, with an identical low framerate. Is there any way to make the framerate... playable?

    Pi Model : 3B, and 4B
    Power Supply used: (Gizmo Junkies Pi3 Power supply 2.5a) (CanaKit 3.5a Pi 4 Power Supply with PiSwitch )
    RetroPie Version Used: 4.6
    Built From: (retropie-buster-4.6-rpi2_rpi3.img), and (retropie-buster-4.6-rpi4.img)
    USB Devices connected: none
    Controller used: 8bitdo sn30 pro
    Error messages received: none
    Emulator: eduke32


  • @vicviper001 I tested eduke32 right now on my pi4 at 1950Mhz and v3d at 750Mhz. I installed from source, if it matters. Seems to run fine here.
    1080p opengl = ~20fps
    1080p classic = ~60fps


  • @Darksavior Huh, that's interesting! Do you have any idea why GL is so much slower? I would have thought that with hardware acceleration it should be at least be on par with software rendering?

    I also ask because I see something similar with systemshock, which I have running on a RPi4 with the same frequencies as you have. GL is somewhat choppy and software rendering is smooth as it gets...


  • @ecto I'm not a developer so I don't know for sure. I don't know if eduke32 is openg es 3.1. I also doubt it's using the latest mesa drivers so there's another possible issue.


  • Figured it out, kinda.
    Turns out you have to edit the .cfg file, AND make sure you choose a video mode with matching screen resolution by pressing a button before the game starts.

    For instance, I edited the .cfg file to say 1280x720, and had to choose a video mode that was the same resolution. Unfortunately, 1280x720 is the smallest 16:9 option that displays properly without errors, and it runs at 30 FPS. It's at least playable I guess.

    Attempting to use a lower 16:9 setting such as 480x720, results in letterboxing, while 4:3 screen ratios cause item-pickup-messages and the bottom of the screen to be cut off.

  • administrators

    Afaik there isn't gles support. If GL is slower it will be because it's using non accelerated rendering. Which is likely the case. It shouldn't be enabled by default on the RPI also.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.