Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RGB COMMANDER



  • Hello, i am new to this. I have built a full cabinet with working buttons and joysticks and a bunch of different roms. the only thing i need help with is a program called RGBcommander ( http://users.telenet.be/rgbcommander/ ) it is a great idea for someone with a Pi and an Ultimarc I-PAC ULTIMATE I/O. its pretty similar to the program LEDBlinky but you don't need a computer.

    when i run the setup file everything clears until the end and it says "rgbcmdd is not running" then is says something like "symlink for mame error"
    I dont know what to do any help would be great!

    Thank you!



  • In order for RGBCommander to work, it’s necessary to use either MAME4ALL or AdvanceMAME. You’ll need to create a symbolic link (“symlink”) that points directly to your chosen emulator's binary. The binaries are located in their respective folders at /opt/retropie/emulators/. The instructions below are for MAME4ALL, which is what I’m using.

    First navigate to the rgbcommander folder:

    cd /etc/rgbcommander

    Then create a new directory called “mame”:

    sudo mkdir mame

    Next create symbolic link to the MAME4All binary:

    sudo ln -s /opt/retropie/emulators/mame4all/mame /etc/rgbcommander/mame

    You should now have a symlink called 'mame' in your newly created directory. To confirm this, type the following and make sure it’s there:

    ls /etc/rgbcommander/mame

    When this is completed, reboot your Pi:

    sudo reboot

    NOTE:
    Retropie comes installed with two versions of AdvanceMAME (v0.94.0 and v1.4), but I haven’t tested either of them with RGBCommander.
    If you’d like to make symlinks for these, substitute the third step with either:

    sudo ln -s /opt/retropie/emulators/advmame/0.94.0/bin/advmame /etc/rgbcommander/mame

    -OR-

    sudo ln -s /opt/retropie/emulators/advmame/1.4/bin/advmame /etc/rgbcommander/mame



  • @SloTayHolmes thank you so much! i will try this tonight or tomorrow, again thank you!

    I also read that this can be used on other emulators besides mame such as snes and others, but i could be wrong



  • @SloTayHolmes said in RGB COMMANDER:

    In order for RGBCommander to work, it’s necessary to use either MAME4ALL or AdvanceMAME. You’ll need to create a symbolic link (“symlink”) that points directly to your chosen emulator's binary. The binaries are located in their respective folders at /opt/retropie/emulators/. The instructions below are for MAME4ALL, which is what I’m using.

    First navigate to the rgbcommander folder:

    cd /etc/rgbcommander

    Then create a new directory called “mame”:

    sudo mkdir mame

    Next create symbolic link to the MAME4All binary:

    sudo ln -s /opt/retropie/emulators/mame4all/mame /etc/rgbcommander/mame

    You should now have a symlink called 'mame' in your newly created directory. To confirm this, type the following and make sure it’s there:

    ls /etc/rgbcommander/mame

    When this is completed, reboot your Pi:

    sudo reboot

    NOTE:
    Retropie comes installed with two versions of AdvanceMAME (v0.94.0 and v1.4), but I haven’t tested either of them with RGBCommander.
    If you’d like to make symlinks for these, substitute the third step with either:

    sudo ln -s /opt/retropie/emulators/advmame/0.94.0/bin/advmame /etc/rgbcommander/mame

    -OR-

    sudo ln -s /opt/retropie/emulators/advmame/1.4/bin/advmame /etc/rgbcommander/mame

    no such luck sadly, i am just not sure what i am doing wrong, i even deleted my retropie image and reinstalled it. Now i have the same problem i had before i had to worry about symlink.

    i run the program and the runs setup.sh as root and asl tried using chmod+x and still nothign everything is not allowing acess to the foldes.

    n



  • root@retropie:/home/pi# /setup.sh install

    RGBcommander installing

    rgbcmd->/usr/bin ERROR
    chmod: cannot access ‘/usr/bin/rgbcmd’: No such file or directory

    rgbcmdd->/usr/sbin ERROR
    chmod: cannot access ‘/usr/sbin/rgbcmdd’: No such file or directory

    21-ultimarc.rules->/etc/udev/rules.d ERROR
    chmod: cannot access ‘/etc/udev/rules.d/21-ultimarc.rules’: No such file or directory

    rgbcommander->/etc ERROR
    chmod: cannot access ‘/etc/rgbcommander’: No such file or directory

    rgbcmdd->/etc/init.d ERROR
    chmod: cannot access ‘/etc/init.d/rgbcmdd’: No such file or directory

    chmod: cannot access ‘/etc/init.d/rgbcmdd’: No such file or directory

    update-rc.d: error: initscript does not exist: /etc/init.d/rgbcmdd
    /setup.sh: line 48: /etc/init.d/rgbcmdd: No such file or directory

    seeking MAME binary.. symlinking -> ERROR



  • @SloTayHolmes It worked 100% thank you! now the only thing i need help with is the .xml file to configure the leds. I set all the rights led pins on the rgbcmdd.xml file but everything still just flashes



  • @kcc406 I’m only using RGBCommander to change between 4/8 way setting on my Ultimarc ServoStik, so I'm not using the LED control features. With that disclaimer aside, I think these ideas might help:

    1. Test to see if RGBCommander is talking to your LED’s. If <lwaxonstart> is currently set to “RANDOM” in your rgbcmdd.xml, then try the other settings and see what happens, i.e., replace lwaxonstart=“RANDOM” with lwaxonstart=“OFF” (or another pre-defined pattern). Similar options also appear in the <emulators> section. If nothing is specified when you launch an emulator, or if RGBCommander can’t tell which emulator it is, then I believe it’ll default to “RANDOM” as well.

    2. If you’re using Mame4All/AdvanceMame and want the LED’s to light up according to the specific rom you load, you’ll need to use “legacy mode” in RGBCommander. Basically, this tells RGBCommander which rom you’ll be loading before the rom actually loads. Here’s how I got this working:

    By default, the rgbcmdd.xml has an <!--sdlMAME--> entry under <emulators>. We’ll be modifying this entry. First, replace <!--sdlMAME--> with <!--Mame4All--> (or AdvanceMame if that’s what you're using). Most importantly, make sure that emulator binary=“mame” is listed underneath (it should already be there by default but check anyway). In this example, we’ll be testing the Donkey Kong rom, so make sure that “dkong.zip” rom is in the appropriate rom folder. After these changes are made, reboot your Pi. To see if legacy mode is working, first open a terminal shell from a separate computer, then type “rgbcmd setlegacy,dkong” (without the quotes) and hit return. Next launch the Donkey Kong rom from EmulationStation. If everything worked correctly, your LED’s should now be set according to what’s listed under <rom id="dkong"> on the rgbcmdd.xml. Test with some other roms and make sure the result is the same. NOTE: This is only a manual test. For the changes to happen automatically when launching different roms, I needed to write a shell script and made various changes to the cfg’s. I’ve posted instructions for my Mame4All setup at the link below.

    http://pastebin.com/FeS3XYAY

    1. It’s possible to use emulators other than MAME, such as SNES etc, but I haven’t tested thoroughly. Note that RGBCommander doesn’t play nicely with the RetroArch emulators (any emulator with “lr-“ in front). It’s designed to work primarily with stand-alone binary emulators. Many of these come pre-installed with Retropie and can be chosen as default emulator for your given system.

    IMPORTANT: On rgbcmdd.xml, the process name for your chosen emulator needs to be indicated where it says <emulator binary=“”>, even if the binary itself is called something different. Think of it this way: emulator binary=“<process name for your emulator>”. To find out the process name, first launch the emulator. Then, with the emulator still running, ssh from a separate computer and enter terminal commands using the instructions here:

    http://www.cyberciti.biz/faq/show-all-running-processes-in-linux/

    Another note regarding RetroArch: I’m able to use RetroArch emulator to switch my joystick, but it’s limited. RGBCommander only recognizes the process name (“retroarch”) and it doesn’t differentiate between the different cores. So in your case, it might not be possible to customize the LED’s per system using RetroArch. I tried some cfg changes to make RetroArch recognize the cores and they didn’t work correctly, even with the kind help from the developer. This is how it behaved for me, but definitely play around and see what happens for you. And if you learn anything, please let me know!

    Lastly, it might be helpful to study the video on the developer’s website — it shows various examples of the LED control and has the corresponding code displayed along side it. This helped me learn the program better and it may help you too. Good luck man!


  • administrators

    @kcc406 please don't remove your posts, even if you resolve the issue - especially when people reply to your previous posts - it breaks the discussion.



  • after lurking for ages, I finally registered an account mostly to say THANK YOU to @SloTayHolmes.

    I have had RGBCommander working with my LEDs for awhile—controlling animations and even doing some default button-illuminations, but ROM-specific settings has simply eluded me. These instructions are perfect, and more than i ever could have figured out on my own. Thank you very much. I will implement this all later, and i look foreward to sharing pictures.

    Also, thanks to @kcc406 for posting his problem in the first place.

    you guys are all fantastic.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.