Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Mystical Ninja Starring Goeman on N64 - has anyone had any joy with this on Pi4?



  • Pi Model or other hardware: Pi4
    Power Supply used: Pi Standard
    RetroPie Version Used: 4.6
    Built From: RetroPie website image

    Has anyone tried to emulate Mystical Ninja Starring Goeman on N64? I have tried various emulators with different settings but haven't managed to make it playable as yet (although it isn't too far away on Mupen64plus Gliden64). As there is a new version of lr-mupen64plus-next, I have just tried to mess about with settings in that. I only managed to make it better, not worse - but it did change things!

    I wonder if anyone more savvy than me can get this working. You folks love a challenge. :p

    The problem seems to be to do with the sky in the game, indoor scenarios are fine but as soon as you are outside, there is a problem.



  • @AdamBeGood said in Mystical Ninja Starring Goeman on N64 - has anyone had any joy with this on Pi4?:

    The problem seems to be to do with the sky in the game, indoor scenarios are fine but as soon as you are outside, there is a problem.

    What is the problem specifically? Game seems to run slow for me but I didn't notice anything wrong with the sky. However I'm not familiar with this game so maybe I didn't notice the problem?



  • @quicksilver Yeah, running very slowly - visually and sound too. Nothing looks wrong with the sky, but it is just when the sky is visible that the game slows. For example, the room you start it runs pretty smoothly but as soon as you go outside it gets choppy.



  • @AdamBeGood actually it isn't the sky causing the slowdown. It seems to be when the camera is moving. If you stop moving your character the camera will stop rotating and the game becomes fullspeed. Unfortunately no combination of settings I tried made the game run smoothly using gliden64. I did briefly test the gles2rice plugin and the slowdown isn't an issue with this plugin, there where a few small graphical issues but nothing major that I noticed (could be issues further in though, idk)



  • @AdamBeGood this is one of those games that always seems to have issues on emulators. Even when I try and play this on my desktop PC it'll run into problems unless you're using an old Project64 emulator. Whenever you try and play this on anything retroarch related the cores don't seem to have whatever hack tricks that make the game run how it did on the original hardware.

    Shame as it's a wild game that is a hidden gem of the n64 imo.



  • @quicksilver Mine is still choppy on gles2rice - have you changed any settings in yours? Lowered the resolution or anything like that? The only thing I've done with gles2rice is change one of the video options in the Config file to "7" as that helps with Pilotwings (I forget which option, something to do with Refresh maybe but I'm sure you know what I mean).

    @retropieuser555 I've heard that, but it doesn't seem that far from working on my Pi now so just wondered if anyone had any fiddles to make it a little bit better. I really don't want perfection at all!



  • @AdamBeGood the game is fullspeed for me with gles2rice. I am also using screen update mode 7. I also changed the video mode for gles2rice in the runcommand menu to 640x480 (to reduce upscaling overhead) and I'm overclocked.

    Edit: tested without overclock and at 1080p and game is still fullspeed. Just to confirm you are using a pi 4 correct? When was the last time you updated mupen64plus from source?



  • @quicksilver My mupen64plus was installed from binary in maybe early May or late April, let me install from Source now. Will I need to change my settings again (ie for the screen update mode for gles2rice)?

    And yep, overclocked Pi4.



  • @AdamBeGood said in Mystical Ninja Starring Goeman on N64 - has anyone had any joy with this on Pi4?:

    Will I need to change my settings again (ie for the screen update mode for gles2rice)

    No you shouldn't have to.



  • @quicksilver Nope still the same, if maybe slightly better. I tried to send you a video but I don't have the privileges apparently. As soon as I step outside the music goes much slower, although when I stop moving it is fine.



  • @AdamBeGood you are for sure using gles2rice? Can you post your mupen64plus.cfg? And your overclock settings? When was the last time you ran a

    sudo apt update
    sudo apt full-upgrade
    

    Edit: you aren't running in 4k mode are you?



  • @quicksilver Yep, defo gles2rice. I did have the 4k enable set in config (someone said it worked as an Overclock setting), but I've taken that out now and done the sudo apt full-upgrade.

    Overclock is now:

    '''
    over_voltage=6

    arm_freq=2095

    h264_freq=750

    isp_freq=750

    v3d_freq=830
    '''

    Just getting you the config for mupen64plus now.

    Edit: https://pastebin.com/J1SnnUpY



  • @AdamBeGood you have frameskip turned on in the gles2rice settings in your mupen64plus.cfg.

    Change to

    SkipFrame = False
    


  • @quicksilver Okay, cool. I've just got to pop out but I'll try this when I'm back. Thank you!



  • @AdamBeGood and just as a side note you don't need these overclock settings:

    h264_freq=750
    isp_freq=750
    

    It likely won't hurt anything since they won't be used but there is also no reason to overclock them in the first place. You can see for yourself by running a game then checking the current frequency of the ISP or h264 block by running
    vcgencmd measure_clock isp (or replace isp with h264) the frequency will be reported back as 0


  • Global Moderator

    @quicksilver I found that a nice script to monitor various Pi clocks and temperature is bcmstats. You can leave it started in a SSH session while testing the performance of your system.



  • @mitu oh neat! I'll definitely check this out, thanks.



  • @quicksilver I've changed the FrameSkip now (and taken the pointless overclock values out), but I still don't see any improvement. Thanks for the advice on those anyway, I am sure they have made things better marginally, but certainly not noticeably with Goeman.

    Does yours really run smoothly? If you enter the game and then take the character immediately outside, the game does not choke up? I can't believe it!



  • @AdamBeGood said in Mystical Ninja Starring Goeman on N64 - has anyone had any joy with this on Pi4?:

    Does yours really run smoothly? If you enter the game and then take the character immediately outside, the game does not choke up? I can't believe it!

    No noticable slowdown whatsoever. I actually played until I got to the top of mt. Fuji. I'll double check your mupen64plus.cfg again to see if there are any other settings that may be different between us. Can you also check what your current video mode is in the runcommand menu?

    Edit:
    Only other difference I see in the gles2rice section of your mupen64plus.cfg is the texture enhancement filter setting. Try changing

    TextureEnhancement = 6
    

    To

    TextureEnhancement = 0
    


  • @quicksilver Everytime I change something I am so optimistic that it is going the game is going to run fine, but it hasn't yet. Still very slow whenever the camera moves outside.

    Here is the video option (I'm having trouble with uploading a screenshot) - "640 x 480 @60Hz 4:3 (25.18 MHz, nhsync, nvsync, driver)"

    This is so confusing, there must be some difference between our two systems. I am glad the game can run on a Pi okay though, that is positive.

    Edit: Could you post your muben64plus config and I will copy that wholesale - that will eliminate any possible differences caused by that?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.