Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hi everyone. I finally got round to playing Super Metroid last night but encountered a super annoying function of retroarch's hotkeys. Save state functions seem to be bound to Select + Left Trigger or a configuration similar. As I was playing the game, I accidentally pushed a combination which loaded a save state! I didn't even know I'd made one either!? I don't use save states, only in game ones. Needless to say I lost about 2 hours play time which was.... frustrating to say the least!

    Can these hotkey combinations be turned off? The fact that they overwrite the actual game's saves is insanely annoying. Anyone who knows Metroid will know that pressing Select (which toggles weapons) and a Trigger (which angles your aim) is a prerequisite. Alternatively can I simply not make a save state? How do I even know if I've created one? The Quick Menu says under "State Slot" 0 which to me reads as no state slots, yet I know there's one because I got taken back to it!

    Basically I'd just prefer the whole save state function walled off, is this possible?

    Any help much appreciated.


  • @gizmo90
    The save states are numbered starting from 0, so you have stave state 0, 1, 2, and so forth.
    I don’t know if there is a way to turn off the save states, but you can disable the relative key or button bindings in retroarch menu by going in Main Menu -> Settings -> User Interfaceand set Show Advanced Settings to ON. Then go to Main Menu -> Settings -> Input
    and set Autoconfig to OFF. Save the configuration and quit Retroarch.
    Relaunch the game, open the Retroarch menu and go to
    Main Menu -> Settings -> Input -> Hotkey Binds.
    Scroll down to the save state and load state bindings and press the Y button on your gamepad to unbind them.
    Alternatively you can use the retroachievements hardcore mode that should disable save states.

  • Global Moderator

    @gizmo90 said in Turn off save states?:

    Basically I'd just prefer the whole save state function walled off, is this possible?

    Yes, just open your controller configuration file in \\retropie\configs\all\retroarch-joypads and comment out (adding an # at the beginning of the lie)/remove the lines that configure the save/load state.

    input_load_state_btn=Y
    input_save_state_btn=Z
    

    If you re-configure your controller in EmulationStation, then you'll have to re-modify the .cfg file and remove/comment out again the lines, since they'll be automatically added.


  • Thanks for the replies everyone. @mitu Could you tell me how I get to that folder? I keep forgetting how to navigate my way around Raspbian. Basically my prompt says pi@retropie and listing the current folder I have the following,
    RetroPie
    RetroPie-Setup
    Neither of these contains a configs folder. I'm sure I'm missing some way to move up on the folder structure. Could someone give me some quick pointers?

  • Global Moderator

    The path I mentioned \\retropie\configs\all is accessible via File Shares, so you can edit the file from any PC you have connected.

    If you wish to edit it from your RetroPie, replace \\retropie\configs with /opt/retropie - the .cfg file should be in /opt/retropie/configs/all/retroarch-joypads.


  • @mitu said in Turn off save states?:

    File Shares

    Thanks for that @mitu I've logged in via my pc and file share. Unfortunately I can't access the retroarch-joypads folder?
    I'm told it's not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Directory name is invalid.

    Any idea why I've not got permission? I can enter every other folder except that one!?

  • Global Moderator

    \\retropie\configs\all\retroarch-joypads is a symlink to \\retropie\configs\all\retroarch\autoconfig, that's probably why you get the error (?). Try the 2nd location or just access the file from the terminal, at the location I mentioned in the previous post.


  • The "Save State 0" is the "position" of the save slot. You can have more than one save state per ROM. I don't know about "walling off the functionality", BUT you set select to be the hotkey when you mapped your controls...or at least didn't assign it to something other than the default.

    You can see if a save state exists in the ROMs directory. (although I'm not sure if you can set another save location.) In the screenshot below you can see the Drill Dozer save state (Drill Dozer.state) next to the ROM (Drill Dozer.gba).

    3298172d-800a-4077-af27-859c79d26f59-image.png


  • Thanks everyone.

    @mitu That did it! The file was in autoconfig called Arduino LLC Arduino Leonardo.cfg

    Now when I push Select and Trigger nothing happens. Phew! :)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.